Problem installing Peppermint 7

Hi Mark,
I have copied the files I want to keep to a spare USB pen drive.
I have written the Peppermint 7 pen drive and I have tried to install Pep 7 but I haven’t been able to get past the ‘Machine Check Error’ message that flashes up.
Where have I gone wrong ?

Have you tried disabling secureboot in the BIOS ?

is it Peppermint 7 64bit ?

is there a setting in the BIOS for “Virtualisation” ? … if so, have you tried disabling it ?

Hi all,
This isnt to do with pendrive, but its about a problem I had.

I downloaded the iso, checked it was ok as per instructions, everything fine. I loaded it as a live disk, everything loads as per normal. Next thing to do is install it onto the hard disk. Installed ok, so now to reboot. Rebooted and when it loaded there was no bottom panel. After a bit of searching (on the other, older laptop), I came across this thread:

https://forum.peppermintos.com/index.php/topic,3712.0.html

Which seemed to be my problem. So after following all the instructions and rebooting the bottom panel was now the top panel and was quite a bit different also. Confused I decided to re-install Pepper 6 from a backup, when it finally loaded it was the same as Pepper 7, no bottom panel etc. I then realised what my problem might be, when installing Pepper 7 I didn`t format the /home partition. So re-installed Pepper 7 again while formatting the home partition and everything was perfect.

I have to say well done to Mark & all the other people who worked on Pepper 7, it`s working brilliantly. Top marks to all concerned. This is just for information of what happened to me.
Tony

Hi Mark,
I can’t see a setting for ‘Virtualisation’.
I have altered the BIOS settings to
OS Select [Windows 8]
UEFI Boot [Disabled]
I have started the machine up twice now with these settings and by using F7 to change to ‘Boot from USB Drive’. It boots into the pen drive ok and gives a beep and displays the ‘Installer boot menu’. The first option ‘Try Peppermint 7 Live OS’ gives a good look at the new opening screen with ‘Install Peppermint 7’ in the top left and ‘WiFi Networks are available’ in the top right of a nice seaside sunset.

take care
Don W

Okay, do what you just did and select “Try Peppermint”

When at the desktop double click the “install Peppermint” icon on the desktop

When asked on this screen


As long as your intention is to ONLY have Peppermint 7, and you’ve copied off any files you need, select “erase disk and install Peppermint”

the installer will walk you through the installation

See here for other pics
http://www.everydaylinuxuser.com/2016/06/an-everyday-linux-user-review-of_28.html

Thanks Mark,
Some real good stuff there, I think the newbies who are thinking of changing to Peppermint should have a look at 'everydaylinuxuser.com.
(I am thinking of Ed here,in the first post in the first forum), that is a well written article.
I will start this with a fresh mind tomorrow.

take care
Don W

Yeah it nicely shows what to expect from the installation process … the pics can all be clicked for larger versions :slight_smile:

Hi Mark,
I have spent time over the last 2 days trying to install Peppermint 7 on this computer to no avail.
I have tried every combination in the BIOS that I can but do not get a reliable boot into the pen drive.
It looks like a reliability problem but I dunno. I am very busy and find this annoying that I can’t install Pep 7. I have never had this problem before and it is getting me down. I will go through the BIOS options again but it takes a while to shut down and reboot so it may be a while before I get back.

I thought you’d managed to boot the LiveUSB ?

Have you tried

a) checking the md5 hash of the Peppermint ISO you downloaded to check it’s not corrupt ?

b) using a different LiveUSB creation tool ?

c) using a different USB stick ?

d) simply burning a LiveDVD instead of using a USB stick ?

Yes Mark,
I had the pen drive boot twice with a certain setting. I have tried the same BIOS setting and it doesn’t boot.
I am confused by this as I had to try a lot of BIOS settings to get the pen drive to boot.

I have ran the md5 checksum and it is ok.
I will try another pen drive.

thanks
Don W

Hi Mark,
I made a boot disc in Brasero but it tool so long to work I abandoned it, but it did work and when I checked the BIOS settings I used the same bios settings for the pen drive and it worked.
I am writing this in my new Pep 7 installation :wink:

I liked the last page of the installation (Enjoy) It says ‘We are always looking for talent and if you are interested in joining us, drop us a line’ Well I am dropping the line as I feel I could fill the role of idiot, as in ‘idiot proof’. I think I am capable of destroying the best of systems and undoing tons of work. ::slight_smile: ::slight_smile:

take care
Don W
PS I chose the ‘erase disc and install peppermint’ option. Only problem I met wasa screen that said I was using a boot from another system (or something)and did I want to force UEFI ?? I just clicked ‘continue’ and it continued, no problem so far.

Hi Mark,
When I open ‘Office’ I see the Libre Office icon and click on that. When it opens I can only get ‘Math’ to respond. I can’t open Writer, Base or Calc.
Where have I gone wrong.?? again
Should I download and install the complete Libre Office suite ?

I have found a file called rtlwifi-lwfinger is this still needed ?
EDIT Added a bit

how did you install libreoffice ?

can you post the output from:

dpkg -l | grep libre

Hi Mark,
I didn’t install Libre Office.
From the Menu I chose ‘Office’ and it opened with an icon for Libre Office. When I click on that it says Libre Office 5 and opens a page with buttons for Writer etc. but when you click on them nothing happens.

don@ldwatson ~ $ dpkg -l | grep libre
ii libdjvulibre-text 3.5.27.1-5 all Linguistic support files for libdjvulibre
ii libdjvulibre21:amd64 3.5.27.1-5 amd64 Runtime support for the DjVu image format
ii libreadline5:amd64 5.2+dfsg-3build1 amd64 GNU readline and history libraries, run-time libraries
ii libreadline6:amd64 6.3-8ubuntu2 amd64 GNU readline and history libraries, run-time libraries
ii libreoffice-base-core 1:5.1.4-0ubuntu1 amd64 office productivity suite – shared library
rc libreoffice-calc 1:5.1.4-0ubuntu1 amd64 office productivity suite – spreadsheet
ii libreoffice-common 1:5.1.4-0ubuntu1 all office productivity suite – arch-independent files
ii libreoffice-core 1:5.1.4-0ubuntu1 amd64 office productivity suite – arch-dependent files
ii libreoffice-math 1:5.1.4-0ubuntu1 amd64 office productivity suite – equation editor
ii libreoffice-style-elementary 1:5.1.4-0ubuntu1 all office productivity suite – Elementary symbol style
ii libreoffice-style-galaxy 1:5.1.4-0ubuntu1 all office productivity suite – Galaxy (Default) symbol style
rc libreoffice-writer 1:5.1.4-0ubuntu1 amd64 office productivity suite – word processor
ii libresid-builder0c2a 2.1.1-14ubuntu2 amd64 SID chip emulation class based on resid
ii librest-0.7-0:amd64 0.7.93-1 amd64 REST service access library
ii librevenge-0.0-0:amd64 0.0.4-4ubuntu1 amd64 Base Library for writing document interface filters
don@ldwatson ~ $

It looks like calc and writer is removed (but left the configuration files)

rc libreoffice-calc rc libreoffice-writer

Try re-installing them

sudo apt-get install libreoffice-calc libreoffice-writer

Erm Peppermint 7 doesn’t come with LibreOffice AT ALL … so you MUST have installed it.

If I were you I’d reinstall the whole thing

sudo apt-get install --reinstall libre-office

Thanks Mark,
I am happy now. Libre Office is working :smiley:
@ SeZo, Thanks for the advice. All is now well :wink:

take care
Don W
I think I will mark this thread solved as I seemed to have strayed from the original topic.