Problem since installing Dual Boot (SOLVED)

Hi Guys,
Last week I installed Peppermint 6 onto my Dell Inspiron 6400 Laptop alongside Ubuntu 14.04, have been using Peppermint 6 with no problems ever since, however, today I tried to boot up Ubuntu and though it booted to the pinky coloured start screen with the password entry box, once i entered my password thennothing else happened, it just stayed stuck on that screen. Have rebooted and when I came to the same screen have used a guest account and this boots up fully into the system, this is where I am typing this query from now.
Any advice on why this might be happening would be greatly appreciated, many thanks in advance,
Note the Ubuntu was previously installed and was working fine up till the dual boot.

Regards,
Degsy

It is possible that some files (could be unrelated to dual booting) got corrupted in your profile.
Try running a file system check while in your guest account:
use this key combination
ctrl+alt+F1
which will start TTY where you will be prompted to log in.
Login with your normal user name and password, then

sudo touch /forcefsck

then reboot

reboot

Hi Sezo,
Many thanks for your suggestion, tried that but no change, still unable to boot into my regular account, still OK with guest account and, Peppermint 6 boots fine.

Degsy

When you get to the Ubuntu login screen, hit Ctrl+Al+F3, log in in text mode, then run:

sudo service lightdm restart

which should start the desktop … I’m guessing it won’t … but it might return a clue as to why (?).

You didn’t share a /home directory between the 2 OS’s did you ?

Hi Mark,
Tried your suggestion but it didnt take me to the desktop, just back to the log in screen, if I enter my password then nothing seems to happen, sometimes the cursor is stuck other times it does move but no responses.
I am not aware that I shared home directory, I just ran the live DVD then installed with the option install alongside Ubuntu, I did slightly enlarge the partition that Peppermint was being allocated. Is there a way to check if I have shared a folder without realising, as things that are daft or stupid I find remarkably easy to do.

Thanks again for your help,

Degsy.

HI Mark,
Just remembered I did go through a Tutorial from Peppermint Forum called “Sharing folders over a network - Peppermint5”, copuld I have caused this problem when using this tutorial, because of my ignorance of what I was doing?

Degsy

Maybe…

Can you point me at the tutorial ?

I have a feeling you’ve changed the permissions of some config file in your home folder

What happens if you (from the login screen) hit Ctrl+Alt+F3 … log in in text mode … then run:

mv -v ~/.Xauthority ~/.Xauthority-old

then

sudo service lightdm restart

Hi Mark,
Thanks for your reply, first of all, carried out your advice, but it just returned me to the Log in screen with my password prompt and returned to this after each password entry.
The Tutorial I was referring to is in the “User Submitted Tutorials” section of the Peppermint Forum, on page 2 about 2/3 the way down entitled “Sharing folders over a network-Peppermint 5” started by 10i.

Regards,
Degsy

Okay, we could spend forever trying to figure out what’s in your home folder that’s stopping X from starting properly for the current user.

Can you confirm you can log into the “Guest” account … and if you can, how do you feel about

a) creating another account
b) making sure it has the same permissions as the first
c) moving all your user docs across to the new account
d) deleting the broken account

If you’re okay with this plan, I’ll post instruction.

First confirm you can log into the guest account

then log inas your regular user in text mode, then post the output from:

groups

HI Mark,
First, yes I can log into the Guest account.
Here is the result of groups
derek adm cdrom sudo dip plugdev lpadmin sambashare

Quite happy to go along with the idea of creating a new user account, so yes please post the instructions for me to do so, totally agree no point wasting time searching for a needle in a haystack, lets just get a solution.

Many thanks,
Degsy

Those CANT be all the groups the regular account belongs to ? … did you run:

groups

from the Guest account ?

You need to (at the login screen, hit Ctrl+Alt+F3 … log in to your regular account in text mode … then run:

groups

Hi, not sure what I am doing wrong here but this is what I just did:
Boot up, went to Guest account, screen came up To log in, hit log in, booted into Guest account, hit Ctrl, Alt, F3, into text mode, logged in with name and password, then entered groups and hot return, the output came up again exactly as I typed in my previous answer.
Sorry if I am doing something stupid but that is how I have interpreted the instructions.
If at the guest log in screen I hit Ctrl,Alt, F3 anted then log in I get exactly the same answer as above.

Degsy.

Not sure if this is relevant but if I boot to Peppermint 6 and then Ctrl,Alt, F3 and groups , I also get the same answer.

Degsy

Sorry mate, I missed the “sudo” group … I must be going blind :o

I’ll post instructions to create a new account in a bit.

Hi Mark,
No problem, will await your instructions.

Degsy

How to create a new user account (including creating the home folder) for the username “degsy” and add to the same groups as the original account

Boot to the login screen, hit Ctrl+Alt+F3, and log into the “derek” account in text mode … then run

sudo useradd -s /bin/bash -m degsy -G adm,cdrom,sudo,dip,plugdev,lpadmin,sambashare

then to set the password for the newly created “degsy” account, run:

sudo passwd degsy

and enter the password … it will prompt you for it a second time … you’ll then be informed the password was successfully set.

Now hit Ctrl+Alt+F7 to return to the login screen, and log into the “degsy” account.

Hi Mark,
Carried out the instructions, got the new degsy account on log in screen above Derek and Guest session but when I click it and enter password I selected for it , the screen returns to the log in screen. I can still log into the Guest session however.
Have tried a reboot but still the same. Did get the message password successfully set so don’t know what is happening now.

Degsy

From the Ctrl+Alt+F3 text console, try signing in as derek (or degsy) and run:

sudo dpkg-reconfigure lightdm

then

sudo service lightdm restart

can you log in now ?

Sorry to say, still not letting me log in.

Degsy

Have you got a liveCD/LiveUSB ?

If so, boot to it and post the output from:

sudo fdisk -l