Problem with 14.04 (Solved)

Hi Guys,
I have a desktop(self build) that was originally running 12.04 LTS, I have installed peppermint 5 to run alongside this with out any problems. I decided to upgrade from 12.04 to 14.04, the upgrade seemed to go alright except that now the computer “locks up” on booting to Ubuntu 14.04.
On switch on I am offered the choices for Ubuntu or Peppermint 5, if I choose Peppermint the computer boots up and I have no problem.
If I choose Ubuntu, then the computer boots up as normal, goes to the password entry screen, as normal, I enter password and then the boot up fails, I have had a blank type screen with Ubuntu 14.04 LTS in the bottom left corner but nothing else and no mouse or keyboard. If I press the reset button the computer reboots, offers me the options again, choose Ubuntu and got to the password screen, this time loaded the desktop but with the following message in the top left corner:
System program problem detected
Do you want to report the problem now?
Cancel Report Problem

No mouse or keyboard operating.
Any help would be appreciated.
Please note I have tried loading Ubuntu 14.04 from a CD and get the same problem, though the disk is fine as I have loaded 14.04 onto a Laptop from the same disk.



When you get to the password screen, can you drop to a terminal with Ctrl-Alt-F1?

If you can, try to login to the terminal with your username and password, then run:

sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot

This will fully update your system, then reboot it. Try to load Ubuntu again and post results back here (including if you got any errors in the terminal)

Ok, thanks Chemicalfan, did as you suggested, did not see any errors reported in Terminal but on reboot still same, no mouse or keyboard activity with error message as before in top left of screen, then screen went black… Reset and rebooted to Peppermint 5, no probs still with that.
Any other suggestions please.
Ps learned something anyway as wasn’t aware could get to a Terminal like that, so thanks too for that info.


Ok, we need to go back into the terminal, and after logging in, note down the result of:

cat /var/log/Xorg.0.log|grep "EE"

Also, from Peppermint, can you post up the output of:

sudo lsblk

Slightly nervous of how this dual boot has been set up

How do I get the symbol between log and grep to display, please?


Ok found that, will report back shortly.


Ok here is the output, first from Peppermint:

sda 8:0 0 149.1G 0 disk
├─sda1 8:1 0 94.8G 0 part
├─sda2 8:2 0 1K 0 part
├─sda5 8:5 0 1.8G 0 part [SWAP]
└─sda6 8:6 0 52.5G 0 part /
sr0 11:0 1 1024M 0 rom

now for the other one;
cat /var/log/Xorg.0.log|grep “EE”
(ww) warning, (EE) error, (NI) not implemented, (??) unknown
[ 23.569] Initializing built-in extension MIT-SCREEN-SAVER
[ 23.848] (EE) Failed to load module “nvidia” (module does not exist, 0)
[ 23.880] (EE) Failed to load module “nvidia” (module does not exist, 0)

Hope this means something.

Thanks again for your help,


Ugh, so it looks like Peppermint & Ubuntu are sharing a partition, unless I’m mistaken?

The second output was from Ubuntu, right?

Hi, yes the second output was from Ubuntu.
The desktop originally ran only 12.04 LTS, then I installed Peppermint 5, I used a Cd that I had prepared for the installation and chose (from memory) install alongside Ubuntu. The two (12.04 and Peppermint) ran happily alongside each other with no problem until the update to 14.04.
I am offered other options from the boot up screen, including Advanced options for Ubuntu if that is any help.


It’s possible there’s a conflict somewhere between the two, so I’d like to make sure of the situation.

From Peppermint (for ease), please can you post up the output from:

sudo fdisk -l

Hi, here is the output from Peppermint
derek@derek-System-Product-Name ~ $ sudo fdisk -l
[sudo] password for derek:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002e2d3

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 198829040 99413496+ 83 Linux
/dev/sda2 198830078 312580095 56875009 5 Extended
/dev/sda5 308914176 312580095 1832960 82 Linux swap / Solaris
/dev/sda6 198830080 308914175 55042048 83 Linux

Partition table entries are not in disk order


Was this output from the Ubuntu command line ?

cat /var/log/Xorg.0.log|grep "EE" (ww) warning, (EE) error, (NI) not implemented, (??) unknown [ 23.569] Initializing built-in extension MIT-SCREEN-SAVER [ 23.848] (EE) Failed to load module "nvidia" (module does not exist, 0) [ 23.880] (EE) Failed to load module "nvidia" (module does not exist, 0)

Hi Mark,
Yes that was taken from the Terminal in Ubuntu.
Obviously it means nothing to me.


could I hazard a guess and say a graphic driver problem?

It’s possible…you could try removing the nvidia driver from Ubuntu from the terminal.

dpkg -l '*nvidia*'

Will give you the package names (depends on which version of the nvidia driver you have)

Post up that result, then I’ll post back the removal syntax :slight_smile:

Edit: Scrub this, follow Mark below…

From the Ubuntu console, try running:

sudo apt-get remove --purge nvidia*

then (if exists) rename xorg.conf

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.old

then reboot

sudo shutdown -r now

Hi Guys,
Followed Mark’s instructions, after the second command the reply was " no such file or directory"
After the last command the system rebooted to a screen with just Ubuntu 14.04 LTS in the bottom left corner, the mouse cursor was present. After a couple of minutes the screen went black and the mouse cursor has frozen.

What next?


Hmm, what’s the output from:

locate xorg.conf

Hi here is the output:
/use/share/X11/xorg.conf.d/11-em dev-track point.conf
Hope this is helpful


Don’t know if this is of any relevance but if I go to Ubuntu advanced options select that then the recovery mode option, after a lot of writing on the screen it says resume normal boot, click this and the system does boot though it still shows the error in the top left that I mentioned in an earlier post.


Do you mean the system is fully functional, or does it still black screen & lock up?