Problem with Kingsoft Office (Solved)

Hi Mark,
I have installed Kingsoft Office and when I open any of the 3 programmes it produces the same error message.

Some formula symbols might not be displayed correctly due to missing …Resolution
Can you help ?

Don W

Try this -

Open a terminal and run these commands in sequence:

sudo mkdir -p /usr/share/fonts/wps-office


cd /usr/share/fonts/wps-office

then (to download the missing fonts from my dropbox):

sudo wget


sudo unzip

and answer “A” if prompted … then:

sudo fc-cache -vf

Now see if Kingsoft Office still moans about the missing “symbols” font.

Thanks Mark,
That worked

You’re welcome :slight_smile:

I want rid of Kingsoft Office, I am disappointed with the interface and I can’'t read the mail I create.
How do I get rid ?

If you want to remove any program use the apt-get remove command followed by the name of the program you wish to remove

You would need to do this in root so the command would be

sudo apt-get remove --purge kingsoft-office

that should completely remove the application including any configuration files assigned to the application if you want to leave these files intact on your system miss out the “–purge” parameter

so the command would just be

sudo apt-get remove kingsoft-office 

if that fails with a "cannot find package " error try replacing the kingsoft-office with wps-office

Good luck


Thanks Emegra,
The deed is done.
I would rather use Libre Office.
EDIT I will mark this solved

Why wouldn’t you like the interface ?

Here’s how I’ve set Kingsoft Writer to open

What’s not to like ?

That interface is spooky

No “borrowing” from Microsoft going on here…

Then again, MS probably “borrowed” it from Wordperfect and Lotus … so who cares right ?

I feel a lot happier working with Libre Office. I thought there was too much going on in Kingsoft.
Thanks for the help

Don W