Problem with Openshot Help needed (SOLVED)

Hi Mark,
I have a problem with Openshot, it has stopped working again.
I was adding video clips to the timeline and the screen froze.
The mouse can move but I can’t click on anything.
I tried Ctrl+Alt,F1 to get to a terminal.
I then used sudo top which gives me a list of processes with the openshot application at the top.
I can’t seem to get anywhere after that as exit doesn’t work, there is no prompt at the bottom of the list.
I have used the Alt+Ctrl,F3 you suggested and now have a prompt ~ $
What can I try now ?
EDIT I have solved the problem (I think)
When I did the Alt+Ctrl,F3, I used sudo kill -9 5190(the number in the shotwell line) and the exit, and I was back at the desktop.
I hope I haven’t upset anything by doing this, but I will car I am making up the digital pictures into a Fileshow ory on with this project and see what happens.
PS It was my Grandsons 21st birthday yesterday and I am making a slideshow of my digital pictures (maybe should have waited a while to recover 8) )
Help needed, openshot has just frozen again. Only one clip and the program froze.

Hi Don

Openshot does have a habit of freezing so it is important to save your work at regular intervals, however it’s not normally as bad as you’re describing, whu don’t you try opening Openshot from the terminal run it till it crashes and see if the terminal gives you any clues, if it reports any errors you can post them here

Good luck

Graeme

Hints -

If openshot has gone bonkers and frozen the whole system … do as you did and drop to a console with Ctrl+Alt+F1

login

now you can kill all openshot instances with:
sudo killall openshot

or find the runaway process PID number with (top will give you this) … and kill it with

sudo kill -9

Hitting Ctrl+Alt+F7 will then return you to the Desktop GUI
(that’s F7 not F3 … F3 will just open a new console)

I have just started up with Openshot again.
I started a new project and saved.
I made a title and saved.
I imported 5 files and added them to the timeline one at a time and saved them one at a time.
I then imported the next 5 files and started scrolling down to pick the next clip for the sequence and the programme suddenly disappeared and I was back at the desktop.
When I go to Terminal and type openshot, when I click Enter I get thhe following

don@ldwatson ~ $ openshot

------------------------- ERROR 1 ------------------------------
Failed to import ‘from openshot import main’
Error Message: cannot import name main


OpenShot (version 1.4.3)

Process no longer exists: 1989. Creating new pid lock file.
No LADSPA plugins were found!

Check your LADSPA_PATH environment variable.

Detecting formats, codecs, and filters…

There is a long list of files etc. and it ends

  • oss

    state saved
    on_frmMain_destroy
    don@ldwatson ~ $

Hi Guys,
I started Openshot again, this time in Terminal, and apart from the odd opening information screen in Terminal the programme ran ok for a while.
It did crash after a while but I think I had confused it a little by trying to shorten a clip. It did have a message in Terminal but I forget what it was.

@ Emegra I didn’t save at all after I saved the project name :-[ :-[ I was getting on so well too.

I will go back and start again but I feel more confident now, I don’t know why
EDIT crashed again
Non-reference picture received and no reference available
[h264 @ 0x7f1cb73aeec0] decode_slice_header error
Non-reference picture received and no reference available
[h264 @ 0x7f1cb4841a60] decode_slice_header error
project state modified
state saved
on_tlbPlay_clicked called with self.GtkToolButton
Non-reference picture received and no reference available
[h264 @ 0x7f1cb469a700] decode_slice_header error
Non-reference picture received and no reference available
[h264 @ 0x7f1cb40391e0] decode_slice_header error
Killed
don@ldwatson ~ $

I’m wondering how much the move from ffmpeg to libav has affected openshot stability (or if it’s always been unstable)

Non of the openshot PPA’s contain versions for trusty (so therefore Peppermint 5) … I’m wondering if you do a lot of video work wether you’d be better off dual booting AV Linux which is the openshot recommended distro (openshot preinstalled).

or maybe a different video authoring app.

I don’t do any video authoring, so can’t help much.

As Mark suggested, you could try a different video authoring app.
I have been using Openshot in the past but some MLT problems surfaced so I switched to Kdenlive which I am happy with. This might bring in some KDE dependencies but it is worth the try.
The other one you could try is Lives

There’s also

Flowblade:
https://code.google.com/p/flowblade/

Cinelerra (via PPA):

and if you’re running 64bit - Lightworks:
http://www.lwks.com/index.php?option=com_lwks&view=download&Itemid=206&tab=1

just to confuse matters even more :slight_smile:

That said, kdenlive is at least in the repos … and the consensus seems to be it’s pretty good … normally I steer clear of KDE apps (because of all the dependencies they pull in), but this may be the exception to the rule.

I’ve never tried kdnlive but it get good reviews but the KDE dependencies is what’s put me off as well, I have tried Cinelerra but found it very buggy, Openshot does have a habit of crashing occasionally (I read on their site it had something to do with memory leaks) but I’ve never found it to be as bad as Don’s experiencing but I stick with it because I like the direction the developers are taking it and hopefully the crashing thing will be sorted out in time, I don’t know anything about Lightworks so I can’t comment on that

Graeme

@ Sezo, I have tried to install Kdenlive but it doesn’t appear in the menus.
@ Emegra, I am thinking that Openshot is OK, but I will possibly need a little more time playing with it.
@ Mark, I have plenty of room for AV Linux. What should I do to get that ?

To try Kdenlive you could run in terminal:

kdenlive

If you like it then you could create a shortcut on your desktop to start it.
On my install the executable is /usr/bin/kdenlive it might be different on yours

Hi Sezo,
When I try that I get this error

don@ldwatson ~ $ kdenlive
ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action

It then opens the programme ok
When I try and open Help I get

Could not launch the KDE Help Center
Could not find service ‘khelpcenter’
I will wait until tomorrow to continue with this problem, I seem to have tried a number of packages and don’t seem to be getting anywhere.
Thanks again

ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml

That must be an Ubuntu specific requirement as on mine it does not ask for that (and I do not have it either)

Could not launch the KDE Help Center

I do not use the KDE help center so not missed here.
You could install it with:

sudo apt-get install khelpcenter4

You would get that with any KDE centric application if used outside KDE.

Thanks Sezo, will have a look
EDIT It comes up with a Documentation not found page, thanks anyway.
I will wait until Mark comes back with some advice on AV Linux

Dunno … I’ve never installed AV Linux.

I’ll download it later and take a looksee … but it’ll probably be tomorrow before I can advise how to install it.

Distrowatch says it’s Debian based so I’ll need to have a look at the installer … that said it’s a LiveDVD so you could always burn it to disk and take a look yourself, but I probably wouldn’t use a “Live” session for video conversion unless you have a LOT of RAM.

32bit PAE version here:
http://www.bandshed.net/iso/avlinux6.0.3-xfce410-pae-i386-en.iso
3.0GB
MD5 = e0d70ca5fae755932b50fe17c36256e3

32bit non-PAE version here (but if you can run Peppermint 5 get the PAE version above):
http://www.bandshed.net/iso/avlinux6.0.2-xfce410-i386-en.iso
2.9GB
MD5 = 6c1cd5a7ac402702a44ba4f29ea9e488

There is no 64bit version.

Thanks Mark,
I will have a look see at the 32 bit PAE version
I will be back :wink:

ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml

haarcascade_frontalface_alt2.xml (at that path) is contained in the opencv-data package, so try installing it:

sudo apt install opencv-data

then see if you still get that error starting kdenlive from the terminal:

kdenlive

Creating a menu item will be easy … in fact run:

sudo cp -v /usr/share/applications/kde4/kdenlive.desktop /usr/share/applications/kdenlive.desktop

It should now be in the menu at:-

menu > Sound & Video > Kdenlive


If you feel you really need the “help” documentaion for Kdenlive…

As SeZo says, you can install the KDE Help Center with:

sudo apt install khelpcenter4

Hi Mark,
1 The only message I get now is

don@ldwatson ~ $ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action

and then the programme opens.
If I try to get the help file it says ‘Documentation not found’ ‘KDE Help Centre’

2 I have a menu item menu>Sound and Video>kdenlive

3 I ran sudo apt install khelpcenter4 but it only shows the Help Centre menu and says document not found

I have downloaded the iso image for AV Linux. Will I use UNetBootin to create a live disk and install AV Linux alongside Pep5 ?

For the kdenlive help, open a terminal and run:

cd /usr/share/doc/kde/HTML/en/kdenlive

then

sudo gunzip index.docbook.gz

Now see if you can go to

Kdelnlive > Help > Docbook


I don’t think those QWidget errors are critical … so for now ignore them, and just start Kdenlive from the menu.


I have downloaded the iso image for AV Linux. Will I use UNetBootin to create a live disk and install AV Linux alongside Pep5 ?

Dunno yet…

Thanks again Mark,
I have carried out those suggestions and kdenlive now offers a Help Manual