problem with removed partition

Had vista partitioned with linux and deleted Vista but cannot find a way of extending Linux into the free space. I am new to Linux and a’ grey surfer’. Attached is screenshot of the hard drive. Wouild appreciate help in simple language

Hello Frank - and welcome to the Forum.

Messing about with partitions is scary for me but there are mentors here who will be able to help you if you can supply a bit more info.
Please start a terminal session and enter the following code:

inxi -Fx

… then post the output here.
This will provide lots of info about your system including partitions.
You might like to install the “Gparted” partition manager, if it’s not there by default, as this is one way to solve your problem.

Another solution is to backup all your files then re-install Linux. You will be offered several choices, one of which is to reformat the whole drive (I use Ext4 but FAT32 is fine). I think that should do the trick.

Thank you for quick reply. I think I messed up by deleting Vista from the Disc map I sent earlier. You will guess that I am nil savvy on Linux. I have taken a screenshot of the terminal using the code you supplied which means nothing to me. (surprise surprise!). I am grateful.

Hi Frank.
I didn’t see any disk-map on your post, and screen shots can’t be displayed here, I believe, so please copy the inxi output from the terminal (highlight by left-click-drag cursor) then use Ctrl+Shift+c to copy the highlighted text.
Then come back to the Forum and Ctrl+p to paste it into a new post. We do a lot of cutting/pasting on this Forum!


Having trouble copying and pasting following your instructions. This is what I have. The previous screenshot I got from going to Control centre > Disks > hard drive and deleted the partition holding Vista which I suppose I should not have done. Thanks for your help
frank@frank-Inspiron-530:~$ inxi -Fx
Host: frank-Inspiron-530 Kernel: 5.3.0-28-generic i686 bits: 32
compiler: gcc v: 7.4.0 Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Type: Desktop System: Dell product: Inspiron 530 v: N/A
Mobo: Dell model: 0K216C v: ??? serial: BIOS: Dell
v: 1.0.15 date: 06/20/2008
Topology: Dual Core model: Intel Pentium Dual E2200 bits: 64 type: MCP
arch: Core Merom rev: D L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 8778
Speed: 2071 MHz min/max: 1200/2200 MHz Core speeds (MHz): 1: 2195 2: 2028
Device-1: Intel 82G33/G31 Express Integrated Graphics
vendor: Dell Inspiron 530 driver: i915 v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.19.6 driver: intel
unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel G33 x86/MMX/SSE2 v: 1.4 Mesa 18.2.2
direct render: Yes
Device-1: Intel 82801I HD Audio vendor: Dell Inspiron 530
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k5.3.0-28-generic
Device-1: Intel 82562V-2 10/100 Network vendor: Dell Inspiron 530
driver: e1000e v: 3.2.6-k port: fe00 bus ID: 00:19.0
IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: 00:21:70:0a:01:e8
Local Storage: total: 149.01 GiB used: 61.05 GiB (41.0%)
ID-1: /dev/sda vendor: Seagate model: ST3160815AS size: 149.01 GiB
ID-1: / size: 65.01 GiB used: 61.05 GiB (93.9%) fs: ext4 dev: /dev/sda5
System Temperatures: cpu: 57.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 156 Uptime: 23h 58m Memory: 1.89 GiB used: 1.21 GiB (64.0%)
Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19
inxi: 3.0.32
frank@frank-Inspiron-530:~$ ^C

Thanks Frank.

It’s clear that the old Vista partition is occupying about 80Gb.

Your first post does indeed show a paperclip icon indicating an attachment, but I can’t open it (can you?).
Can you upload the screen shot to (for example) Registration is easy and any images that you upload are there for ever as far as I can tell. Once uploaded, you can copy a link to the image and then paste the link into a Forum post.


Hi Keith,
Thanks for your patience. The link is The large square is where Vista was 80Gb. When I shut down and reboot Vista is still registered below Linux mint, but when highlighted it says ‘doesn’t exist’ I feel that I am getting into a ‘fix’ beyond my capabilities.

Thanks for the image, Frank. I see what you mean.

Don’t despair! I would be reluctant to advise you on re-assigning/deleting partitions although I have done it successfully. I don’t mind risking screwing up my own computer, but not yours.
Have you considered my other, safe, suggestion of re-installing Linux? You clearly know how to do that and as long as you back up all your files first I am confident that your problems will go away. What do you think?


Hi Keith
. I may try to reinstall Linux Mint when I back up my private files. It was some time ago so I hope I remember. Just to clarify; if I download Mint 19.3 will it guide me through replacing what I have on the hard drive?
I seem to have occupied quite a lot of your time for which I am grateful.

Did you not install it yourself the first time?
Did you create a “live USB” for the installation? If so do you still have the ISO file?

to the first question. Yes. To the second question; I downloaded Lubuntu 16.04 to a dvd which I still have. If I remember correctly I then upgraded to Mint.
At 84 my memory is not as sharp as once was.

Hi frankmac,

If you are ready to install Mint or Lubuntu and want to get rid of the Windows partition first back up any important files that you need to keep to a flash drive or similar.

Put the DVD in the drive and boot, if you cant boot from the DVD press F2 when you boot to enter the bios and change the boot sequence so DVD drive is the first one in the list. Once youve booted the DVD you can then start the installation process. Follow the prompts until you get to updates and other software - this the way I do it. After that you get the choice of installation type - - you might want to erase disk and install your linux which will create one big partition or you could choose something else, make your own partitions. The choice is up to you.

Sorry its a bit long winded, Im no expert I just do what I know works for me. I hope this helps you a little bit. Any problems come back and ask.

Kind Regards

I might have misunderstood the question! If all you want to do is remove the reference to Windows I would start GParted and then delete the 80GB partition and the 8.6GB recovery partition, they should then have no effect, hopefully.

Yep: That’s good if one is confident about doing it but lots of people have come unstuck as errors are only too easy to make. Re-installation is probably the safest option.


Wishbone’s advice is good if you want Peppermint (which is excellent) but Wishbone’s second link shows “Install Peppermint alongside (your present version)” and you definitely don’t want to do that. You need to choose the second option: “Erase disc and install Peppermint” as that will then reformat the disc.

If you prefer Mint try Download Linux Mint 21.3 - Linux Mint and choose 32bit Cinnamon or Mate.

If you choose the live DVD route, do check the live disc in demo mode before installing!!!
Let us know how you get on.


I have burned a dvd for Linux Mint 19.3 and put it in computer; shows on desktop but not to install. Shut down and tried to get BIOS setup with no success. I’ve probably forgotten how to or maybe because I already have Linux Mint installed. However I feel that I have kept you busy far too long so I should be satisfied with the limited amount of space I have and call it a day.
Thank you Keith for your support and time; and also to Wishbone who tried to help.

Don’t worry about the time, Frank - we are here to help if we can.

The way you set up the BIOS is something like: Keep clicking the F12 key during the boot up process.

This should boot the system into the BIOS editing suite. If that key doesn’t work, then some computers use the F2 key or perhaps the delete key - you may have to experiment but one of them will work.
Peruse the menus and find something like “Set Boot Order”. Usually, the RHS of the screen has some advice on what to do to change the boot order.
When finished, look for the “Save & Exit” instructions.
Then, with DVD installed, reboot.

Good luck

Hi Keith.
Thank you for the “nudge” and encouragement. Finally it has installed and I am back to a full use of hard drive. I appreciate the time you have spent guiding me through this.

That’s wonderful! Well done, Frank.
I’ve been through all this myself so I understand the difficulty.

Mint is a nice operating system and well suited to your Dell. We hope to see you on the forum again.