Problems installing virtualbox [solved]

I’m trying to install virtualbox in a new installation of Xubuntu, by following Mark’s advice in a different thread, which I’ve quoted below (because I don’t know how to reference the other thread here).

Everthing works until sudo apt install virtualbox-4.3, which gives the following errors

mike@xubuntu:~$ sudo apt install virtualbox-4.3
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
virtualbox-4.3 : Depends: libvpx1 (>= 1.0.0) but it is not installable
Recommends: libsdl-ttf2.0-0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
mike@xubuntu:~$

I tried the following, but no luck…
mike@xubuntu:~$ sudo apt-get install libvpx1
[sudo] password for mike:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libvpx1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libvpx1’ has no installation candidate
mike@xubuntu:~$

Where do I go from here, folks? This worked in Ubuntu 14.04.

TiA.

Maybe it is not working because of the old version?
They are on version 5.2
Have you tried the instructions here:
https://www.virtualbox.org/wiki/Linux_Downloads

Thanks SeZo,

I followed the link, downloaded the Ubuntu 16.04 files, accepted the option to open with the package installer and bingo! I can now open virtualbox 5.2.22.

My next task will be to get it to recognize one or two VMs I created before reinstalling Xubuntu and upgrading to 5.2.22. I’ll leave this thread open for the moment since it’s the obvious place for any questions I might have on that score.

Ok. I got vb to recognise one of my vms, so I’m marking this solved now.

Thanks again, SeZo.