Problems installing WINE on linux linpus lite AA1

the WINE install freezes all i do is

[user@localhost ~]$ sudo yum install wine
audit_log_user_command(): Connection refused
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.6 kB 00:00
Setting up Install Process
Parsing package install arguments

and it stops here

Can you run these commands in a terminal, and post back the output:

yum list available 'wine*' 

and

yum list available 'wine' 

[user@localhost ~]$ yum list available ‘wine*’
Available Packages
wine.i386 0.9.47-1.fc8 fedora
wine-capi.i386 0.9.47-1.fc8 fedora
wine-cms.i386 0.9.47-1.fc8 fedora
wine-core.i386 0.9.47-1.fc8 fedora
wine-devel.i386 0.9.47-1.fc8 fedora
wine-docs.noarch 0.9.47-1.fc8 fedora
wine-esd.i386 0.9.47-1.fc8 fedora
wine-jack.i386 0.9.47-1.fc8 fedora
wine-ldap.i386 0.9.47-1.fc8 fedora
wine-nas.i386 0.9.47-1.fc8 fedora
wine-tools.i386 0.9.47-1.fc8 fedora
wine-twain.i386 0.9.47-1.fc8 fedora

[user@localhost ~]$ yum list available ‘wine’
Available Packages
wine.i386 0.9.47-1.fc8 fedora

Can you post the output from:

sudo find / -name wine*

YUM can see the files, but for some reason is stalling on the installation… I’m wondering if there’s a corrupt package in the package cache.

Though it would be better if I can find some info on installing a newer version than 0.9.47 … that’s quite old now ::slight_smile:

[user@localhost ~]$ sudo find / -name wine*
audit_log_user_command(): Connection refused
/usr/share/apps/katepart/syntax/winehq.xml

thats all

OK, try this…

First make a backup of the /var/lib/rpm directory:

sudo cp -vr /var/lib/rpm /var/lib/rpm.bak

Then see if any processes are accessing the /var/lib/rpm directory:

sudo lsof | grep /var/lib/rpm

If anything is listed, STOP HERE, and post back what is listed, as you may need to kill those processes.

If nothing is returned… delete the RPM database lock files:

sudo rm -v /var/lib/rpm/__db.*

Now rebuild the RPM database indices from the installed package headers:

sudo rpm --rebuilddb

Now try installing WINE again:

sudo yum install wine

If (for some reason) you need to return to the original (backed up) /var/lib/rpm directory…

Rename the new directory:

sudo mv -vr /var/lib/rpm /var/lib/rpm.broken

then rename the backed up directory to its original name:

sudo mv -vr /var/lib/rpm.bak /var/lib/rpm

If that doesn’t work, you may need to clean out YUM’s caches… let me know how you get on and I’ll post instructions if necessary.

it worked! :smiley: installed WINE and now im going to try it. btw when i inserted
sudo lsof | grep /var/lib/rpm
it said “sudo lsof command unknown” or something like that

OK, the lsof (list open files) package is obviously not installed by default in Linpus… but who cares if it worked :slight_smile:

OK for this to make sense to other readers I’d better explain… we got WINE installed, but then tried to get JAVA to install IN WINE…
which it doesn’t seem to want to do ::slight_smile:

After searching online I can only assume that the version of WINE (0.9.7) is at fault here… it is a VERY old version.

Searching seems to suggest installing java in WINE 0.9.X was an issue when that version of WINE was current… and as I can find no SAFE way to install a later version of WINE in Linpus Lite… I think you’re stuck.

You could try installing a later version of WINE, but it’s at your own risk.

Or ditch Linpus Lite altogether in favour of a more up to date Linux distribution.

what are the risks installing a newer version of wine?

I don’t know, that’s the point… I suppose you could download all the rpm’s for WINE from an later version of Fedora and try manually installing them, but if there are any dependency requirements, these will probably not be satisfiable by Linpus, so it could just be as simple as WINE doesn’t work, or it could be as bad as it screws up your system.

what about the previous versions of WINE? do they have the same problem?

I would expect so…

your problem is that Fedora didn’t include any significant upgrades to WINE until Fedora 10 (wine version 1.1.7 which is still old), Linpus being based on Fedora 8… but they’d changed the wine rpm’s by that stage… 12 of them for Fedora 8, 13 for Fedora 10… so I doubt if they are compatible with Fedra 8 and therefore Linpus.

Take a trawl through the different Fedora versions repository archives here:
http://archive.fedoraproject.org/pub/archive/fedora/linux/releases/

and you’ll see what I mean.

As I said if you want to run recent software, there is probably no way to install it on Linpus… on most other Linux distributions if necessary you could compile the software from source, but (something I learned from a previous question on this forum) Linpus Lite doesn’t seem to have the correct versions of the tools necessary to compile most modern software.

Like I said… if this is important to you, probably your best option would be to ditch Linpus in favor of a more up to date Linux distribution.


YOU ATTEMPT THIS AT YOUR OWN RISK … if it messes up your operating system, don’t blame me.

If you’re feeling brave, there’s nothing stopping you going here:
http://archive.fedoraproject.org/pub/archive/fedora/linux/releases/10/Everything/i386/os/Packages/

and downloading these files:-

  wine-1.1.7-1.fc10.i386.rpm
  wine-capi-1.1.7-1.fc10.i386.rpm
  wine-cms-1.1.7-1.fc10.i386.rpm
  wine-core-1.1.7-1.fc10.i386.rpm
  wine-desktop-1.1.7-1.fc10.i386.rpm
  wine-devel-1.1.7-1.fc10.i386.rpm
  wine-docs-1.0-1.fc10.noarch.rpm
  wine-esd-1.1.7-1.fc10.i386.rpm
  wine-jack-1.1.7-1.fc10.i386.rpm
  wine-ldap-1.1.7-1.fc10.i386.rpm
  wine-nas-1.1.7-1.fc10.i386.rpm
  wine-tools-1.1.7-1.fc10.i386.rpm 
  wine-twain-1.1.7-1.fc10.i386.rpm

And then attempting to install them.

If you ARE going to attemp this, I’d leave out the ones I’ve marked in red… the first one appears to just be a meta package to install the others through yum, and the second one it the extra package that isn’t present in Fedora 8.

YOU ATTEMPT THIS AT YOUR OWN RISK … if it messes up your operating system, don’t blame me.

It must also be said that there is no guarantee that java will install in WINE 1.1.7 either. … I’ve only tested it in Wine 1.3.15

geez, i think i’ll leave it be, now i understand why my sister bought it for so cheap

Mmm, it’s just that for some strange reason Acer decided to load an OS based on a very old version of Fedora… it’s the same in the Windows world… try installing recent software in Windows 98, some will install, most won’t, and it’s no longer receiving updates.

The good news is, like Windows, there’s nothing stopping you loading a more recent version… the even better news is, it won’t cost you anything other than a little bit of your time.