Problems with Lubuntu upgrade to 11.10

The update manager offered an up grade I have version 11.04. Both Chrome and the newer version of Linux failed to install. they seem to be looking for dependencies that are not on my system. Is there a way to get rid of the failed installation.

Afraid not … there is no easy “downgrade” option, and I’ve come to the conclusion that Ubuntu version upgrades are about as reliable as Windows ones, and rarely go well … so I only attempt a version upgrade when I’m fully prepared to do a wipe/fresh install if/when things go wrong.

It may however be possible to"fix" the 11.10 version with some work, and a Lubuntu LiveCD.

The Ubuntu 11.10 LiveCD allows for upgrading … so maybe the Lubuntu one will too … if not, there may be other ways, like selecting fix packages form the Recovery mode, or attaching the filesystem to a booted Lubuntu 11.04 LiveCD with chroot and doing a dist-upgrade.

But you’re going to need to backup your user files first, just in case … and once you’ve done that, it may just be easier to do a fresh install.

Does the system boot at all ? … what are the error messages ?

Chrome will probably be fairly easy to fix, but what do you mean by

and the newer version of Linux failed to install. they seem to be looking for dependencies that are not on my system


Chrome seems to be looking for GNOME files when the desk top is KDE. IT also tried to install a new Kernel which failed. It boots to a shell as dose recovery mode.

Version 11.04 still boots fine.

OK, now you’ve lost me ??? … if you selected 11.10 as an UPGRADE, 11.04 shouldn’t exist any more ??

How are you booting 11.04 exactly ?

I’m also baffled as to why you have the KDE desktop, when you said you were using Lubuntu, which by default uses the LXDE desktop ??

Tramlink, are you sure it’s not Kubuntu you installed? I don’t see how chrome could have tried to install a kernel? ???
Kernels only install through the package managers, when there is available updates. Did it say which version of the kernel it tried to update to?

If you are able to boot and can run a terminal can you post the output of:

uname -s -r -p

allusers@allusers-laptop:~$ uname -s -r -p
Linux 2.6.38-8-generic i686

My apologies it is LXDE desktop.

Installation was through Update manager and was listed as an Upgrade to a newer version from 11.04 to 11.10.

I can chose which operating system to start through the GRUB launch manager ( Win 98 is also installed to play DOS games).

Other versions of Linux are listed so I start the previous version 2.6.38-8 and it works fine.

After the update I was told 2 package’s had not been installed- the first is an updated version of Chrome and the second was a new Linux Kernel 2.6.38-12

Linux 2.6.38-12 if allowed to start in normal or recovery mode falls back to a shell promt (initram fs)

OK, boot to the 2.6.28-8 kernel, open a terminal and run:

sudo apt-get install --reinstall linux-image-2.6.38-12-generic linux-headers-2.6.38-12-generic linux-headers-2.6.38-12

Wait till you are back at an $ prompt … NOW try booting into the 2.6.38-12 kernel

Once we’ve sorted the kernel update issue, we’ll move on to Chrome, so let me know how that goes :slight_smile:

Hi, Linux 2.6.38-12 still falls back to the shell prompt. In recovery mode it seems to be looking for things that it can not find. Then opts to fall back to the shell.

OK, what happens if you boot to 2.6.38-8, then run:

sudo apt-get remove --purge linux-image-2.6.38-12-generic linux-headers-2.6.38-12-generic linux-headers-2.6.38-12


sudo apt-get update && sudo apt-get upgrade

It was still not working so have decided to try another Linux Light product. Thanks for your help.

Okey Dokey :slight_smile: … good luck, and please let us know which one you try, and how it compares to Lubuntu 11.04 … Thanks.

Went back to Peppermint 2, although I had problems with the hot-swap bay floppy there were work-a-rounds for that.

I noticed after the installation that I was offered to upgrade to Ubuntu 11.10. This seemed strange, I know it is based on Ubuntu and Mint but why would I be offered an upgrade to a program that is not installed.

I noticed that too, and have no idea why … Ubuntu and Mint are based on Debian, but it doesn’t offer to update to Debian 6 … so Why Ubuntu.

Just ignore it, and wait for PeppermintOS (Three)