Problems with skype icon (solved)

I am using mint 17 64bit and I have an issue with just my personal SKYPE account.

When I am not logged in to skype I am shown as “Away” I have tried removing the account and putting it back.

I have reinstalled Skype on the computer.

I have logged in to my account from different computers and my phone and tablet… the icon then shows I am on line but when I sign out of Skype it says I am away.

This is an issue as people try to contact me…anyone had this problem.

Any suggestions as the suggestions on Skype do not resolve the issue.

Uninstalling Skype will not clear your personal configuration files for it … these will stay on your system and be picked up again when you reinstall Skype.

Personal settings for Skype are saved in your home folder in a hidden folder called .Skype

So enter your home folder, and set your file manager to “show hidden files” (or hit Ctrl+H) … then with Skype closed, try renaming the .Skype directory to .Skype-old

Then fire up Skype.

Be aware Skype will have forgotten your login details, etc. … so it will be like starting with a fresh install of Skype.


Or (with Skype closed) rename it from the command line with:

sudo mv ~/.Skype ~/.Skype-old

Thought that was to easy… it makes no difference… I created and logged into my company account and it shows my personal account as “away” and I am not even logged in.

When I hover over the away icon it says away since xx time which is the same time I logged into my company account.

so that is not the answer but thanks for that tip…

Well that’s not really a problem with the locally installed copy of Skype as much as a problem with the Skype servers not recognising you’ve gone “Offline” … not much you can do about that other than maybe log on, then try going “Offline” again.

Are you sure you don’t have another Skype app (maybe on a smartphone) that’s logged on ?

I think it is solved found out about commands you can use in the chat window.

/showplaces shows where you are logged in.

Found out that when I logged in on a friends ipad that even when I thought I logged out I was still logged i after 2 weeks.

This command /remotelogout closes all but the present log-in and now the icon is behaving normally.

So have marked as solved…

I thought skype no longer worked on Linux- mine hasn’t worked in months.

Skype should work in Linux.

Which distro/version are you talking about ?

I don’t use skype on my laptop ( which is my main computer)- as it doesn’t have a built in webcam and the external one I was given is pants. The distro is Peppermint 3 which you helped me load on a good while back.

I was using skype on my netbook which is on Mint.

We can try getting it to work in Peppermint 3 if you wish ?

We could, but given it has no built in webcam ( and the portable one is crap) it makes more sense to sort it on my Mint netbook which has a great inbuilt webcam. Thanks Mark.

OK, in Mint, what happens if you run:

sudo apt-get install skype

did it install, or did it throw an error about not being able to find it ?

if it installed, does it work ?

If it threw an error that it couldn’t find it, can you run:

gedit /etc/apt/sources.list

and post the contents back here.

Here’s what turned up:

karij@karij-Inspiron-1011 ~ $ sudo apt-get install skype
[sudo] password for karij:
E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
karij@karij-Inspiron-1011 ~ $ gedit /etc/apt/sources.list
The program ‘gedit’ is currently not installed. You can install it by typing:
sudo apt-get install gedit
karij@karij-Inspiron-1011 ~ $

Hi Melissa

It looks like your version of Mint doesn’t use gedit as it’s default text editor, what text editor do you have installed ?

also I notice on this and another post your terminal output is showing this error


E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

so perhaps you should run that command and try again

sudo dpkg --configure -a

Then

sudo apt-get install skype

Then

gedit /etc/apt/sources.list

replace “gedit” with the name of your default text editor, if you dont know what it is


cat /etc/apt/sources.list

and paste the output here

Good luck

Graeme

You have a lot of topics open, but we can’t continue with any of them until you’ve run:

sudo dpkg --configure -a

as you’re being asked to do :wink:

There’s no point in me typing this in all your topics as you only need to run that once … see your "flash topic here:
http://linuxforums.org.uk/index.php?topic=12334.msg100633;topicseen#new
and we’ll come back to this topic after that one is sorted :wink:

Ah ok, sorry not good with this command sudo stuff! Downstairs at laptop - will do that in a bit

OK, now what happens if you run:

sudo apt-get install skype

Will do these tomorrow Mark, thanks- got to get to sleep- up early in the morning.

Okey dokey.

arij@karij-Inspiron-1011 ~ $ sudo apt-get install skype
[sudo] password for karij:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
skype-bin
The following NEW packages will be installed
skype-bin
The following packages will be upgraded:
skype
1 upgraded, 1 newly installed, 0 to remove and 555 not upgraded.
Need to get 20.1 MB of archives.
After this operation, 5,303 kB of additional disk space will be used.
Do you want to continue [Y/n]?

Sorry for late reply Mark- not used my Mint netbook for ages! I am on it now as my Pepppermint laptop is doing the torrent. It is asking abut disk space- not sure if I have enough as this netbook has a teeny SSD.