Problems with Windows

Since your computer shipped with Windows 8 / 8.1, you will need to DISABLE “Secure Boot” and ENABLE “Legacy Support” before you can install Linux. As Mark says this should be from the BIOS menu.

I will have a look…In the boot settings i remember seing an enable/disable option which i disabled. Will investigate further, the problem being my lack of skills in this sector of technology. Will have another go.

Having another look at this Samsung notebook. If I go into set up and Secure boot is disabled, I have another label -“Secure Boot Mode”
This i have set to custom (set to standard) this brings up “Default Key Provisioning” is {Enabled} under this title-Manage All Facory Keys (PK,KEK,DB,DBX) Under these abbreviations is a list of the descriptions showing “Installed” by each. Not sure what to do next in my challenge to instal Linux.
And a big thank you to all who have come forward with supporting advice.

Is there any option in there to switch to Legacy BIOS mode ?

Be aware if you set this to Legacy BIOS instead of UEFI, Windows won’t boot until you set it back to UEFI … but I just want to know if changing it to Legacy BIOS alows you to boot a LiveUSB ?

Note - Some UEFI implementations call Legacy BIOS "CSM " (compatibility support module).

From selecting F12 evenualy takes me to UEFI settings and requests restart to make changes. I’m taken to the BIOS Config from which gives me SysInfo _ Security _ Exit choices. Selecting security takes me to TPM 2.0 Device {Enabled} switcheable selection or by moving down takes me to secure Boot config which has the option to enable / disable. Following down is the next instruction “Secure Boot Mode” with the option to select standard or custom. I did ‘take the bull by the horns’ at one stage and attempt to delete Windows altogether and I thought all was going well accept part way through a pop up message read that this action was not permitted!! so had to abort. In set up mode under the Security label I have a select/disable option for Default key provisioning. When bringing up ‘Please select boot device’ from F10 I have three options: Windows Boot Manager_UEFI SanDisk (USB stick) _ Enter Setup. So far what ever I try results in the standard Windows8 start screen!

Have you tested booting from the LiveUSB on another PC just to make sure it works ?

Hi Mark, I’ve acquired an old XP laptop so I can give your suggestion a try. Will report back when I know more.

Back with an update… well dugout an old Acer Aspire 5536 laptop running Windows7. Logged onto Ubuntu and followed instructions after setting up a DVD. Sailed through installation and running side by side with Windows which I wanted to keep. It’s the first time I’ve used ubuntu and very impressed am I, very fast and trouble free so far. However I still can’t boot up the same program loaded on my USB onto my Samsung Windows 8.1 (pre loaded) notebook even after following instructions regarding boot method etc. What bothers me is should I remove windows altogether and if so will it upset anything else? Anyway have made some progress if only I can sort this out it would be a huge bonus.

Here’s the problem … right now you’ve tested a DVD as working (but you can’t use that DVD in the Samsung), the purpoe of the exercise was to test the LiveUSB to find out if it was at fault or not.

Have you got a PC that can boot from USB stick (other than the Samsung) … if so, can you try booting from the LiveUSB stick and see if it works … don’t install Ubuntu, just check it boots in “Live” mode, ie. choose “Try Ubuntu”.

We need to be sure the problem doesn’t lie with the USB stick rather than the Samsung.

OK thanks Mark… I’m going to try a different USB stick, also an old XP Toshiba doesn’t show a USB boot option for me to test, only FDD_HDD & LAN options show in the menu… will come back. Regards

This is where I am with the continuing saga of trying to run Linux along side windows 8 pre-installed notebook. Several USB sticks have been tested with various USB creator downloads but no success yet. I have checked for boot up on another laptop with the USB sticks to hand and in all cases they have not booted after re configuring the boot up sequence. My old Acer laptop is the one that loaded up and runs without any trouble along side Windows XP.
The Samsung note book is the one I’m trying to win with. In the boot sequence I can select the following options: (1) Windows Manager (2) UEFI: PNY 2.0 USB
(3) SET UP. If I choose option 2 after selecting F10 at start up I see the SAMSUNG activation screen logo with the usual rotating disc followed by please wait when after a brief pause the Windows welcome screen appears. Unless any one has any ideas where I’m going wrong, It may point to USB sticks problems?

If NO PC can boot from the LiveUSB sticks, it MUST be either the sticks or the ISO image

Can you give me the Samsung model again please … I’m wondering if this is one of those devices that require a 32bit UEFI implementation.

Thank’s Mark… I’m only a novice with this problem so my way of thinking is not from a technical point of view! Would you not normally expect to see an error message if the boot up failed? Here’s another thought… I’m running ubuntu on this old Acer from a down load onto disc_ no problem, so can I copy from this disc onto USB and try that?

Hi Mark: Samsung model 500T P13AAI thanks

Here’s what I think the problem may be.

The Samsung 500T, I think uses an intel Atom Baytrail CPU … these are often tied to a UEFI system that requires a 32bit bootloader (even though the CPU can handle a 64bit OS).

Tie that to the fact that it’s impossible on some of these devices to switch back from UEFI to legacy BIOS mode … and the fact that most Linux distros only support UEFI on the 64bit versions (so only come with the 64bit UEFI bootloader)

And you end up with a major headache … see here:

Luckily it seems quite easy to modify the LiveUSB to contain the 32bit UEFI bootloader (to test this theory) … do you want to give it a shot ?

Bring it on Mark… I’ll try anything to get this running on what is a better OS than Windows

Okey dokey, plug the LiveUSB into an already running version of Windows (ie. don’t boot from it).

Are you able to navigate onto it and find the /boot/efi directory … it should contain a file called bootx64.efi

At this point I just want to know if you’re able to see that file on the USB stick ?

Hi Mark…here we go: ubuntu -14.04.3-desktop-amd64 EFI - BOOT - BOOTX64.EFI
as requested.


Okay, go to this address:

and click the button marked Raw

Save the file bootia32.efi file somewhere, then copy it to the same directory on the LiveUSB as the bootx64.efi file (so they are BOTH in that directory).

Now you NEED to make sure “Secure Boot” is disabled on your Samsung

Now try booting the LiveUSB.