Quick Nas question

I’ll be doing a few things over the weekend and one of them is adding a NAS.
I was thinking of getting one of these.

http://www.argos.co.uk/static/Product/partNumber/1525498.htm#pdpPromotions

And using xp or similar in vbox to set it up etc.
Any comments or suggestions welcome.
Will also be upgrading to Peppermint 5 (still running Pep 3) so might have some Q’s about that later.

You may not need to run a Windows VM look here WD My Cloud NAS on Ubuntu | [[Cocoa alloc] init];

Good luck

Graeme

Well that allays any fears I may have had thanx.
So reading that it looks like he’s essentially created a symlink to an IP Address?

Once set up via the NAS web interface (so through a web browser) and given a static IP on your local network, you can access the NAS either via “Network” or mount it automatically at boot then it will just appear as another folder(s) in your file manager.

Can I add that I now have so much valuable stuff on a single bay NAS that I SERIOUSLY wish I’d bought a dual bay one that could mirror the drives, so in case of a drive failure I wouldn’t loose everything … just sayin :wink:
(in fact that’s going be my next purchase … just hope nowt goes wrong between now and then, but you know how these things have a habbit of getting pushed backwards)

I’m looking at one of these:

then have 2TB mirrored (RAID 1) … so if one drive fails I can just replace it and the mirror will rebuild … there’s MUCH less chance of both drives failing at the same time, lightning strike aside :wink:

I’ve got a single bay Buffalo Linkstation, and have been very pleased with it, so I’ll either get another or buy an empty 2 bay NAS enclosure and add my own drives.

I’m not 100% sure but it looks like the WD Nas galaxytdm is looking at has 2 USB ports so I suppose theoretically he could add an external HDD and backup on to that

Graeme

AFAIK, there’s no way to get it to automagically mirror to an external USB HDD … my Linkstation has a USB port, and it will automagically copy anything on a USB drive plugged into it too the NAS HDD, but not the other way around … the USB port can also be used to plug in a printer and have that as a networked printer (printserver).

I’m not suggesting he buy a Linkstation, or even a dual bay NAS … just drawing attention to the fact that I REALLY wish I had my stuff mirrored, so though I’ll never be without a NAS again I wish I’d bought a dual bay (and mirrored the drives) in the first place … for peace of mind, because the second you start using a NAS you start to worry about the data you’re putting on it :wink:
(they tend to get used for things you consider important … at least important enough to want access to from more than one PC)

the second you start using a NAS you start to worry about the data you're putting on it

How true is that

As you know I have a home built NAS which in the beginning I only built as an experiment and to re-purpose an old PC and now I couldn’t be without it, but I know what it’s like to lose data through a drive failure so yeah you’re absolutely right it’s a worry

Graeme

All I know is that once you get a couple of hundred GB of data on an un-mirrored NAS you spend the rest of your life “on edge” :wink:

So I’d never buy a single drive NAS again … much better to wait until you can afford a dual bay, and mirror the drives … but that’s just my opinion.

Peace of mind may not seem so important when you first get a NAS, but it WILL later on, I guarantee it :wink:

Actually I’d get one of these:

and add drives (set up as RAID 1) myself as and when I could afford them.

much more useful :slight_smile:

[EDIT]

In fact if I had £130, I’d order one today … anyone feeling generous ? :slight_smile:

Right, I bought it plugged it in and…
I think there may be a problem here.
Firstly, I know it’s broadcasting because the tv can see it.
I’ve had a look at my router and can’t see it’s mac address listed though so can’t determine the ip address.
Tried the web interface and just get a google message saying can’t open web page.
WD help page says if all else fails, use the set up software, but that’s for windows and as the wife’s lappy is xp sp1 and God alone knows what’s going on with xp sp3 in VMware I can’t get the software to run on either.
Any suggestions?

I've had a look at my router and can't see it's mac address listed though so can't determine the ip address.

You can sweep the network with a simple Ping scan to determine which hosts are online:

sudo nmap -sP 10.0.0.0/24

Replace the 10.0.0.0 with your network
This should return information with MAC addresses against each IP address and possibly host names too.
You may haveto install nmap first

What happens if you click this link in a web browser:
http://WDMyCloud
?

[b]Launch the WD My Cloud Web Interface[/b]

The browser-based interface provides you with the means for configuring and maintaining your WD My Cloud.

To launch the web interface:

Open a browser window.
In the Address bar, enter http:// followed by the name of your WD My Cloud
(default name: WDMyCloud)

Example:
http://WDMyCloud

The WD My Cloud web interface displays.</blockquote>

http://setup.wd2go.com/?mod=faqs&device=mc&faq=connect

What happens if you click this link in a web browser: http://WDMyCloud

Chrome says-- “The server at wdmycloud can’t be found because the DNS look-up failed. DNS is the network service that translates a website’s name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.
Error code: DNS_PROBE_FINISHED_NXDOMAIN”

IE in VMware won’t run the website because it’s outdated but refuses to be updated.

Firefox won’t display the website due to lack of Java and although I’ve downloaded the tar,gz I’m at a loss as to how to install it.

I’ve been able to access it with lappy windows and vm windows buy entering \WDMycloud in the run box.
I can then transfer files by accessing my hard drive in vm but this is not ideal and I’d much prefer to do it in linux but just can’t see the drive on the network.

@Sezo

Try to install nmap from the repo’s but it won’t install. It starts but stops at 10% and the install button re appears.

What is the IP address of your Linux PC ?

on the Windows PC, what is returned if you run:

ping wdmycloud

at a command prompt … does it return the IP address ?

Which distro are we talking about ?

Right.
Lets forget about XP in VM as its just thrown its toys out again but the ping on the lappy (henceforth to be known as lxp) returned 198.162.0.10.
Entered into the address bar of chrome I can access the interface but it doesn’t allow me to transfer files just use the set up utils.
BTW 198.162.0.10 doesn’t even show up in the router table of connected devices.

I am currently running Peppermint 3 but as stated earlier I’ll be moving to Pep 5 (a few q’s about that first though) soon.

OK, in the web interface is there a way to set the mycloud to have a static IP address ?

if so, set it to
192.168.0.200
(see bottom of his posting for some more settings)

That way we’ll always know it’s IP address

I take it you’re router is 192.168.0.1 ?

in network manager is your Linux PC (IPv4 method) set to Automatic (DHCP) ?

On the Pepeprmint 3 PC install smbclient

sudo apt-get install smblient

then in the address bar of file manager, enter:
smb://192.168.0.200

or if you haven’t changed it yet
smb://192.168.0.10
but you REALLY want to give the NAS a static IP, or it’s IP will change, then you’ll have to go through all this again to find out what it is.


I don’t know exactly what the mycloud will ask for to set a static IP but here’s what my linkstation wants

DHCP: disabled
Primary IP Address: 192.168.0.200
Subnet Mask: 255.255.255.0
Default Gateway Address: 192.168.0.1
Primary DNS Server: 192.168.0.1
Secondary DNS Server:

Those settings suppose your router is 192.168.0.1

NAS now on static 198.162.0.200
Router is 198.162.0.1
Linux box is dhcp.
When I run

sudo apt-get install smbclient

I get an error returned

~ $ sudo apt-get install smbclient
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  liblinear-tools liblinear1
Use 'apt-get autoremove' to remove them.
Suggested packages:
  cifs-utils
The following NEW packages will be installed
  smbclient
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 5,329 kB of archives.
After this operation, 42.5 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  smbclient
Install these packages without verification [y/N]? y
Err http://gb.archive.ubuntu.com/ubuntu/ raring-updates/main smbclient i386 2:3.6.9-1ubuntu1.2
  404  Not Found [IP: 194.169.254.10 80]
Err http://security.ubuntu.com/ubuntu/ raring-security/main smbclient i386 2:3.6.9-1ubuntu1.2
  404  Not Found [IP: 91.189.91.15 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/s/samba/smbclient_3.6.9-1ubuntu1.2_i386.deb  404  Not Found [IP: 91.189.91.15 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Edit
Entering smb://192.168.0.200/ allows me to see the nas and I can write to it (small file) but can’t delete from it.
Also, writing a large file (2Gig) it hangs at processing file for, well, I gave up after 5 minutes.

If your sources are reporting failure to download from the “raring” repositories, this must be Peppermint 4 not 3.

You’ll not be able to install anything in Peppermint 4 … now is the time to install Peppermint 5, then we’ll pick this up if necesssary. Peppermint 5 has a newer version of the pcmanfm file manager that’s better at networking, and smbclient is installed out of the box.

Install Peppermint 5, then gimme a shout if you’re still having any problems :wink:

Actually, gimme a shout ANYWAY, as we’ll mount the NAS through fstab … it makes things much more stable :slight_smile:

OK.
I’LL start a new thread on that score as I have one thing I want/need to make sure of before I upgrade.

I noticed that there was a network folder icon on the end of docky and clicked it, only to find that that the NAS opened in file manager at address

/run/user/celticbiker/gvfs/smb-share:server=192.168.0.200,share

and I have full access to the files, and they transfer at about 3min/1.5gig.

Yup. that’s where it’ll get mounted, but only after you’ve opened once in file manager.

Once you have PM5 installed, we’ll mount the share through fstab … that way it will immediately be available (it will also open faster.

I suppose we might be able to do that in PM4 if you already have cifs-utils installed … but you’re going to need to move to PM5 anyway, so now’s the time :wink: