"quiet splash clocksource=hpet" doesn't work. (SOLVED)

Hi All,

it’s been a while, but I was somewhat distracted by my 19" 4 x 3 monitor going down on me. It transpired that a ceramic disk capacitor on the power board had burnt out, which I managed to fix but in the meantime treated myself to a 23" 16 x 9. Absolutely magic. Grandson gets the advantage of the 19" now, but I digress.

As advised, did a new installation of Mint 13 on my 40Gb drive, with others disconnected. Let it have the whole drive to itself (no swap partition), no problems whatsoever with that. Boots O.K. with HPET disabled.

Again, as advised, ran “sudo gedit /etc/default/grub” and edited GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash” to GRUB…DEFAULT=“quiet splash clocksource=hpet” and attempted restart with HPET enabled. System hung on me.

Disabled HPET and tried again. Booted O.K. Checked that grub was still as modified, it was, and double checked my previous proof reading, which had been correct.

Question, any ideas why it didn’t work?


Tony N

Perhaps you could try to force hpet:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash hpet=force clocksource=hpet"

Don not forget to update grub afterwards.

Thanks SeZo,

but it didn’t do it.

I have been updating ‘grub’ as I go.

If I leave “Floppy” as first boot it hangs on floppy check.

HD as first boot and I get 2 blocks of code then it stalls.

Slight problem, Windoes trips over its own feet wmore often when ‘hpet’ is disabled.


Tony N

Can you send the contents of:

gedit /etc/default/grub


gedit /boot/grub/grub.cfg

Hello again Mark,

the first is: -

If you change this file, run ‘update-grub’ afterwards to update


For full documentation of the options in this file, see:

info -f grub -n ‘Simple configuration’

GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash hpet=force clocksource=hpet”

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)


Uncomment to disable graphical terminal (grub-pc only)


The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’


Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux


Uncomment to disable generation of recovery mode menu entries


Uncomment to get a beep at grub start

#GRUB_INIT_TUNE=“480 440 1”

The second as my reply re mounting & unmounting.


Tony N

Have you tried the hpet=force WITHOUT the clocksource=hpet parameter ?

eg. just make the line in /etc/default/grub read:-

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash hpet=force”

Then update grub with:

sudo update-grub


Well, I booted into Linux and did the mod you suggested but it didn’t cure the hpet problem.

So I rebooted, disabled HPET in the BIOS, set the Linux (40GB) disk as first priority and let it reboot. Strange thing, it came up with a menu with several options including Win XP Pro on /dev/sda1, which I selected, and the system booted in to Windows, which is where I am now posting this from.

Although it seems that I will have to run, for the time being, with HPET disabled, I now have immediate (well, a little slower than immediate in the case of Win XP) access to both both operating systems.

When I have posted this I’m going to restart, without changing the BIOS, and double check that I can access Linux OK.

Many thanks Mark.

Tony N

Ahh, ok ignore my posting in your other topic then :slight_smile:

I’ll see if I can find anything else about HPET, and let you know.

Yipee!!! It works.

Linux Mint 13 on /dev/sdb1, which I am now posting this from.

I don’t know how you do it Mark, telepathy ?

Many, many thanks

Tony N

Thanks mate.

It might be interesting to know if an Ubuntu 12.10 LiveCD will boot with HPET enabled … if it does, it may be that a kernel update would fix your issue.

just a thought :slight_smile:

Have done Level 1 and Level 2 updates, would this have included a kernel update?

Reading the pdf indicates that it may not be wise for me to action the 435 level 3 and higher updates at this time.

It still doesn’t work with HPET enabled. Just hangs, no HD activity, after the menu display.

Tony N

I’m pretty sure Mint blocks kernel updates by defualt … where Ubuntu doesn’t.

What’s the output from:

uname -a

Do you mean it stopps after the GRUB menu ? … or don’t you get to see the GRUB menu ?

I'm pretty sure Mint blocks kernel updates by defualt .. where Ubuntu doesn't.

Kernel updates appear if you enable level 5 updates

Cheers SeZo :slight_smile:

I was thinking of just manually downloading/installing a new kernel … but I suppose we could enable level 5 updates, unmark everything except the kernel update and headers … run the update, then disable level 5.

Personallly, the last time I ran Mint I left ALL levels enabled … I never understood why Mint was so cautious with kernel updates etc. … it’s AFAIK never been more stable than Ubuntu (roughly the same).

After re-reading that, it may still be easer to just download the kernel :slight_smile:

and depending on what’s going on with his graphics driver (another topic), it might turn out to be better to just add the xorg-edgers PPA which IIRC has the 3.5 kernel.

So I suppose a decision on the best route forward is still up in the air ATM :slight_smile:

Hi guys,

thanks for the feedback.

“uname -a” yields the following: -

“Linux Tonys-Bitsa 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux”

I guess this dates the level of the kernel at 10th April 2012. Yes? In which case I would also guess that there has probably been an update since then.

However, there are no updates, on the list that I get, above level 3 and none whose package name would seem to indicate that they are kernel updates.

Perhaps I should just let the system install all the level 3 updates? I did Levels 1 and 2 yesterday.

Just had a thought, “what if I right-click the update manager icon?”, whereupon ‘Preferences’ showed how to see all levels of update, including Level 5 “Dangerous etc.”.
Thinking there can’t be any harm in viewing them it revealed the following level 5 updates available: -

Package New version Old version

base-files 6.5ubuntu6.2 6.5ubuntu6
linux-firmware 1.79.1 1.79
linux-lib-dev 3.2.0-32.51 3.2.0-23.36 (the “-” is not a typo, that’s exactly how it appears on the list and reflects the “uname-a” result.)

My guess is that the last one is what I am looking for but should I, if I install this one, install all of these “Dangerous” updates? Please advise a beginner.

If they are as dangerous as ‘Preferences’ claim, and do affect the stability of my system, could I go back to where I was, or would I have to go back to square 1?

I am quite comfortable with the manipulation of ‘Update Manager’ and now able to select only such updates as are recommended.


Tony N

Hi again,

Yes, MINT, or my version of it, only displays levels 1, 2 and 3 by default.

With HPET enabled it displays the GRUB menu for the TIMEOUT period then nothing.


Tony N

Please note, I’ve nearly got a handle on the “quote” system. Didn’t realise until this morning that there is loads of stuff below the [Post] [Preview] buttons! :-[

OK, let’s see what kernel you have … can you send the output from:

uname -a

Have you checked if an Ubuntu 12.10 LiveCD/LiveUSB will boot with HPET enabled ?

“uname -a” yields the following: -

“Linux Tonys-Bitsa 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux”

I’m afraid I don’t have a Ubuntu 12.10 Live CD.

Tony N

You can get the ISO image from here:

It makes sense to try booting to the Ubuntu 12.04 LiveCD (with HPET enabled) just as a test, it has a later kernel than Mint 13 and if that doesn’t work there’s probably little point updating the Mint kernel.