Ralink wireless card does not work after upgrading kernel [SOLVED]

I asked a question on the wireless card which has been solved before:


But now when I upgrade the kernel to 3.2.0-31-generic, it does not work again. In “Additional drivers”, I see nothing. When I run the command “modprobe”, it said: “FATAL: Module rt3290sta not found”. What should I do?

After running

sudo apt-get update; sudo apt-get install hwinfo grep rfkill; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'anufact|roduct|erial|elease'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|wmi|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; sudo hwinfo --netcard ; ps -aux|egrep 'wpa|icd|etwork'; sudo lsmod

I get the output in the attachment.

The solution is to redo the following procedure again.


Sorry, I forgot to mention that it may need recompiling for new kernels :-[

Glad you worked it out though :wink: