Re: Keyboard question (Solved)

I’m using Ubuntu 14.04 and have 2 slight problems with the keyboard.

Firstly, the @ and " keys are reversed (ie: for @ I have to select " and vice versa). I’ve come across this in Windows and been able to fix it - can’t remember how. Something to do with regional settings I think. Can’t seem to fix it in Ubuntu though.

Secondly, is there a way to cause the numlock to be ‘on’ at boot up? Small point, but nice to have the option.

Thanks in advance…

M

You’ve got the English (US) keyboard layout selected instead of English (UK)
see here for how to add “English (UK)”, switch to it, then remove English (US)

and

What’s the output (if any) from:

dpkg -l | grep numlockx

That’s odd. English (UK) was checked in the Text Entry panel in ‘settings’. I selected English (US), then back to English (UK). Now it’s working.

No output from dpkg -l | grep numlockx.

Thanks Mark

OK, run:

sudo apt-get install numlockx

reboot and test if the numlock is on once booted ?

Yes. Worked a treat!

Thanks Mark. Much appreciated.

M

No problem … thanks for marking the topic solved :slight_smile:

Sorry to bump a solved topic, but Numlock on boot is normally a BIOS option. Not sure how it works when Linux boots (whether it does its own thing), but seems excessive to have to install a new package just to enable what should be a config option!

It’s not always a BIOS option … numlockx is there to switch it on/off as you require.

Ubuntu/Mint/most other “heavy” distros will have it installed by default … as it’s an allways running daemon most LXDE/lightweight distros won’t have it by default … opting more for an “if you want it, install it” as opposed to a “let’s force it on everyone” approach.

This is NOT a “Linux” thing … both Windows and OS X have software options to enable/disable the numlock (irrespective of the BIOS settings or in their lack) … but AFAIK Linux is the only one of the three that gives you the OPTION to install it or not :wink:

Think about it … you may want say the login screen to have the numlock ON, but it switch off when you reach the desktop … effectively software could take advantage and turn it on/off.

It can also work in conjunction with the laptop-detect package … where the numlock will be disabled on a laptop without a numpad
(something that baffled the hell out of me once on an AA1 that had numlockx installed but not laptop-detect … so half my letter keys where producing numbers instead ::slight_smile: … but I suppose it give you the option to enable numlock on a laptop without a numpad where there wouldn’t be a BIOS option … quite why anyone would want to do that is beyond me, but isn’t that the Linux way, to at least give you the option ?)

Seems a bit hardcore, maybe it’s just the future though (context-sensitivity growing in scope every day)
I figured it would be a DE config option, surprised it’s necessary to run a seperate daemon for it. Seems like the sort of thing that would be present in the kernel driver, or X come to think of it. In fact, I’m dead surprised it’s not a simple switch in X’s config!

I personally don’t see it as a kernel job … that would be to make sure the “hooks” are there to make it work, but not to include the software to do it.

There’s nothing “different” in the way Linux is doing it (daemon) to Windows and OS X … but Linux gives you the option to NOT have it installed if you don’t require it.

Kinda pointless having numlock functionality in say a router kernel don’t you think ?

As for it being a DE config option … normally IT IS … the DE just uses numlockx to achieve it, so it’s installed by defalt in DE’s that have it as a config option.
Lightweight DE’s (like LXDE) don’t offer it as a DE config … but that’s the kinda thing that keeps them lightweight :wink: … IMHO it’s good to have the choice :wink:

Amen to that :smiley:

After my last post in this thread I realised that numlockx took effect only after I was into the DE, whereas in Windows, it’s already on by the time I enter my password (which contains numbers). That reminded me that it’s usually a BIOS setting, so I looked in the BIOS, and sure enough, that was configured with numlock on.

I wasn’t going to bother mentioning it, as it’s a very small point, and apart from entering my password, numlockx does the business, but it does seem a bit odd that BIOS settings apparently act differently under Windows and Linux…

It’s NOT behaving differently in Linux.

If you watch the keyboard in Windows the numlock will be enable at POST … then go off for a split second as it transitions to being controlled by the OS and re-enabled or not depending on your settings.

I’m pretty sure it’s possible to load numlockx earlier in the boot process in Linux too … in fact IIRC, the lightdm greeter has an option to enable it at the login screen which forces it to load earlier and is remembered across boots … so does the full pantheon greeter … not sure about the lighter lightdm-gtk-greeter (as used by Peppermint and most LXDE distros) though, I’m guessing not and you’d have to do it manually somehow.

Simply “installing” numlockx causes it to load with X, so obviously only as the desktop loads … but it is possible to load it earlier with rc.local or through the greeter.
see here:
https://help.ubuntu.com/community/NumLock
As I said, it gives you the “option” to be like Windows or not. :wink:

OK. That’s another topic for my Linux ‘to do’ list.

Once again, thanks Mark.

No problem :slight_smile: