Recommend WiFi / Wireless Network 802.11g PCMCIA Laptop Card

Can anyone recommend a card that works on Linux (Peppermint) out of the box?

Thank you in advance.

As Peppermint is based on Mint 9/Ubuntu 10.04, your best bet would be to click on any of the manufacturers name in the list here:

https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported

then look under PCMCIA, in the Works “out of the box” column.

Though it’s getting a bit hard to work out now, as PCMCIA isn’t used much these days.

I’ve got 2 Linksys WPC54G’s… one version v4, and one version v7.1… the v4 was a b*tch to make work in Ubuntu 10.04 (though possible), but the v7.1 “just worked” (if I remember correctly)… If I have time tomorrow, I’ll see if I can test it with a Peppermint LiveCD… though I have no idea how hard it would be to find one now.

If you were in the UK, you could have it.

That said, most cards can be made to work, just a matter of how much work is involved.

[EDIT]

According to this test of Lubuntu 10.04 which is based on the same version of Ubuntu, and has the same LXDE desktop as Peppermint One… the D-Link DWL G630 worked “out of the box”.

This also ties in with the fact that the LinuxEmporium also sell the DWL G630 as Linux (Ubuntu) compatible.
http://www.linuxemporium.co.uk/products/wireless/

But according to this page:
https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsDlink
make sure it’s NOT the Ver:E1 hardware revision.

Thanks for all the information.

Have ordered a card from a maker on the list that you linked too. Also had positive reviews from Linux users in regards to working out of the box.

Will add something here when it arrives.

I know PCMCIA is a bit old-hat but as I am trying Linux out on a 12 year old laptop it is a requirement.

This box only has one USB port 1.1v so a usb connection will only work at around 36mbs and not 54mbs.

My present PCMCIA card is very poor performance keeps dropping the connection - PEAK 802.11g type WG2400 peakhardware.com - This website is for sale! - peakhardware Resources and Information. but then it was nothing to write home about under Windows XP.

Thanks for your help.

New card has arrived “TP-LINK” TL-WN310G has worked out of the box using the following driver ath5k included in Linux.

As per a number of other users the activity lights are not working but has been working for 2 hours with no drooped connections.

I think that closes the issue.

Thanks to all for assistance.

Thanks for the update… it’s always handy to know what hardware to recommend :slight_smile: