Removing Chromium entry in Peppermint 5 (SOLVED)

Hi Guys

As I mentioned in an earlier I’m upgrading my daughters PC and adding an account for my Grand-Daughter, but we want to restrict her accidentally or otherwise logging on to the internet and only allowing her access to her favourite websites using Ice, I’ve removed Chromium from the main menu under Internet using Alacarte but I can’t see any way remove the other Chromium entry further down the menu between Preferences & Software manager, I did this before when I first set up this PC with the help of the good folk on this forum but I can’t find the thread, can anyone tell me how I can remove that Chromium entry

Any help would be much appreciated

Graeme

In your grand daughters account … First backup the panel config file:

cp -v ~/.config/lxpanel/Peppermint/panels/panel ~/.config/lxpanel/Peppermint/panels/panel.bak

now open it for editing:

gedit ~/.config/lxpanel/Peppermint/panels/panel

remove the section that reads:-

        item {
            name=Chromium
            image=chromium-browser
            action=chromium-browser
        }

Save the file.

log off/on.

Ok i did as you instructed then logged off/on but the entry is still there, I double checked the config file and the Chromium entry has definately been successfully been deleted

Many thanks

Graeme

I juust noticed that the backup file plays havoc with the panel (half my system tray icons disappeared), so move it to your home folder:

mv -v ~/.config/lxpanel/Peppermint/panels/panel.bak ~/panel.bak

then log off/on.

No luck I’m afraid, also it moved the panel down to the bottom & changed the Menu icon back to default (I had previously changed it for a whole peppermint)

Many thanks

Graeme

post the contents of:

gedit ~/.config/lxpanel/Peppermint/panels/panel

and the output from:

ls -a ~/.config/lxpanel/Peppermint/panels

Hold on I’ve just noticed the Chromium entry has returned to ~/.config/lxpanel/Peppermint/panels/panel

Should I try removing it again ?

# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

Global {
    edge=top
    allign=left
    margin=0
    widthtype=percent
    width=100
    height=22
    transparent=0
    tintcolor=#000000
    alpha=35
    autohide=0
    heightwhenhidden=2
    setdocktype=1
    setpartialstrut=1
    usefontcolor=1
    fontsize=10
    fontcolor=#222222
    usefontsize=0
    background=1
    backgroundfile=/usr/share/peppermint/images/panel-background.png
    iconsize=22
    loglevel=2
}

Plugin {
    type = menu
    Config {
        image=/usr/share/peppermint/images/menu-four.png
        tintcolor=#000000
        system {
        }
        separator {
        }
        item {
            name=Chromium
            image=chromium-browser
            action=chromium-browser
        }
        item {
            name=Software Manager
            image=/usr/lib/linuxmint/mintInstall/icon.svg
            action=gksu mintinstall
        }
        item {
            name=File Manager
            image=system-file-manager
            action=pcmanfm
        }
        item {
            image=system-run
            command=run
        }
        separator {
        }
        item {
            image=gnome-logout
            command=logout
        }
    }
}
chloe@OurPC ~ $ ls -a ~/.config/lxpanel/Peppermint/panels
.  ..  panel  panel~
chloe@OurPC ~ $ 

OK, gedit is saving a backup as “panel~” when you save … that needs to go …run:

gedit ~/.config/lxpanel/Peppermint/panels/panel

remove the Chromium section (if present)

SAVE and exit gedit

then run:

cd ~/.config/lxpanel/Peppermint/panels

then

rm -v panel~

then log off/on

Sorry Mark that didn’t work either, it placed the panel back to the bottom and rewrote the Chromium entry

# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

Global {
    edge=top
    allign=left
    margin=0
    widthtype=percent
    width=100
    height=22
    transparent=0
    tintcolor=#000000
    alpha=35
    autohide=0
    heightwhenhidden=2
    setdocktype=1
    setpartialstrut=1
    usefontcolor=1
    fontsize=10
    fontcolor=#222222
    usefontsize=0
    background=1
    backgroundfile=/usr/share/peppermint/images/panel-background.png
    iconsize=22
    loglevel=2
}

Plugin {
    type = menu
    Config {
        image=/usr/share/peppermint/images/menu-four.png
        tintcolor=#000000
        system {
        }
        separator {
        }
        item {
            name=Chromium
            image=chromium-browser
            action=chromium-browser
        }
        item {
            name=Software Manager
            image=/usr/lib/linuxmint/mintInstall/icon.svg
            action=gksu mintinstall
        }
        item {
            name=File Manager
            image=system-file-manager
            action=pcmanfm
        }
        item {
            image=system-run
            command=run
        }
        separator {
        }
        item {
            image=gnome-logout
            command=logout
        }
    }
}

Plugin {
    type = space
    Config {
        Size=4
    }
}

Plugin {
    type = taskbar
    expand=1
    Config {
        tooltips=1
        IconsOnly=0
        ShowAllDesks=0
        UseMouseWheel=1
        UseUrgencyHint=1
        FlatButton=0
        MaxTaskWidth=150
        spacing=1
        GroupedTasks=0
    }
}

Plugin {
    type = pager
}

Plugin {
    type = tray
}

Plugin {
    type = volumealsa
}

Plugin {
    type = dclock
    Config {
        ClockFmt=%R
        TooltipFmt=%A %x
        BoldFont=0
        IconOnly=0
        CenterText=0
    }
}

Plugin {
    type = launchbar
    Config {
        Button {
            id=peppermint-logout.desktop
        }
    }
}

What’s the output from:

ls -a ~/.config/lxpanel/Peppermint/panels

now ?

chloe@OurPC ~ $ ls -a ~/.config/lxpanel/Peppermint/panels
.  ..  panel
chloe@OurPC ~ $ 

For some reason it looks like whenever I delete the Chromium entry and log out it’s re-writing any changes I’ve made to the panel back to default when I log back in

SO WTF keeps replacing it ???

Try removing alacarte … we’ll make any changes manually if necessary

sudo apt remove alacarte

Now make sure your
~/.config/lxpanel/Peppermint/panels/panel
file reads as below and is the ONLY file in the
~/.config/lxpanel/Peppermint/panels
directory,

# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

Global {
    edge=top
    allign=left
    margin=0
    widthtype=percent
    width=100
    height=22
    transparent=0
    tintcolor=#000000
    alpha=35
    autohide=0
    heightwhenhidden=2
    setdocktype=1
    setpartialstrut=1
    usefontcolor=1
    fontsize=10
    fontcolor=#222222
    usefontsize=0
    background=1
    backgroundfile=/usr/share/peppermint/images/panel-background.png
    iconsize=22
    loglevel=2
}

Plugin {
    type = menu
    Config {
        image=/usr/share/peppermint/images/menu-four.png
        tintcolor=#000000
        system {
        }
        separator {
        }
        item {
            name=Software Manager
            image=/usr/lib/linuxmint/mintInstall/icon.svg
            action=gksu mintinstall
        }
        item {
            name=File Manager
            image=system-file-manager
            action=pcmanfm
        }
        item {
            image=system-run
            command=run
        }
        separator {
        }
        item {
            image=gnome-logout
            command=logout
        }
    }
}

Plugin {
    type = space
    Config {
        Size=4
    }
}

Plugin {
    type = taskbar
    expand=1
    Config {
        tooltips=1
        IconsOnly=0
        ShowAllDesks=0
        UseMouseWheel=1
        UseUrgencyHint=1
        FlatButton=0
        MaxTaskWidth=150
        spacing=1
        GroupedTasks=0
    }
}

Plugin {
    type = pager
}

Plugin {
    type = tray
}

Plugin {
    type = volumealsa
}

Plugin {
    type = dclock
    Config {
        ClockFmt=%R
        TooltipFmt=%A %x
        BoldFont=0
        IconOnly=0
        CenterText=0
    }
}

Plugin {
    type = launchbar
    Config {
        Button {
            id=peppermint-logout.desktop
        }
    }
}

Then log off/on again.

If it still gets overwritten again … what else are you autostarting that might be overwriting the menu … cairo-dock ?

ls -a ~/.config/autostart

Success :slight_smile:

That worked but from what I can see we did nothing different we didn’t do before unless I was getting it wrong somehow, if I was i apologize

Thank you again , I’ll mark this solved

Graeme

I wanted to send you a screenshot showing the missing Chromium entry but I couldn’t keep the menu open while I took the shot but I’ve attached a screenshot anyway because I think you’ll appreciate the wallpaper :slight_smile:

EDIT
Screenshot removed

OK, that was just cruel … I even clicked it to enlarge, before realising what it was.

I dunno … try to help a fella out, and that’s what you get ::slight_smile:


[EDIT]

Can you please not “attach” screenshots or other images/files unless they’re relevant to the topic and there’s no other/better way of including them.
in all cases it’s be better to host them elsewhere, and post a link
Mad Penguin gives part of his server(s) over to the forum, but there’s limited space set aside for attachments … he’s not IMGUR/Megaupload :wink:

If it gets abused (intentionally or not), we’ll have no choice but to disable attachments.

Sorry mate

Couldn’t resist it :slight_smile:

Thanks again and goodnight :slight_smile:

Graeme

Joking aside … please see the edit above … TIA :slight_smile: