Resolution issue on Aspire One 531h [Peppermint]

Hi guys, this is my first post in this forum that i’ve just discovered. :slight_smile:

Last week i’ve know Peppermint and i fall totally in love with that (easy, everything just work and very very light) but i’ve one problem: my max resolution is 1024 x 600. When i was under Windows i was able to go to 1024 x 768 (and also up) but not now. Now are 2 days that im trying to fix it (even becouse is just a pain working without seeing all ^^" ).

So please if anyone know a solution (or even a walkaround) i will be very glad.

See you soon and Thank you,
Danno

Try creating an xorg.conf file, and copying it to the /etc/X11 directory.

You’ll want to write these instructions down, because most of it will be run without a desktop GUI

Drop to a virtual console by hitting Ctrl+Alt+F2 at the same time.

Log on with your username and password.

Run:

sudo service lxdm stop

then

sudo Xorg -configure

then

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

(the above command may fail, but just carry on with the next command)
then

sudo cp -v ~/xorg.conf.new /etc/X11/xorg.conf

When that finishes, run:

sudo service lxdm start

You should now be back at a desktop … now see if you are offered more resolutions (may require a reboot).


If anything goes wrong, you can always just rename the /etc/X11/xorg.conf file

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.broken

and reboot … you’ll be back to where you are now.

REMEMBER … Linux commands ARE case sensitive, so be sure to use a capital X where shown.

According to this spec the resolution for Aspire One 531h is 1024 x 600:
http://support.you.gr/catalog/8D/8D7C834DFC7D0D41A6FFE5BD42C93C39.pdf

Display 10.1" SD 1024 x 600 (WSVGA) pixel resolution, high-brightness (200-nit) Acer CrystalBriteTM LED-backlit TFT LCD
Can you get higher resolutions than that stated by the manufactures?

SeZo appears to be right … everywhere I look on the web states the MAX resolution as 1024x600 for the 531h ???

Thanks for your reply guys :slight_smile:

I can absicure you that (under windows, to be honest) im able to reach 1024 x 768 and more (by changing a key into regedit), for this i suppose that must be a way also in linux, im not right?

Btw i’ve tried your solution Mark, but it seems that peppermint doesnt have xorg (im sorry, but im arent in the linux world for a couple of years, so i dont know the news about recent change ^_^").

Again Thank you for your help :slight_smile:

P.s.
Did you know if there is any way to zoom or adapt the various programms that doesnt fit with 1024x600?

I KNOW Peppermint doesn’t have an /etc/X11/xorg.conf file by default … but if one is present IT IS USED, which is why I sent instructions on how to generate one.

It may be possible to force non-native resolutions (though I probably wouldn’t advise it) … but they would have to be added to xorg.conf … so you’d have to create one first.

Hey Mark, first of all, thank you for your help.

Unluckly your commands seems wrong: i’ve tried all the things that you have wrote and i get an error like “number of created screens does not match number of detected device”.

Looking via google for it i’ve seen that xorg.conf become deprecated and that now all the configuration is in /usr/share/X11/xorg.conf.d (and actually i have this folder). I’ve tried to add a new file (10-monitor.conf) like i’ve read on some others place, but it seems not work at all. Any other suggestion to force my resolution? (actually it’s terrible working on 1024x600 but honestly i dont want get back to windows just for it :slight_smile: )

I’ve already answered that … if you CREATE an xorg.conf file (which you’ve already done but it’s probably still in your home folder), then copy it to /etc/X11/xorg.conf it WILL be used.
(depreciated does not mean it won’t work)

You can then edit it to add resolutions.

If you choose not to believe me … fine, but I can only tell you what I know to be true :wink:

You are totally right, the xorg.conf is in my home folder but i dont have seen it ^_^“”"

Sorry for the mistake, i will try it now and tell you if works :wink:

Update:

Ok, now xorg.conf is in the right folder, but seems that notthing have changed.

It probably won’t work on its own … you’ll have to rename it from xorg.conf.new to xorg.conf and move/copy it to your /etc/X11 directory.

You’ll then have to edit it to add a mode line.

See here:
https://wiki.ubuntu.com/X/Config/Resolution

i’ve tried to add at xorg.conf (section screen 0) the following lines:

DefaultDepth 16 #Choose the depth (16||24)
SubSection “Display”
Depth 16
Modes “1024x768” #Choose the resolution
EndSubSection

But still nothing change. It’s pretty strange even becouse when i tried to add a new modeline by xrandr it add on VGA1 (that result disconnected) and not on LVDS1 (that is active)

Guys, It might be worth to looking into scaling the display (see here)

Sadly no, SeZo. I’ve already try to scaling and even if it works the mouse wasnt able to reach the bottom menu :confused:

I dunno if it is a Peppermint issue or not but from all the distros I tried on my AA1 (using the native resolution)
only found a problem with Bodhi (E17) where the dialog boxes were too big for the screen.
I ended up changing the default display font size in the theme (at least that is what I remember)
and that has resulted with a corresponding reduction in the dialog box sizes.
Unfortunately cannot check now as I have changed it to Archbang (no problem there)

OK, for the time being (whilst I work on this) … lets rename xorg.conf to xorg.conf.broken:

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.broken

Now REBOOT

Then try this in a terminal:

xrandr --output LVDS1 --mode "1024x600" --scale "1x1.28".

does that do what you want ?

As I’m having issues getting xrandr to set a new modeline that LVDS1 will accept.

If that works (and it does on my AA1), I’ll document how to autostart it … if not, leave it with me and keep checking back till I find a working solution.

and post the output from:

xrandr

and

xrandr -q

Unluckly dont work Mark.
The resolution are good but my mouse cant go to bottom (like the resolution where it can move is still 1024x600).

Here is my result for xrandr

max@max-AO531h:~$ xrandr 
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 223mm x 125mm
   1024x600       60.0*+
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)

and xrandr -q are the same (but i’ve just noticed that now the resolution here are the right one)

Sorry for the double post, but i’ve solved the problem and now all things work fine :slight_smile:

So, first of all you must do this patch:

sudo apt-add-repository ppa:mdeslaur/testing

and than


sudo apt-get update

After this reboot and

xrandr --output LVDS1 --mode "1024x600" --scale "1x1.28"

It work perfectly for me, and now im on 1024x768 :slight_smile:

Now i just need to know how can i set this permanent and the work is over! Again ty all! :slight_smile:

OK, lets create an autostart .desktop file:

gedit ~/.config/autostart/monitor-adjust.desktop

When a blank file opens, make it read:-

[Desktop Entry]
Name=Monitor Auto Adjust
Comment=Change LCD resolution to 1024x768
Exec=lxterminal --command xrandr --output LVDS1 --mode "1024x600" --scale "1x1.28"
Terminal=true

SAVE the file … reboot, or log off/on to test


Thanks for the PPA instructions, it may come in handy for anyone else with a 531h … it wasn’t necessary on my AOA110L :slight_smile: … maybe a different graphics adapter, or something I’ve done previously

Perfect, now i have a netbook with 1024x768 resolution!

Mark, you’re a saint! ;D

Heh … I wouldn’t go quite that far :wink: