Restore Audio Setting

Dose anyone know how to restore the default audio settings in Peppermint One?

Details of my system.

~ $ inxi -F
System: Host smalllaptop Kernel 2.6.35-22-generic i686 (32 bit) Distro Peppermint
CPU: Single core Pentium III (Coppermine) (UP) cache 256 KB flags (sse) bmips 1049.46 clocked at 524.730 MHz
Graphics: Card S3 86C270-294 Savage/IX-MV X.Org 1.7.6 Res: 1024x768@60.0hz
GLX Renderer Mesa DRI Savage/MX/IX 20061110 x86/MMX/SSE GLX Version 1.2 Mesa 7.7.1 Direct Rendering Yes
Audio: Card Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] driver Sound Fusion CS46xx
Sound: Advanced Linux Sound Architecture Version 1.0.23
Network: Card-1 Intel 82557/8/9/0/1 Ethernet Pro 100 driver e100 v: 3.5.24-k2-NAPI at port 1800
Card-2 Atheros AR5007G Wireless Network Adapter driver ath5k v: 0.6.0
Disks: HDD Total Size: 20.0GB (33.0% used) 1: /dev/sda IBM-DJSA-220 20.0GB
Partition: ID:/ size: 18G used: 6.2G (38%) fs: ext4 ID:swap-1 size: 0.88GB used: 0.06GB (7%) fs: swap
Sensors: System Temperatures: cpu: 51.0C mobo: 0.0C
Fan Speeds (in rpm): cpu: 0
Info: Processes 117 Uptime 4:01 Memory 408.4/496.6MB Client Shell inxi 1.3.2

I don’t understand what you mean by “restore the default audio settings”… how were they changed ?

If you create another account, does the new account have what you mean by “default audio settings” ?

First things first, when I logged in this morning the panel at the foot of the screen has vanished, so I can not access any programs, how do I get it back?

The audio issue will have to wait.

OK, try this…

open a terminal… you can do this by hitting Alt+F2 typing lxterminal and hitting Enter.

In the terminal, run:

mv -v ~/.config/lxpanel ~/.config/lxpanel-old

then enter this to reboot (you must reboot for the changes to be applied):

sudo reboot

That should put the panel back to default.


If that doesn’t work, open a terminal and enter:

sudo apt-get install --reinstall lxpanel

and reboot.

Thanks the second option worked OK. Back to the Audio issue, I was having problems with SKYPE Audio skype was not recognising my mic plug in or on-board though I could hear my self in the headphones when talking. The sound recorder was also not working.

A recommended fix was to install Pulse Audio. However, there was a conflict with the existing program called sound mixer so I uninstalled it and installed Pulse Audio. Now there is no sound when playing MP3 files and Skype still is not working.

If I run a live CD will the package manager tell me what programs were installed?

Erm… pretty much, but not necessarily 100% accurately… not exactly the same packages are pre-installed on the LiveCD as will be installed to a hard drive… take the Gparted partition manager for example, it’s available on the Ubuntu LiveCD, but has to be manually installed after installing Ubuntu to a hard drive.

installing a log file viewer, such as gnome-system-log:

sudo apt-get install gnome-system-log

(yes, I know it’s for GNOME, but I’ve tested it in peppermint on a VM)

Then starting it from Menu>System Tool>Log File Viewer, and looking at the dpkg log should tell you what was install/uninstalled and when.

or if you don’t want to install the gnome-system-log viewer, you can just open the dpkg.log in gedit:

gedit /var/log/dpkg.log

Also if you open the apt log in gedit it may give a clue what you uninstalled:

gedit /var/log/apt/history.log

Thanks for the tips have restored GNOME ALSA mixer and a couple of other ALSA files and sound is now OK.