Rogue mouse (solved)

I’m having a bit of mouse trouble.

Using the scroll wheel to scroll down works fine, but scrolling up usually results in Firefox jumping back to a previous page.

I can’t find any way to change settings for the mouse wheel (Ubuntu 14.04 LTS).

Obviously I can get round this by not using the wheel to scroll up, but a solution would be nice…

In firefox enter

about:config

into the address bar and hit enter … acceept the “Dragons” warning

in the search box enter:

mousewheel.with

in the resulting list, have any of the setting (except “with_shift.action” got a value of 2
?

Could you have a stuck shift key ?

No. No other values of 2.

And no stuck shift keys. I’m very fussy about the cleanliness of my keyboards!

What’s the output from:

ls /etc/X11

Here it is

mike@mike-abit:~$ ls /etc/X11
app-defaults rgb.txt Xreset Xsession.d
cursors X Xreset.d Xsession.options
default-display-manager xinit Xresources xsm
fonts xkb Xsession Xwrapper.config
mike@mike-abit:~$

Is this some weird wireless mouse/ game mouse ?

if so, what’s the make/model ?

is this behaviour ONLY in firefox ?

is this a laptop ? … does touchpad scrolling work in firefox ?

Have you tried a different mouse ?

What’s the output from:

xinput list

Bog standard wired, optical Microsoft intellimouse. Only noticed it in FF.

Not a laptop, but now I come to think of it, it’s a USB mouse connected via an adapter to a PS2 KVM switch. Clearly I need to embark on a process of elimination! I’ll do that and get back to you.

For info, the result from xinput list is

mike@mike-abit:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ImExPS/2 Generic Explorer Mouse id=9 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=8 [slave keyboard (3)]
mike@mike-abit:~$

Got to sleep now. Don’t spend any more of your time on this until I’ve tried the process of elimination…

Thanks Mark.

M

It’s going to be a little while before I get round to this… my Ubuntu box just died on me! Might be the video card, might be the motherboard, but I’ve got a lot on my plate just now, so it’ll take a while to troubleshoot this.

Bum! Just as I’d decided Linux was the way to go, I find myself using a spare XP machine. At least this confirms one thing - I’ve made the transition to Linux, even though I’ve still a huge amount to learn. It’s really annoying me that things in XP are in the ‘wrong place’.

I’ll be back, as the big Austrian bloke says.

M

Sorry to hear you’re having to use XP … I feel for you :frowning:

Hello Folks,

Just checking in to let you know that I will get back to this asap.

I won’t bore you with the details, but I’m preoccupied with stuff far more important than computers right now. When the dust settles I’ll get back to Linux and shake off XP and Vista, in which I’m typing this on an old laptop…

Hooray!

Just swapped the video card and I’m back in Ubuntu. For once, it seems the cheaper, easier solution has worked.

Not only that, the mouse seems to be behaving properly too (mind you, the KVM switch isn’t part of the current equation). I’ll confirm/refute that when I’ve had a bit more time to test it out.

M

Great news :slight_smile:

Ok it’s been about a week now, and the mouse has behaved itself perfectly. Looks like the KVM switch was the guilty party.

Thanks for your input Mark.

No problem, glad you found the culprit :slight_smile:

Just realised I never marked this solved.

Doing so now.