Scanners in Linux-SOLVED

I just did what you posted first time Mark- doing the above now.

melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ sudo apt-get install xsane sane-utils
[sudo] password for melissa:
Reading package lists… Done
Building dependency tree
Reading state information… Done
sane-utils is already the newest version.
xsane is already the newest version.
The following packages were automatically installed and are no longer required:
libkcmutils4 libnepomukdatamanagement4 qapt-batch libclucene0ldbl
kubuntu-debug-installer libqca2 language-pack-en-base libutempter0
libkdeclarative5 libkjsembed4 language-pack-kde-en oxygen-icon-theme
libwxgtk2.8-0 libkemoticons4 libkdecore5 phonon libkidletime4 docbook-xml
libqt4-qt3support docbook-xsl shared-desktop-ontologies amarok-common
kdemultimedia-kio-plugins libdlrestrictions1 language-pack-kde-en-base
odbcinst kde-l10n-engb libkcddb4 libntrack-qt4-1 kde-runtime-data
libkatepartinterfaces4 libsolid4 virtuoso-minimal libkde3support4
libnepomuk4 libkdewebkit5 libsoprano4 libpolkit-qt-1-1 libqtscript4-core
libkdnssd4 libkparts4 libqapt1 kdelibs5-data libwxsqlite3-2.8-0 kdoctools
libvirtodbc0 odbcinst1debian2 libmygpo-qt1 libwxbase2.8-0 icoutils katepart
libqtscript4-gui libqtscript4-uitools libthreadweaver4 libnepomukutils4
libkmediaplayer4 libntrack0 libkfile4 libknewstuff3-4 libqapt-runtime
phonon-backend-gstreamer libkpty4 libnepomuksync4 libstreamanalyzer0
libphonon4 libknotifyconfig4 libkntlm4 libplasma3 libqtscript4-sql
libexiv2-11 kdelibs-bin libktexteditor4 libqtscript4-xml firefox-locale-en
kde-runtime sgml-data libkio5 libkjsapi4 libstreams0 libtag-extras1
libxml2-utils libattica0.3 language-pack-en virtuoso-opensource-6.1-common
plasma-scriptengine-javascript libssh-4 soprano-daemon amarok-utils
libkhtml5 libkdeui5 libkdesu5 libqtscript4-network kdelibs5-plugins
amarok-help-en virtuoso-opensource-6.1-bin kate-data ntrack-module-libnl-0
libkrosscore4 libnepomukquery4a
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 111 not upgraded.
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ scanimage -L
device `gt68xx:libusb:003:005’ is a Mustek BearPaw 1200 CU flatbed scanner
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $

What’s the output from:

scanimage

and

ls -a /usr/share/sane/gt68xx

melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ scanimage
[gt68xx] Couldn’t open firmware file (`/usr/share/sane/gt68xx/PS1fw.usb’): No such file or directory
scanimage: open of device gt68xx:libusb:003:005 failed: Invalid argument
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ ls -a /usr/share/sane/gt68xx
. … PS1Dfw.usb PS1Dfw.usb.1 PS1Dfw.usb.2
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $

Run these commands in sequence

cd /usr/share/sane/gt68xx

then

sudo wget http://www.meier-geinitz.de/sane/gt68xx-backend/firmware/ps1fw.usb

then

sudo chmod 755 /usr/share/sane/gt68xx/ps1fw.usb

then

sudo mv -v /usr/share/sane/gt68xx/ps1fw.usb /usr/share/sane/gt68xx/PS1fw.usb

Now see if the scanner works … if not, what’s the output from:

scanimage

now ?

It worked Mark! Thank you very much. I chose it as text and it saved as a pdf- I want to be able to have it as Libre office document so I can edit- how’d I convert it?

Scanners save as images, not editable text.

If you want to be able to edit the text it has to pass through some optical character recognition (OCR) software … which -

a) is notoriously unreliable (in Windows)
and
b) I’m not sure what OCR software (if any) is available for Linux.

Off to do dinner … but I’ll have a look for available OCR software later and post what I find (if anything).

Thanks Mark- doing my dinner also!

Hey Mark, I found this:

http://pdftoword.pro/

It isn’t perfect- the text saves with weird line breaks and some of the spellings in random words are rather odd- but at least it is editable now and pastable in to another document.

Well if you’re happy with that we’ll leave this then.

If not, there’s tesseract/yagf in the repo’s … but after a quick test it’s not very accurate.

You can set Xsane to scan to a text file. On mine it was set to use gocr as the OCR/text client.
Then change the file type to be saved as text, and scan.
I do not use it so cannot comment on how effective it is in recognising the characters.
You may need to install gocr:

sudo apt-get install gocr

In Xsane go to Prefrences->Setup->OCR

I have X sane but it doesn’t recognise the scanner.

Well it will do for now Mark- something will be developed that’s better one day!