Schizophrenic USB stick?

I gave to a friend an old desktop with Peppermint 5 installed. It has been fine from an operational point of view but I have an interesting problem.
In anticipation of persuading my friend to back up her college work I needed to know the GB of her USB stick. Easy! Right-click on its entry in File Manager and select Properties. But this is what she got:
Open in new tab
Open in new window
Open in terminal
Unmount volume
Eject removable medium

No sign of “Properties”

Being a resourceful chap I suggested df /media/USB_name but the result was “No such file or directory”.
A simple ls /media does not show any attached USB stick, either.
My friend can move files between the stick and the PC without difficulty, so although File Manager believes it is present, the rest of the system pretends that it isn’t.

It’s 65 miles away so I can’t do much testing except by Teamviewer, and then only occasionally, but if you have any ideas I would appreciate it.

Just open the USB stick in file manager … and its size and unused space will be displayed in the bottom of the file manager window (status bar)

I’ve just tried that on my Peppermint 3 laptop but it doesn’t show anything but the USB name in a task-bar tab - jpg attached.
Perhaps P5 is different.

when I need to know the size of a stick, after plugging in, I go to menu>accessories>disks, this will show the size of all disks and free space,

This is on peppermint 3 and 5.

Hope that helps.

Keith

Thanks Keith; that worked a treat!

Keith

… but it would still be useful to know why I can’t list the device via the command line as I often find it convenient to manipulate files in that way.
Any ideas, anyone?

OK

a) I didn’t mean on the bottom panel … I meant on the bottom of the File Manager window.

http://linuxforums.org.uk/MGalleryItem.php?id=1602

b) USB sticks are usually mounted at /media//<USB_stick_name>

eg:
/media/mark/4GB-STICK

c) the easiest way to find where it is mounted is with the

mount

command … which will list where things are mounted.

d) if it’s mounted:

df -h

will give you Filesystem / capacity / used / free space /used as a percentage / and the mount point.

eg:

[b]mark@AA1-Blue[/b] [b]~ $[/b] df -h Filesystem Size Used Avail Use% Mounted on /dev/sda1 13G 7.1G 4.9G 60% / none 4.0K 0 4.0K 0% /sys/fs/cgroup udev 675M 12K 675M 1% /dev tmpfs 137M 1.3M 136M 1% /run none 5.0M 0 5.0M 0% /run/lock none 684M 220K 684M 1% /run/shm none 100M 16K 100M 1% /run/user /dev/mmcblk0p1 3.7G 3.0G 728M 81% /media/mark/4GB-SDcard //172.16.0.99/share 452G 313G 140G 70% /media/Linkstation/Share //172.16.0.99/Torrents 452G 313G 140G 70% /media/Linkstation/Torrents [b]/dev/sdb1 3.8G 1.4G 2.4G 37% /media/mark/4GB-STICK[/b]

Thanks for all this info, Mark.
Quote " USB sticks are usually mounted at /media//<USB_stick_name>" .
My P3 machine doesn’t show the username:
keith@D505 ~ $ df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sda1 47048648 20755496 23903188 47% /
udev 504844 4 504840 1% /dev
tmpfs 102428 948 101480 1% /run
none 5120 0 5120 0% /run/lock
none 512128 76 512052 1% /run/shm
/dev/sdb 3782096 731276 3050820 20% /media/New Volume
keith@D505 ~ $

… but my friend’s PC is P5 which might be different. It’s not important anyway.

My need is not just to find the size of the stick but to be able to view and manipulate its contents via the terminal, and the offending PC does not list anything with the ls /media command. From memory, it doesn’t list it with df either, but I shall have to check.

But I shall have to wait until I have access to the PC via Teamviewer, which might take a while. I shall report back.

[EDIT] Just out of interest: I use gnome fallback (classic view) which has a “Places” item in the top bar. Using this to get to a file manager does not display the device size at the bottom of the screen. Selecting File Manager from the accessories menu does display the size. How odd.

You’re right … I was talking about Peppermint 5, Peppermint 3 usually mounts them at /media/


OK, the problem seems to be that the stick hasn’t got a valid partition table

[b]/dev/sdb[/b] 3782096 731276 3050820 20% /media/New Volume

Should really read:

[b]/dev/sdb1[/b] 3782096 731276 3050820 20% /media/New Volume

Also if you’re going to give it a label, best not to use “New Volume” as it has spaces in the name.


Copy everything off the USB stick, then used GParted to create a new msdos partition table … then create a single new FAT32 partition.

Let me know if you need help with this.

I think we are talking at cross-purposes here. The “New Volume” stick is here in Oxford on my own P3 laptop - I was showing it to demonstrate that the username does not appear in /media//USBname
Although there may well be a problem with its partition table it works fine and I can access it via a terminal:

keith@D505 ~ $ ls /media
New Volume
keith@D505 ~ $ ls /media/“New Volume”
autorun.inf casper ldlinux.sys menu.c32 preseed ubnfilel.txt ubnkern
boot isolinux md5sum.txt mint4win.exe syslinux.cfg ubninit ubnpathl.txt
keith@D505 ~ $

(It’s my Mint Live Disc)

The problematic USB stick is in Birmingham on my friend’s P5 desktop. Although I was hoping to do something using Teamviewer, I think it might be best if we wait until I visit B’ham on the 13th December and I can revive this post with the PC in front of me. Sounds good?

If the USB stick can be accessed via the file manager then it’s mounted.

If it’s mounted:

mount

will tell you “where” it’s mounted

Good idea, and one that my computer-phobic friend can cope with.
I shall report back when I get a chance to try it out.

My thanks as usual.
Keith

Found the problem by using “df” command:
When there is more than one registered user, the USB is shown as being in /media//<usb_name>.
When there is only one registered user, it’s just /media/<usb_name>.

Thank you Mark, as usual.
Keith