Screen crash then no boot

Hi guys

Recently I’ve managed to to covert the missus to Linux and she couldn’t have had the worst possible start, it began when her PC running Win XP packed up with motherboard failure so I had an old PC lying around I set up for her as a stop gap until I got her something better it actually had fairly decent spec and run PM4 beautifully except for a network error that was just impossible to fix, then I got her another PC (second hand) installed PM4 and it ran beautifully everything worked and she was well happy, untill last night when the screen froze so she hit the off button switched off the PC and switched on again only to find it stuck on the Peppermint splash screen and go no further, strangely enough a similar thing happened to me with my PC shortly after installing PM4 for the first time and only a full re-installation would put it right, I’m hoping I don’t have to in this case

I thought this might be a graphics issue so I removed the nvidia graphics card and switched over to onboard and at first i thought it was gonna boot because It went passed the splash screen the cursor popped up then a floating box appeared saying “no signal input” indicating it’s not getting a graphics signal it would then alternate between the cursor (which I can move) and the no signal message

any help would be much appreciated

Many thanks


If she hit the power button to turn it off , what’s stopping it booting is liable to be a file system error (unless it’s a hardware failure, such as HDD).

Boot a LiveCD/LiveUSB and post the output from:

sudo fdisk -l

and we’ll run fsck on the root partition.

Unless it’s a failing HDD that is unlikely to have caused the initial lockup though

Ok thanks

I’m at work but I’ll do that when I get home

Many thanks


ok believe it or not it refused to boot into a PM4 live session, all I got was garbled graphics so I tried with the onboard and it got past the splash screen but then all I got was alternating cursor and a black screen, I did manage to boot into a Linux Lite live session, so here’s the out put you asked for

linux@linux:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000af57d

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    78262216    39130084+   7  HPFS/NTFS/exFAT
/dev/sda2        78262270   156301311    39019521    5  Extended
/dev/sda5        78262272   152109055    36923392   83  Linux
/dev/sda6       152111104   156301311     2095104   82  Linux swap / Solaris

Disk /dev/sdb: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00043822

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048   156119039    78058496   83  Linux
/dev/sdb2       156121086   160835583     2357249    5  Extended
/dev/sdb5       156121088   160835583     2357248   82  Linux swap / Solaris

Question … what other OS’s are on this PC, and do they boot ?

The 80gb hard drive (sda1) has 2 operating systems PM4 & Windows 7, I also have Linux Lite installed on a seperate 40gb drive (sda5) only Linux Lite will boot.

Sorry I never tested the windows partition before I posted the original post, but I’ thought I’d test it before I posted this and sure enough it wont boot either.

If your gonna tell me the HDD is faulty and I’m gonna have to reinstall all this again I will kill myself

How do you boot from the second HDD … from GRUB on the first, or by changing the boot order in the BIOS ?

I’m sure it’s from GRUB on the first HDD,

do you want me to check in the bios to see for definate what the boot order is ?

Whatever it is … boot to Linux Lite (don’t do anything that might mount /dev/sda5) and run:

sudo fsck -f /dev/sda5

and see if it fixes things.

do you mean the live session or the installed one ?

Doesn’t matter, just as long as /dev/sda5 ISN’T mounted when you run fsck.

Ok i did it in the live session but it still wont boot into PM4 it just sits on Peppermint splash screen with the red strip below and wont go any further

Do you know how to remove these 3 terms -

quiet splash $vt handoff

from GRUB’s kernel boot line for Peppermint 4 ?

So we can see how far the boot gets.


and did fsck find any errors ?

Do you know how to remove these 3 terms -

Yes I’ll try it and get back to you

doesn’t seem to give much away there are no errors it jus stops

The last few lines are

  • stopping save kernal Messages [ok]
  • starting [ok]
  • starting [ok]
  • starting team viewer remote control daemon [ok]
  • starting regular background processing daemon [ok]
  • stopping cpu interupts balancing daemin [ok]
  • stopping save kernel messages [ok]
  • starting adaptive readahead daemon preload [ok]
  • stopping systemv runlevel compatibility [ok]
  • starting [ok]
  • starting [ok]
  • stopping [ok]


and did fsck find any errors ?

Sorry I didn’y pay any attention I just ran it closed the terminal the rebooted but I’ll go do it again

Just as a matter of interest … will it boot an earlier kernel ?

Just as a matter of interest .. will it boot an earlier kernel ?

I tried that this morning it’s just the same in fact it wouldn’t even boot into recovery mode with the nvidia card but it would go into recovery with the onboard

I’m a bit confused with this command

sudo fsck -f /dev/sda5

excuse my ignorance but how can I run that command in the installed Linux Lite when Linux Lite is installed on that partition (sda5) if you didn’t want me to mount it ?

Ok I ran sudo fsck -f /dev/sda5 again in Linux Lite live session and no errors reported

I thought you said Peppermint was on sda5 ?

if you boot normally, when it appears to stop, are you able to drop to a console with Ctrl+Alt+F2

if so, what happens if you log on and run:

sudo service ligtdm restart

Did you say it will no longer boot a Peppermint LiveCD/LiveUSB that it used to boot ?