Screwed up fonts in LO

no such file or directory, eveb tried ‘.fonts’ and when in the folder with .font(s) visible and even inside the folder, even tried upen in terminal and nothing?

Not 100% sure what you’re saying there … first you suggest there IS no ~/.font directory, then you seem to suggest you entered it ???

Is there a (hidden) .font directory in your Home directory ?

ls -a ~/

Is there anything in it ?

In defense of pooky2483 the previous command had a typo in it.:slight_smile:
Should have been:

ls -a ~/.fonts

Oops … My apologies :-[

I see the bored admin is now mistakenly making typo’s. :stuck_out_tongue:

Careful … I just may suggest a search to see who’s made the most mistakes :wink:

Though I suppose there’s a risk I’d loose that too :o

still the same error :o

Thats a mistake there… You mean WIN it!

He has more posts than me, it is most likely he would lose haha.

Pooky, you can make a “.fonts” if it’s not there. I know I had too in Peppermint. :slight_smile:

OK, smart Alec, maybe I should have said “search to see who’s made the LEAST mistakes” … but when I said “I suppose there’s a risk I’d loose that too”, how do you know I didn’t mean that I’d loose in a competition of who made the most mistakes (meaning I made the fewest errors) C:-) … ahaaaa, get out of that one :wink:

What exactly is

ls -a ~/.fonts

trying to do?

It just lists the files contained in .fonts directory

for clues as to what a given command does and the commands options etc. … see its man (manual) page … or its info page … as in:

man ls


info ls


man sudo


info sudo


Dont ask me what I did as I didnt do anything and it just worked now;
peter@Petes-ubuntu-pc:~$ ls -a ~/.fonts
. adam_gorry_inline.otf Aldo_Open.otf
… adam_gorry_lights.otf AleksandraC_regular.otf
20db.otf Aerolite Bold Italic.otf AleksandraC_vintage.otf
abeatbyKaiRegular.otf Aerolite Bold.otf Alex.otf
acid_bold_italic.otf Aerolite Italic.otf Alido.otf
acid_bold.otf Aerolite.otf helvetica
acid_italic.otf Aerolite Sky Italic.otf Library
ACIDL___.otf Aerolite Sky.otf My_fonts
acid_medium_italic.otf After_Disaster.otf Read Me.txt
acid_medium.otf AlbertTextBold.otf vibocentric
acid.otf Alcefun.otf

OK, if font-manager is still NOT working … first lets see if renaming the ~/.fonts directory then updating the font cache will make it work
(this will effectively remove the fonts you added … we can put them back … but it will tell us if it is something in that directory that is causing the problem)

With font-manager CLOSED, run:

mv -v ~/.fonts ~/.fonts-backup

now run:

sudo fc-cache -fv

NOW open font-manager and see if it works.

If it works … we may have to add those fonts one at a time till we find the broken one.

You can get back to where you were by running:

mv -v ~/.fonts-backup ~/.fonts


sudo fc-cache -fv

The fonts I added are in ‘.fonts/My_fonts’

Thats gonna take a looooooooooooooooooooooooooooong time, I’ve got over 3000 fonts :o

As has previously been mentioned … if you can’t be bothered … just uninstall font-manager, it’s not necessary anyway :wink:

But no harm in checking that’s where the problem lies :slight_smile:

Up to you.


Quick question … where did you get the fonts ? … copied directly from a Windows PC ?

3000+ fonts, are you a professional author, or do you just have a font fetish … does Garamond/Helvetica/Ariel turn you on or something :wink:

I've got over 3000 fonts

Wow… Then I thought that my son was “Mr. Fontman”. ???

Have done

Got them from here

[QUOTE]3000+ fonts, are you a professional author, or do you just have a font fetish … does Garamond/Helvetica/Ariel turn you on or something :wink:
Nah, just got loads and I’m slowly going thru them and keeping the ones I really want