Setting up a printer in OOo4kids (Open Office for kids) (SOLVED)

Hi Guys

I’ve installed OOo4kids on my Grand-Daughters PC which is and Office suite based on Open Office but I can’t connect to the printer I’m only offered “Generic Printer & ”.

The program comes with a separate printer administration program with an add printer wizard but my printer model isn’t listed, I have an option to “Import” and when I select that it asks for a driver, I have a .ppd file for the printer located an “Downloads” but when I navigate there it doesn’t show it so I assume it must be the wrong file type

Any help would be much appreciated

Graeme

Have you tried bunging the PPD somewhere else, such as your home directory ?

I’m guessing this is based on a quite early version of OOo

I would have expected it to have just “known” about printers already added to CUPS, and not have needed them adding again through spadmin anyway.

Have you tried bunging the PPD somewhere else, such as your home directory ?
I tried that but it made no difference

It has a separate admin application for setting up the printer probably because it’s a childrens program (Gcompris is the same)

Anyway I downloaded the universal driver from the Samsung site and extracted the zip file in Downloads and I can navigate to there it then seems to find the driver and adds the printer to the list of printers, so I can highlight the printer and click next on the next screen it’s asking me to enter “a command line appropriate for the device”

I don’t have a clue what that means

Graeme

Here’s what I mean…

Do you have a PC with LibreOffice on it ? … if so run:

/usr/lib/libreoffice/program/spadmin

am I right in thinking that’s the same dialog window ?

LibreOffice does NOT require you to add printers that way as it should pick up the CUPS ones.


Anyway, I think it wants a command like:-
lp -d

lpstat -p -d

should list available destinations (printers)

Source:
http://www.openoffice.org/docs/setup_guide/appendix.html

am I right in thinking that's the same dialog window ?

No it’s a different window

chloe@Linux3 ~ $ lpstat -p -d
printer Samsung-CLP-320 is idle.  enabled since Sat 08 Nov 2014 13:49:08 GMT
no system default destination
chloe@Linux3 ~ $ 

Could it be there’s no destination found due to this being a network printer ?

Here’s a video showing the procedure maybe that will help explain it better

http://videobin.org/+89w/b37.html

Many thanks

Graeme

Did you try

lp -d Samsung-CLP-320

as the command ?

Unfortunately that made no difference, when I try to print a document the printer dialogue box flashes up for a millisecond saying “preparing to print” but nothing is printed

Here is where I’ve downloaded the driver I selected the Linux version it’s the only option, I downloaded it to Documents and extracted it and when I run the printer wizard I’m navigating to the extracted folder

Many thanks

Graeme

try

lpr -P Samsung-CLP-320

Sorted :slight_smile:

That got it working

Many thanks (I don’t know what you’d do without me ) :slight_smile:

Graeme

No worries :slight_smile: