Setting up static IP addresses - How do I

I have a Netgear WNR2200 and I want to set static IP addresses to my devices but I’ve forgotten how I did it before.

Connected devices;
Kubuntu Desktop
Peppermint Desktop
Win7 Lappy
HP Offiejet 4630
HP Deskjet 3070A

I’ve also noticed;
HP 3070A 192.168.0.6
HO 4630 192.168.1.4
Peppermint 192.168.1.2
Kubuntu 192.168.1.3

Any ideas why the 3070A is 192.168.0.6 and the rest are 192.168.1.***
Can I change the 3070A to 192.168.1.*** or is it stuck at that?

No it’s not stuck at that.

What’s the IP address of your router ? … 192.168.1.1 maybe ?

And what are the current settings in your router for the DHCP pool ? … 192.168.1.2 ↔ 192.168.1.254 maybe ?

Yep, router IP address is 192.168.1.1
DHCP is 192.168.1.1 - 192.168.1.200

Set the DHCP pool from say:
192.168.1.201 ↔ 192.168.1.254
(that gives you everything between 192.168.1.2 ↔ 192.168.1.200 ‘inclusive’ for static IP’s … ie. they will never get automatically assigned by your router via DHCP).

Now give all PC’s/Devices a static IPv4 address of:-

IP - 192.168.1.n (where ‘n’ is a number from 2 to 200 ‘inclusive’ … but no 2 devices should have the same static IP)
NetMask - 255.255.255.0
Gateway - 192.168.1.1

DNS server - 192.168.1.1 (if you have DNS problems, this/these can be set to either your ISP’s DNS addresses or those of OpenDNS or Googles DNS servers)

Set IPv6 to “Ignore”

Did that make sense ?

Just writing things down so I don’t need to keep refering back here swapping tabs over.
Also, any idea how I can change the IP address of my HP3070?
I can easily change the IP address of the 4630 as it can be done using the OSD on the printer.

Not working.
I set the DHCP range to 201 - 254
Then try to set my PC to 192.168.1.5
I am then informed that I should select an IP in the range of 201 - 254

Informed by what ?

In NetworkManager have you changed the “Method” to “Manual” on the IPv4 tab … then entered the details as above ?


any idea how I can change the IP address of my HP3070?

Do you get a configuration page for the 3070 if you browse to
http://192.168.0.6
in a web browser ?

ifconfig

eth1 Link encap:Ethernet HWaddr 78:24:af:35:97:e7
inet addr:192.168.1.201 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::7a24:afff:fe35:97e7/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:405106 errors:0 dropped:0 overruns:0 frame:0
TX packets:253236 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:514893022 (514.8 MB) TX bytes:41724958 (41.7 MB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:115375 errors:0 dropped:0 overruns:0 frame:0
TX packets:115375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:302847679 (302.8 MB) TX bytes:302847679 (302.8 MB)

Why is it eth1 and NOT eth0 ???
That’s why I think the HP307 is 192.168.0.6 and not 192.168.1.6

To change the ipv4 I can’t see anything in the Netgear settings pages, do you mean in the settings on the PC itself?

Regarding the range, I was informed to stay in range by the router settings page (Netgear)

You DON’T change ANY settings on the router other than the DHCP pool beginning and ending addresses.

Static IP addresses are then assigned on each PC/device.

In Ubuntu that will be in NetworkManager.

[EDIT]

If the router still moans, put it back to how it was before … and we’ll use static IP’s in the range 201 ↔ 254 … which will fall outside the DHCP default pool.

Network Manager, you mean here…

http://imagizer.imageshack.us/v2/480x400q90/911/hcMvBT.jpg

I can’t enter anything in the DHCP Client ID section.
What am I supposed to enter in the area with the blue strip, ‘Address Netmask Gateway’ ?

Start from scratch then…

OK, starting from scratch …

What is the routers IP
and what are the routers current DHCP pool settings.

IP Address 192.168.1.1
DHCP Start 192.168.1.201
DHCP End 192.168.1.254

OK using your netwrokmanager piccy

http://imagizer.imageshack.us/v2/480x400q90/911/hcMvBT.jpg

IPv4 tab

Method = Manual
DNS Server = 192.168.1.1
Search domains =

Address = 192.168.1.n (where n is a number from 2 to 200 ‘inclusive’ … remember no 2 devices/connections should have the same static IP address, even different adapters on the same PC need their own IP)
Netmask = 255.255.255.0
Gateway = 192.168.1.1

IPv6 tab

Method = Ignore

I’ll have a go at changing the setting to what you suggest, but before I do, could you take a look at the screenshot first…

http://imagizer.imageshack.us/v2/580x500q90/909/ImnEdX.jpg

Check out the settings on the Internet Port > IP Subnet Mask 255.255.252.0

Why is mine 255.255.252.0 and not 255.255.255.0
Ist that of any relevance?

Dunno why it’s set that way, but AFAIK it’s irrelevant here.

But if you wanna check what the netmask is currntly set to on your PC, then mirror it in your static settings … feel free.

I’ve changed the settings and first attempt, I set the subnet mask to 255.255.255.0 and (looking at the internet port) there was nothing configured, they were all ‘0’
I then changed the subnet mask to 255.255.252.0 and the internet port details were complete.
However, when I clicked on ‘connected devices’ there was nothing showing?

you may need to disable networking, then re-enable it (or reboot) before the new network settings are applied

does internet work ?

Does:

ping -c 3 192.168.1.1

and

ping -c 3 74.125.230.226

and

ping -c 3 google.com

all work ?