slow, often unresponsive acer aspire one running peppermint 5 (SOLVED)

hi all
my aspire one often slows right down and becomes generally unresponsive since i upgraded to peppermint 5.
videos etc are not the only problem, even good old ebay won’t scroll down sometimes.
i did run my query in the search box but got no relevant answers back.
any advice would be most welcome.
many thanks
john

How much RAM do you have ?

and

How much HDD/SSD space do you have ?

what’s the output from:

inxi -F

and

free -m

and

df -h

hi mark
A Distro: Peppermint Five
Machine: System: Acer (portable) product: AOA150 version: 1
Mobo: Acer model: N/A Bios: Acer version: v0.3114 date: 05/09/2008
CPU: Single core Intel Atom CPU N270 (-HT-) cache: 512 KB flags: (nx pae sse sse2 sse3 ssse3)
Clock Speeds: 1: 1066.00 MHz 2: 1600.00 MHz
Graphics: Card: Intel Mobile 945GSE Express Integrated Graphics Controller
X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x600@60.0hz
GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 GLX Version: 1.4 Mesa 10.1.3
Audio: Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: k3.13.0-53-generic
Network: Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169
IF: eth0 state: down mac: 00:1e:68:ac:52:4e
Card-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) driver: ath5k
IF: wlan0 state: up mac: 00:22:69:08:97:13
Drives: HDD Total Size: 120.0GB (7.3% used) 1: id: /dev/sda model: Hitachi_HTS54321 size: 120.0GB
Partition: ID: / size: 109G used: 8.2G (8%) fs: ext4 ID: swap-1 size: 1.06GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 55.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 126 Uptime: 33 min Memory: 286.3/988.7MB Client: Shell (bash) inxi: 1.9.17
john@john-AOA150 ~ $

total used free shared buffers cached
Mem: 988 918 70 60 68 554
-/+ buffers/cache: 295 692
Swap: 1009 0 1009

Filesystem Size Used Avail Use% Mounted on
/dev/sda1 109G 8.2G 96G 8% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 485M 4.0K 485M 1% /dev
tmpfs 99M 992K 98M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 495M 26M 469M 6% /run/shm
none 100M 8.0K 100M 1% /run/user

these are my outputs in order.
thanks for your help
john

It’s an old Atom chip, with 1Gb of RAM (which is heavily used, and the machine is swapping).
I think this is the weight of modern web browsers unfortunately :frowning:

hi chemicalfan
thanks for the reply
so no point upgrading to peppermint 6 then i guess.
I’ts a shame because it ran ok once.

thanks
john

WattOS R9 might be a good candidate … that’s supposed to be pretty light, yet is still based on 14.04
http://www.planetwatt.com/

[EDIT]

WattOS would have been my second choice as a starting point for my AA1 had it not been for Peppermint, then they went Debian based, and whilst I have nothing against Debian it does have its rough edges (such as getting the touchpad to work properly, etc.) so I’d have been hard pushed to recommend it to anyone except experienced users … now they’re back on a smoother Ubuntu base so I’d recommend WattOS R9 to anyone :slight_smile:

thanks mark
i’m constantly asked to udate flash player, as mine is out of date. i dont know if that would have a bearing on slow running?
I can’t find the appropriate update in the update manager.
I will probably stick with peppermint 5, though won’t risk trying six.
thanks for your advice
john

Have you ever run a system update ?

Open a terminal and run these commands in sequence:

sudo apt-get update

then

sudo apt-get upgrade

then

sudo apt-get dist-upgrade

then REBOOT

After rebooting, try flash and let me know if it still says you need an update for flash

hi mark
i get this at the end of stage one

E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
i copied and pasted your instructions.
thanks john

I would do as the error suggest:

sudo dpkg --configure -a

looks like you have broken packages or have not updated for a loong time
If that completes without error then start from the begining again with:

sudo apt-get update

Then complete the rest of the steps as Mark instructed

thanks SeZo
that did the trick
yes i have not updated since i have been using peppermint 5, i didn’t realise i had to? i assumed it did it automatically, how wrong was i.

so to clarify, do i run the above commands to update, and if so, how often?
just about to reboot to try flash player.
thanks
john

hi mark
thanks for the commands
this is what i’m running according to a site i logged onto to test flash player
Detailed results
JavaScript Flash Detection Library

Installed
Yes
Raw version
Shockwave Flash 11.2 r202
Major version
11
Minor version
2
Revision
202
Revision string
r202

Adobe Flash Player Detection Kit (Client)

Type
Plugin (Non-IE)
Version
11.2.202

Adobe Flash Player Detection Kit (Server)

Installed
Yes

sometimes it says a plug in is required to view content, i don’t know whether that’s normal?

perhaps there is a good flash player test page that would give accurate results?
i will try out some web pages in the mean time to see if there is any improvement.
many thanks
john

What’s the output from:

dpkg -l | grep flash

?

and which web browser are you using ? … Chromium, Chrome, or Firefox ?

yes i have not updated since i have been using peppermint 5, i didn't realise i had to? i assumed it did it automatically, how wrong was i.
Is not there not a update manager icon (shield) on the bottom right of the screen? I thought that Peppermint uses the Mint update system, whereby indicates that there are updates available? You would still need to login and allow the updates to run. If you have not got this then you will haveto do the updates manually (like you just did now).

Peppermint 6 uses mintupdate (so has the shield in the tray), but 5 used the ubuntu update-manager which IIRC had a bug that occurred on SOME peoples systems where it never opened and offered update unless manually started.

hi mark the output is;
$ dpkg -l | grep flash
ii adobe-flash-properties-gtk 1:20150811.1-0trusty1 i386 GTK+ control panel for Adobe Flash Player plugin
ii adobe-flashplugin 1:20150811.1-0trusty1 i386 Adobe Flash Player plugin
rc flashplugin-installer 11.2.202.411ubuntu0.14.04.1 i386 Adobe Flash Player plugin installer
ii pepperflashplugin-nonfree 1.3ubuntu1 i386 Pepper Flash Player - browser plugin

this was done on the chromium browser, i usually use firefox as my default though

thanks SeZo
as mark said there is no update icon,
so how often should i run the above commands?
cheers
john

I would run them every day, but at least once a week to be safe. Security updates get pushed through this mechanism, so it’s always a good idea to stay up to date