Software Updater

Hi,
I am happily using Peppermint 3 OS on my Acer Aspire One and update the software whenever advised.
Today when doing so this message appeared :

Not Enough Free Disk Space
The upgrade needs a total of 422 M free space on disk ‘/’. Please free at least an additional 4 704 k of disk space on ‘/’. Empty your trash and remove temporary packages of former installations using ‘sudo apt-get clean’.

Not being to clever on computers I wonder if someone could give me a simple explanation of what I have to do.
Thanks.

Hi woodward

could give me a simple explanation of what I have to do. Thanks.

Well you have to free up some space, there’s is various ways to do that depending on what’s eating up the disc space firstly you can empty the rubbish bin by opening the file manager and in the left hand pane you should see Rubbish bin or Trash (I cant remember what it’s called in PM3) right click and click “Empty rubbish bin”, if you have any programs you no longer use you can uninstall them (if you need help with that post back here).

Are you storing a lot of files in your home directory such photos, videos etc ?, if so you may have to store them somewhere else or delete what you don’t need anymore

before you do anything can you post the output of


df -h

Graeme

…Have you tried the above?
You could also try running the following:

sudo apt-get autoremove

Thank you one and all - back to having space though I could not believe I could have a problem.
I have no pictures, videos and very few letters or spreadsheets. Use my computer for emailing and Skype !

Till next time. Regards, Kevin

sudo apt-get clean

As suggested by the updater will probably recover the most space as it’ll clear the package cache

Hi all helpers,

I am in again trouble with Software Updater - not space this time - I have done the clean-up suggested last time.

I have been struggling to update - tried a number of times over a few weeks - kept getting an
error message half way through the process.

Tried again today and this is the message

The package system is broken
If you are using third party repositories then disable them, since they are a common source of problems.
Now run the following command in a terminal: apt-get install -f

I tried running in the Terminal but it says:

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Can anyone guide me.

Regards,
Kevin

Try not to use the Software Updater and the Terminal command at the same time.
Start by closing down the Software Updater then try in terminal:

sudo apt-get update

If that still complains about the lock file then remove it with:

sudo rm /var/lib/dpkg/lock

then try again in the terminal:

sudo apt-get update

See if that gives any clue what is causing the update to fail

apt-get install -f

won’t cut it … it needs to be run as root … so try:

sudo apt-get install -f