[SOLVED] Adding new columns in Nautilus

I have been looking into adding new columns in nautilus to give me information on audio and video such as duration.
I have found this;

01 - Download the script from http://www.2shared.com/file/7716528/d1676f26/bsc-v2.html to ur desktop
02 - Install the needed dependencies (make sure universe source is enabled “System>Administration>Software Sources>Ubuntu Software tab”)
sudo apt-get install python-nautilus python-mutagen python-pyexiv2
03 - Make a directory in ur home/.nautilus named “python-extensions”
mkdir ~/.nautilus/python-extensions
04 - Copy the script to it (if done graphically, hit ctrl+H to view hidden folders in ur home directory)
cp bsc-v2.py ~/.nautilus/python-extensions
05 - Make the script executable
chmod a+x ~/.nautilus/python-extensions/bsc-v2.py
06 - Close all Nautilus windows
killall nautilus
07 - Relaunch Nautilus

But, it did NOT work!. What’s wrong with it?

That link points to an out dated script try this updated (for 12.04) version instead,
and follow the instructions here

I’m trying to follow it but I’m having problems.
Post #38 Adding mp3 info columns (e.g. bitrate, etc.) to nautilus list view - Page 4

Step #2 is telling me to make sure universe source is enabled “System>Administration>Software Sources>Ubuntu Software tab”
Does this mean the ‘Source Code’ Tab in screenshot #01?

Step #3 is telling me to Make a directory in ur home/.nautilus named “python-extensions”
But I did that and then looked in the folder created above and there was a file telling me that it has been re-created as home/.config/nautilus/python-extensions

I have even done a re-boot but I still get the standard options, screenshot #02

What am I doing wrong???

The file ‘bsc-v2.py’ is also in ‘usr/lib/nautilus/extensions-2.0/python’

I’ve tried changing ownership of it but it still says I’m not the owner

chmod a+x /usr/lib/nautilus/extensions-2.0/python/bsc-v2.py

I’ve even tried it with

sudo chmod a+x /usr/lib/nautilus/extensions-2.0/python/bsc-v2.py

But still no change!

Since when does “chmod” change a files “ownership” … that would be “chown” :wink:

chmod a+x

Just made the file executable by everyone … it did not change ownership

see:

man chmod

and

man chown

Sorry, I’ve just had another look and it is just ‘chmod’

I’ve also seen that someone is also saying the file ‘bsc-v2.py’ should be in ‘~/.local/share/nautilus-python/extensions folder’ so I’m now completely lost in what I need to do…

Just guessing here, but what’s the output from:

la -al ~/.local/share/nautilus-python/extensions

and

dpkg -l | grep python-nautilus

and

dpkg -l | grep python-mutagen

and

dpkg -l | grep python-pyexiv2
la -al ~/.local/share/nautilus-python/extensions

ls: cannot access /home/pooky2483/.local/share/nautilus-python/extensions: No such file or directory

dpkg -l | grep python-nautilus

ii python-nautilus 1.1-3 Python binding for Nautilus components

dpkg -l | grep python-mutagen

ii python-mutagen 1.20-1ubuntu1 audio metadata editing library

dpkg -l | grep python-pyexiv2

ii python-pyexiv2 0.3.2-1 Python binding to Exiv2
ii python-pyexiv2-doc 0.3.2-1 Documentation for Python binding to Exiv2

run:

sudo updatedb

then post the output from:

locate bsc-v6.py
locate bsc-v6.py

[/quote]
pooky2483@pooky2483-ubuntu12:~$ locate bsc-v6.py
pooky2483@pooky2483-ubuntu12:~$

Instead , I ran

locate bsc-v2.py

pooky2483@pooky2483-ubuntu12:~$ locate bsc-v2.py
/home/pooky2483/.config/nautilus/python-extensions/bsc-v2.py
/usr/lib/nautilus/extensions-2.0/python/bsc-v2.py
pooky2483@pooky2483-ubuntu12:~$

[EDIT]
‘ran’ - wtf! dunno why I typed ‘ran’

run:

mkdir -p ~/.local/share/nautilus-python/extensions
cd ~/.local/share/nautilus-python/extensions
wget http://dl.dropbox.com/u/11876059/bsc-v6.py
chmod a+x ~/.local/share/nautilus-python/extensions/bsc-v6.py

REBOOT (or restart Nautilus) and see if it works.

If not, try:

mkdir -p ~/.nautilus/python-extensions
cp ~/.local/share/nautilus-python/extensions/bsc-v6.py ~/.nautilus/python-extensions/bsc-v6.py

And again, REBOOT to test.

.

I tried the first bit.
It’s worked now Mark ;D Thanks
What exactly was wrong/what did/didn’t I do?

a) you were using the earlier version of the python script … not the one for Ubuntu 12.04
and
b) you were putting it in the wrong place

Ah thanks.
I’ll try and remove the file(s) I don’t need.

I’m going to remove that file from my dropbox

So for future readers using Ubuntu 12.04:-

Download the bsc-v6.py file attached below … and put it in your Home folder … then open a terminal and run these commands in sequence:

sudo apt-get install python-nautilus python-mutagen python-pyexiv2

then

mkdir -p ~/.local/share/nautilus-python/extensions

then

mv -v ~/bsc-v6.py ~/.local/share/nautilus-python/extensions/bsc-v6.py

then

chmod a+x ~/.local/share/nautilus-python/extensions/bsc-v6.py

Now REBOOT to test