[SOLVED] After 'fixing' a previous problem, I now have another problem.

The problem I previously had is HERE

I believe the new problem is related as I now no longer have VLC installed and when I tried to install it through Muon Package Manager, I get this;

The “vlc” package could not be marked for installation or upgrade:

Depends: vlc ,but is not installable
Depends: vlc ,but is not installable
Recommends: vlc ,but is not installable
Recommends: vlc ,but is not installable

Yes, the warnings appear twice for some reason.

Run:

sudo apt-get clean

then

sudo apt-get update

now what’s the output from:

sudo apt-get install vlc

Hi Mark, sorry for not getting back to you sooner, me & Mrs pooky have had the flu since Christmas,we’ve almost got over it and now she’s ill in hospital.
I’ll get back to you as soon as I can.

No worries … wish the missus all the best and a speedy recovery from me.

Throw all the insults you like at me but I call it the chemtrail flu. My immediate family for three months now have had bronchitis like chest infections with my heavily pregnant daughter now in intensive care. I’ve never seen anything like this and the doctors at the surgery and those at the hospital haven’t either and it’s right acros
s the U.K.

Hi Mark,
I tried the suggestion above and was given this;
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
vlc : Depends: vlc-nox (= 2.1.6-0ubuntu14.04.2) but it is not going to be installed
Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed
Recommends: vlc-plugin-notify (= 2.1.6-0ubuntu14.04.2) but it is not going to be installed
Recommends: vlc-plugin-pulse (= 2.1.6-0ubuntu14.04.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi pooky2483,
Try

sudo apt-get -f install

that should fix any broken packages messages you are getting
Regards Zeb…

Nope… I still get the error I posted above!

What happens if you run:

sudo apt-get install --reinstall vlc-nox libvlccore7 vlc-plugin-notify vlc-plugin-pulse vlc

I entered

sudo apt-get install --reinstall vlc-nox libvlccore7 vlc-plugin-notify vlc-plugin-pulse vlc

And got;

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
libvlccore7 : Depends: vlc-data (= 2.1.6-0ubuntu14.04.2) but 2.2.4-3ubuntu2~ubuntu14.04.1york1 is to be installed
E: Unable to correct problems, you have held broken packages.

I have the feeling this is going to be PPA related again … try:

sudo apt-get install --reinstall vlc-nox libvlccore7 vlc-plugin-notify vlc-plugin-pulse vlc vlc-data

I finally got round to looking at VLC on my desktop again and looked for anything installed which was VLC related and found libvlccore8 so I decided to go for it and purge it.
I then selected to install VLC from Muon Update Manager and IT WORKED!

I now have VLC installed.