[SOLVED] Boot without password

I need to set my desktop PC to boot without needing to enter my password as I am mainly on my laptop and use teamviewer to access my desktop PC.

Which distro/version ?

In my ‘tag’ lol!

But I’ll let you off as most people don’t bother reading them ::slight_smile: :P.

Kubuntu 14.04LTS 64bit|KDE 4.14.13|QT 4.8.6|Linux 4.2.0-42-generic|M5A78L-M USB3|BIOS 2101|AMD PhenomII X4 965 3400+|P8H77-I Motherboard NIC|32.0GB PC3-10600 1333Mhz CL9 ( 9-9-9-24 ) DDR3

It’s not that I didn’t read it, it’s that I have no way of knowing if that’s the PC you’re talking about (or if indeed the sig still applies) … you mentioned “on my desktop PC”, so I figured as you’d mentioned it maybe your sig was from another PC.
(I’m sure I’ve said this before … it’d help when asking a question if you said something like “system specs in my signature” if that is indeed the PC you’re talking about)

Try this…


sudo kate /etc/sddm.conf

when a blank file opens, make it read:-


(replacing “YourUsername” with your actual login username)

SAVE the file, and reboot to test.

Understandable, I can’t see you sitting at the PC all day answerin questions on here.
I tried the commands and I still had to enter my password at boot.

I take it you’ve tried this:-

  • Go to KDE settings.
  • Go to the “Login Screen” menu.
  • Go to the “Convenience” tab.
  • Put a tick in the “Auto-Login” tick box.
  • Select your username from the dropdown menu.

No, as I didn’t know about that or where to look as I since using 16.04 I’m lost, But now I’ve changed the settings.

Sorry, I’ve got mixed up there, I changed 16.04’s settings and not 14.04. I’ll just use Teamviewer to change them on 14.04.

I’ll have to remove the automount settings for one of the drives as it’s power (plug) has failed, before I can try a reboot.


It worked, thanks Mark :slight_smile:

No problem my mate :slight_smile: