[SOLVED]Can't print PDF files on Ubuntu 11.10 and 12.04 using default PDF viewer

Good Day!

As the topic states, I can’t print PDF files on my Ubuntu 11.10, It seems I need a third party software or somthin’. Any suggestions on how can I make it work? Sorry I’m just new in this kind of OS.

Thanks in advance!

If you mean you can’t print TO a PDF … try installing the cups-pdf package:

sudo apt-get install cups-pdf

If you mean you can’t print a PDF from the document viewer to your printer … let us know.

Yes, what I mean is I can’t print a PDF file from document viewer to my printer. And by installing cups-pdf I now manage to print PDF files on my printer. Your code did the trick and I’ve been looking for this a long time. Thanks for helping me out (again) on this. Glad to see a very helpful and informative forum. God Bless you and your members.

Thanks and More Power!

Sorry but I think my last post was a bit misleading, I tried the code that you posted and run it on Administrator account but it seems it only runs on that user, and whenever my office mates tries to print using their user accounts the same issue that I reported is still occuring. Mind if I open the topic again? Thanks in advance! BTW, I made two accounts for every user one for administration that has all access or in an administrator state also password protected and one for users with limited access or standard account state with default password which I enter same to all workstations and will ask them to change for future use.

You shouldn’t have to reinstall cups-pdf … once installed it should be available for all users on the system.

Another way to print pdf’s –

When you print something, choose “Print to file” as your printer … then select PDF as the “Output format”.