[Solved] Corrupted update

I installed Ubuntu V11.10 on the laptop (Acer K53S) belonging to an elderly gent with strict instructions not to click the “Upgrade” button during routine updates.

You’ve guessed correctly that he did, but worse than that: he closed down the computer during the updating process and some things have screwed up.
Now, only partial upgrades are offered and some Applications are missing from the menu, in particular “Main”(Classic View) which means I can’t look for them.

I attempted to reload V11.10 from disc but not even wubi.exe responded. The machine is dual boot with Windows 7 but I would be happy to reload on top of Windows and use the whole disc if you can advise me how. I am reluctant to download the installation from the web, partly due to the large file size, partly because I don’t know what I’m doing.
Thanks, in anticipation.

OK, my advice would be to download/install 12.04 … as it’s an LTS version that won’t display an “Upgrade” option for another 3.5 years :slight_smile:

So first let’s create a 12.04 LiveCD or LiveUSB

On a Windows PC … download this:
http://releases.ubuntu.com/12.04/ubuntu-12.04.1-desktop-amd64.iso

once you have it, can you answer a couple of questions …

Do you have and blank DVD’s ?

Do you have a blank 2GB or larger USB stick (or one you can erase) ?

Do you want to keep Windows 7 on the PC ?

I have downloaded the file - 700MB. How glad I am that I had fibre installed three days ago!
I don’t have a 2GB USB stick, but do have some DVDs.
I don’t see any reason to keep W7 as I can’t help the chap with Windows problems.

Just one query: is it possible to have a pseudo Classic View in V12 as it is in V11?

Just one query: is it possible to have a pseudo Classic View in V12 as it is in V11?

Yup, you just need to install gnome-shell, or gnome-panel, the same as in 11.10 :slight_smile:

Do you know how to burn the Ubuntu ISO image to the DVD using Imgburn ?

Yup, you just need to install gnome-shell, or gnome-panel, the same as in 11.10
I've used "sudo apt-get install gnome-session-fallback" in the past. Is that the one?
Do you know how to burn the Ubuntu ISO image to the DVD using Imgburn ?
I've never burnt ISO images - just ordinary files. Your help wuold be appreciated.

I have a separate desktop for communication if I screw up on the laptop!

I've used "sudo apt-get install gnome-session-fallback" in the past. Is that the one?

Yes that would also do it … the ones I posted above would also install the Gnome3 desktop … and you could choose between Gnome3, Gnome classic, and Unity

2 secs and I’ll post instructions for burning the ISO to a DVD

On a Windows PC …

Download ImgBurn from here:
http://download.imgburn.com/SetupImgBurn_2.5.7.0.exe

Install ImgBurn, then see here for instructions on how to burn the Ubuntu 12.04.1 ISO image to a blank DVD with ImgBurn:

http://neosmart.net/wiki/display/G/Burning+ISO+Images+with+ImgBurn

on the second picture, where it says Write Speed: AUTO (or AWS) … change that to 4X
and put a tick in the Verify box.


Once you’ve burned the Ubuntu DVD … boot to it, and select “Try Ubuntu” NOT “Install Ubuntu” … this will give us an idea if the DVD burned correctly, and Ubutnu 12.04.1 is happy on your hardware … also if you’re happy with 12.04 :wink:

Let us know if there are any problems, and if not, when you’re ready to install.

Before your post appeared, I used Brasero Image burn to create an ISO disc, and it appears to have burnt OK.
I’ll just try to run it now as you suggest and come back in an hour or so.

Inserting the ISO disc brings up a window inviting me to start it using Package Manager.
Clicking Continue merely starts the Ubuntu Software Centre.
I tried running wubi.exe. That flashes a terminal window briefly but does nothing.
Hmm!
Today’s awkward customer?

DO NOT run WUBI.

Burn the ISO image to a disk using ImgBurn on a Windows PC … if you don’t have a Windows PC, let me know.

[EDIT]

You’re meant to be BOOTING the LiveDVD you just created … not just inserting it in an already booted OS

Leave the DVD in the drive and reboot … as the system boots you should see a message like

F2 = BIOS/Setup
F12 = Boot device selction

or similar … you need to hit whichever key allows you to choose which device to boot from … then choose the DVD drive

in the above example you’d choose the F12 key … but it may be different on your PC

That’s just what I did, Mark. The message that comes up is:
“A volume software package has been detected.
Would you like to open it with Package Manager?”
Would a Windows download of the file be a better bet? Though I’m not sure why.

you usually get that message when you boot to an already installed Linux with a LiveCD/LiveUSB in the optical drive.

So I’m guessing it’s booting to the installed 11.10 and not the 12.04 LiveCD … is there an “Install Ubuntu” icon on the desktop ?

and what’s the output from:

cat /etc/*-release

[Sorry: I posted this before your post displayed. I didn’t see an ‘Install Ubuntu’ on the desktop]

Ah Ha! Success by the back door.
I rebooted whilst pressing F12 repeatedly, which I expected to provide the options you indicated.
Instead it ignored me and displayed the usual dual-boot options.
I opted this time for a Terminal, and it opened a Grub terminal.
In a panic I typed ‘exit’ and the machine started to boot from the disc - and I am using the demo version now.
It looks just like the Unity desktop, so if the rest of V12 looks similar to V11 I shall be happy to install it over Windows.

I shall play around a bit to see any differences c.f. V11, show it to the owner and get back to you tomorrow for any advice before installing.
Thanks, Mark.

According to the ASUS K53SV manual, to access the boot device selection menu, hit the Esc (Escape) key when you see the ASUS logo.

Page 34 of this manual:
http://www.manualowl.com/m/Asus/K53SV-A1/Manual/236969?page=34

That may not be your EXACT model, but it’s probably the same key :slight_smile:

Setting the boot order occurred to me in bed this morning (yeah, how sad!) so I booted up on F2 just now, as you suggest, and changed the boot priorities. It worked, of course, and I don’t know why I didn’t realise my error before. Sorry for the delay that caused. So now I’m running V12 from the disc.
The laptop owner is happy to overwrite Windows so now I am ready to install.
Do you have any last words of advice before I do so?
I notice that [i]http://releases.ubuntu.com/12.04/ubuntu-12.04.1-desktop-amd64.iso[/i] is for desktop whereas my application is for a laptop - are there any potential problems?

“Desktop” just distinguishes it from the “Server” edition … it’s the right one :slight_smile:

If you haven’t already, I’d create the Windows recovery DVD’s before installing … there’s normally an application in Windows to do that … but up to you.

Then just install Ubuntu and tell it to use the whole disk.

Summary of successful completion

Background
Asus K53S laptop owned by a computer newbie, loaded by me with Ubuntu V11.10 alongside Windows 7, in Classic View.
I provided worksheets for common operations including what to do when the update screen appeared. Critically, I stated not to click the “Upgrade” button until I had heard how stable V12 is.

Symptoms

  • The routine update screen showed an error window indicating that a full update was not possible due to missing or incomplete previous updates. A partial update was offered.
  • Items were missing from the Applications menu.
  • Selecting “Settings” produced an error message.

Attempted recovery
sudo apt-get upgrade installed many updates.
sudo apt-get update produced messages that I didn’t understand but suggested -
sudo install -f which tried hard to fix the broken system, but to no effect.
The Settings Error “Details” link was very informative and showed a list of about thirty packages that needed to be fixed. It also showed that there had been an aborted attempt to upgrade to V12! It appears that the owner had clicked on Upgrade to V12 in error and had later switched off the computer because the screen was black. I tried:
Sudo apt-get install package-name repaired many (some were newest versions) but indicated that there were ~390 more to go.

At his point I asked for help on this Forum.
The consensus was to perform a complete upgrade to V12. For people as ignorant as I am, here is the suggested method that worked for me.

  1. Download: http://releases.ubuntu.com/12.04/ubuntu-12.04.1-desktop-amd64.iso (It’s 700MB)
  2. Then burn to a DVD using Brasero if you already have Ubuntu (select “Burn Image”), or Imgburn if you run Windows (download from: http://download.imgburn.com/SetupImgBurn_2.5.7.0.exe ).
  3. Now insert your ISO DVD and use the boot device selection key (F11 or F12 on most PCs or Esc on my Asus K53S).
  4. The computer will now boot from the DVD.
  5. Voila!

Many thanks to Mark

Nicely laid out … and you’re welcome :slight_smile: