[SOLVED] CUPS username & password

I’ve forgot my username and password for cups, is there any way to find out what it was?

CUPS should accept your LINUX username and password as long as you’re an administrator (so are a member of sudo and lpadmin).

It worked, I was trying that earlier and it wouldn’t work.
It cant see my PDF printer for some reason?
I had to reinstall it as for some reason when I update, things get removed, like xscreensaver, cups was removed and I didn’t realise, I typed

sudo apt-get install cups-pdf 

to put it back, I then went into system settings/printers and did something then the PDF printer just vanished!
how do I get it back/reinstall it?

If it’s not installed … yes, just reinstall it.

if it keeps getting removed during updates … next time update from the command line, and see if you can get a clue to what’s being updated that might be removing it.

How do I 're’install it? What’s the command?

sudo apt-get install --reinstall cups-pdf

or

make sure it’s uninstalled:

sudo apt-get remove --purge cups-pdf

then install it again:

sudo apt-get install cups-pdf

Thanks for that Mark, I had to do the latter. I tried

sudo apt-get install reinstall cups-pdf

but it wouldn’t work, I see now that I missed out the ‘–’ earlier when I tried it myself.

No problem :slight_smile: