[SOLVED]Dual booting Peppermint and Linpus problems

Hi I tried to make a dual boot with pepper mint and linpus on my AA1. I did this by shrinking the linpus partition and installing peppemint in the free space. Now the problem is that I cant boot into linpus, there is no option to do so. I think I need to edit something in grub but I dont know what. I’d appreciate it if someone could help.

I assume you can boot into Peppermint.

Try to install os-prober (if not already installed)
by running the following command in the Terminal:

sudo apt-get install os-prober

then update grub:

sudo update-grub

This will scan the hard disk for other operating systems and add them to the boot menu.

After doing what SeZo says, and waiting till the command line leaves you back at an $ prompt … reboot, and see if you’re offered both OS’s.

if not, boot back to Peppermint, open a terminal (Ctrl+Alt+T), and send the output from:

sudo fdisk -l

and

sudo blkid

and the contents of:

gedit /boot/grub/grub.cfg

os brobber and update grub did’nt work

output requestef is below:

sanish@AcerAspireOne ~ $ sudo fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf3d7e454

Device Boot Start End Blocks Id System
/dev/sda1 * 63 170532863 85266400+ 83 Linux
/dev/sda2 232332030 234436544 1052257+ 82 Linux swap / Solaris
/dev/sda3 170532864 232331263 30899200 83 Linux

Partition table entries are not in disk order
sanish@AcerAspireOne ~ $ sudo blkid
/dev/sda2: UUID=“3af9f80a-1fab-4601-907b-7a3efa43959b” TYPE=“swap”
/dev/sda3: UUID=“edead51b-8cb3-47f6-a670-7a16b4c00381” TYPE=“ext4”
sanish@AcerAspireOne ~ $ gedit /boot/grub/grub.cfg

DO NOT EDIT THIS FILE

It is automatically generated by grub-mkconfig using templates

from /etc/grub.d and settings from /etc/default/grub

BEGIN /etc/grub.d/00_header

if [ -s $prefix/grubenv ]; then
set have_grubenv=true
load_env
fi
set default=“0”
if [ “${prev_saved_entry}” ]; then
set saved_entry=“${prev_saved_entry}”
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z “${boot_once}” ]; then
saved_entry=“${chosen}”
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n “${have_grubenv}” ]; then if [ -z “${boot_once}” ]; then save_env recordfail; fi; fi
}

function load_video {
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root=‘(hd0,msdos3)’
search --no-floppy --fs-uuid --set=root edead51b-8cb3-47f6-a670-7a16b4c00381
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=auto
load_video
insmod gfxterm
insmod part_msdos
insmod ext2
set root=‘(hd0,msdos3)’
search --no-floppy --fs-uuid --set=root edead51b-8cb3-47f6-a670-7a16b4c00381
set locale_dir=($root)/boot/grub/locale
set lang=en_GB
insmod gettext
fi
terminal_output gfxterm
if [ “${recordfail}” = 1 ]; then
set timeout=-1
else
set timeout=10
fi

END /etc/grub.d/00_header

BEGIN /etc/grub.d/05_debian_theme

set menu_color_normal=white/black
set menu_color_highlight=black/light-gray

END /etc/grub.d/05_debian_theme

BEGIN /etc/grub.d/10_linux

function gfxmode {
set gfxpayload=“${1}”
if [ “${1}” = “keep” ]; then
set vt_handoff=vt.handoff=7
else
set vt_handoff=
fi
}
if [ “${recordfail}” != 1 ]; then
if [ -e ${prefix}/gfxblacklist.txt ]; then
if hwmatch ${prefix}/gfxblacklist.txt 3; then
if [ ${match} = 0 ]; then
set linux_gfx_mode=keep
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=keep
fi
else
set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ “${linux_gfx_mode}” != “text” ]; then load_video; fi
menuentry ‘Peppermint, with Linux 3.2.0-23-generic’ --class peppermint --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_msdos
insmod ext2
set root=‘(hd0,msdos3)’
search --no-floppy --fs-uuid --set=root edead51b-8cb3-47f6-a670-7a16b4c00381
linux /boot/vmlinuz-3.2.0-23-generic root=UUID=edead51b-8cb3-47f6-a670-7a16b4c00381 ro quiet splash $vt_handoff
initrd /boot/initrd.img-3.2.0-23-generic
}
menuentry ‘Peppermint, with Linux 3.2.0-23-generic (recovery mode)’ --class peppermint --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_msdos
insmod ext2
set root=‘(hd0,msdos3)’
search --no-floppy --fs-uuid --set=root edead51b-8cb3-47f6-a670-7a16b4c00381
echo ‘Loading Linux 3.2.0-23-generic …’
linux /boot/vmlinuz-3.2.0-23-generic root=UUID=edead51b-8cb3-47f6-a670-7a16b4c00381 ro recovery nomodeset
echo ‘Loading initial ramdisk …’
initrd /boot/initrd.img-3.2.0-23-generic
}

END /etc/grub.d/10_linux

BEGIN /etc/grub.d/20_linux_xen

END /etc/grub.d/20_linux_xen

BEGIN /etc/grub.d/20_memtest86+

menuentry “Memory test (memtest86+)” {
insmod part_msdos
insmod ext2
set root=‘(hd0,msdos3)’
search --no-floppy --fs-uuid --set=root edead51b-8cb3-47f6-a670-7a16b4c00381
linux16 /boot/memtest86+.bin
}
menuentry “Memory test (memtest86+, serial console 115200)” {
insmod part_msdos
insmod ext2
set root=‘(hd0,msdos3)’
search --no-floppy --fs-uuid --set=root edead51b-8cb3-47f6-a670-7a16b4c00381
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}

END /etc/grub.d/20_memtest86+

BEGIN /etc/grub.d/30_os-prober

if [ “x${timeout}” != “x-1” ]; then
if keystatus; then
if keystatus --shift; then
set timeout=-1
else
set timeout=0
fi
else
if sleep --interruptible 3 ; then
set timeout=0
fi
fi
fi

END /etc/grub.d/30_os-prober

BEGIN /etc/grub.d/40_custom

This file provides an easy way to add custom menu entries. Simply type the

menu entries you want to add after this comment. Be careful not to change

the ‘exec tail’ line above.

END /etc/grub.d/40_custom

BEGIN /etc/grub.d/41_custom

if [ -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi

END /etc/grub.d/41_custom

os brobber and update grub did'nt work
Quick question: Do you get a grub menu at boot with Peppermint listed but no Linpus?

No it just goes straight into peppermint

OK try this:

gksudo gedit /etc/default/grub

Comment the next two lines (put a # in front of them):

    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true

Save and close

sudo update-grub

Then reboot.
Does the grub menu now showing up?

the grub menu now shows up but linpus is not an option. There is peppermint, peppermint recovery, and two memtests or something.

Yeh there’s no stanza for linpus in grub.cfg … when I can get at my other PC that has an image of linpus, I’ll try to work out how the stanza should read … then come back to this.

It may not be today though.

[EDIT]

Meanwhile it probably would help if you download and run the boot info script:

run it … then attach the RESULLTS.txt file to your next posting.

Thanks for your help so for

See the edit in my last posting … if you need help running the script, just ask.

Here’s the instructions for downloading and runnig the bootinfo script, just in case …

Open a terminal (Ctrl+Alt+T) and run these commands in sequence:
(and remember, Linux commands ARE case sensitive)

cd ~/Desktop

then

wget http://heanet.dl.sourceforge.net/project/bootinfoscript/bootinfoscript/0.61/bootinfoscript-061.tar.gz

then

tar -xvf bootinfoscript-061.tar.gz

then

sudo ./bootinfoscript

you should now have a file called RESULTS.txt on your desktop … attach that file to your next posting.

Then feel free to delete that stuff from your desktop if you wish.

I have attached the file to this post. I dont know why it say Windows XP for sda1, I have never had that OS on this machine??

Can you sednd the output from :

mount


/dev/sda3 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
gvfs-fuse-daemon on /home/sanish/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=sanish)


OK, let’s try to mount the Linpus partition, then update grub … with a little luck os-prober will then pick up the Linpus installation and add it to the grub boot menu.

first lets make a mount point:

sudo mkdir /mnt/linpus

now try mounting it:

sudo mount /dev/sda1 /mnt/linpus

(if there’s any output from that last command … post it here)
if not, what’s the output from:

ls -a /mnt/linpus

?

It does not mount i get this output:


sanish@AcerAspireOne ~ $ sudo mkdir /mnt/linpus 
[sudo] password for sanish: 
mkdir: cannot create directory `/mnt/linpus': File exists
sanish@AcerAspireOne ~ $ sudo mount /dev/sda1 /mnt/linpus 
mount: /dev/sda1: more filesystems detected. This should not happen,
       use -t <type> to explicitly specify the filesystem type or
       use wipefs(8) to clean up the device.

mount: you must specify the filesystem type
sanish@AcerAspireOne ~ $ ls -a /mnt/linpus 
.  ..
sanish@AcerAspireOne ~ $ 

Hmm … wonder whay that’s there …

Anywho, try it with a different mountpoint

first lets make a mount point:

sudo mkdir /mnt/linpuslite

mount it

sudo mount /dev/sda1 /mnt/linpuslite

(if there’s any output from that last command … post it here)
if not, what’s the output from:

ls -a /mnt/linpuslite

?

The reason it said

mkdir: cannot create directory `/mnt/linpus': File exists

is because I tried the whole thing twice. So making another mount point wont work.

EDIT:

Do you think it is because the peppermint partition is ext4 and linpus is ext2?

OK, try:

sudo mount -t ext2 /dev/sda1 /mnt/linpus

what’s the output from that ?

[EDIT]

Do you think it is because the peppermint partition is ext4 and linpus is ext2?

Simple answer … Nope … it should be able to recognise an ext2 partition without issue … I’m guessing it’s down to the weird union filesystem overlay that Linpus uses for adding an (FAT32) SDcard to the main file system.

Have you got an SDcard inserted ?