[SOLVED] HPLIP - No System Tray

I just installed Ubuntu 12.04 and after sorting out some other problems, I now have this problem;
No system tray for HPLIP.
running Gnome, rebooted quite a few times, so this problem is new.

Gnome shell, or Gnome classic ?

Can you reboot and check you’re still getting this error.

It’s Gnome Classic, theres no normal Gnome installed, theres Gnome Classic (No Effects) too
I just logged out and back in and got the same error as above screenshot

What happens if you NOW run:


Does it start ? … if so, you need to edit the command for the hp-systray item in startup applications from:-



sh -c “sleep 15; exec hp-systray”

It seems like hp-systray is attempting to start before the system tray is loaded … changing that command will introduce a 15 second delay in starting hp-systray, giving the system tray time to come up first.

If you’re not sure how to change the hp-systray startup applications command line … ask.

I got this and it did start, theres the icon in the top corner.

pooky2483@pooky2483-ubuntu12:~$ hp-systray

HP Linux Imaging and Printing System (ver. 3.12.2)
System Tray Status Service ver. 2.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/init.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK

Above is what you need to do then.

Don’t get you???

Did you change the command in the hp-systray startup application entry (as described above) … or not ?

if so, did it work upon a reboot ?

in other words … is this now solved ?

Yes :slight_smile: