SOLVED. Network problem when dual boot with Windows 8

On a new machine I have installed Windows 8 and Ubuntu 12.04 but only Windows is connecting to the network. Ubuntu only shows ‘localhost’ 127.0.0.1.

I don’t know quite what further information you may need.

Has anyone any ideas please?

is this a wired or wireleess connection ?

What do you mean by “network” ? … a local network, or the internet via your router ?

What exactly only shows “localhost 127.0.0.1” ?

Open a terminal and post the output from:

ifconfig

Thank you for your reply Mark.

It is a wired network, connected to a router for the internet.

Localhost is shown by ‘System Setting/Network’.

ifconfig returns:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:144 errors:0 dropped:0 overruns:0 frame:0
TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11520 (11.5 MB) TX bytes:11520 (11.5 MB)

Can you attach the output of:

lspci | grep net

Hmm, it doesn’t appear to be detecting ANY network adapters…

Can you make chemicalfan’s command read:

lspci -vnn | grep -i net

please.

And also send the output from:

sudo lshw -C network

Sorry, I always keep the syntax vague and return more than I need… laziness with learning all the switches :-[

Oddly I actually WANTED more this time … the “-vnn” will also return the [IDvendor:IDproduct] ID strings, which will hopefully help identify the network adapters

I only threw “-i” into the grep to make “net” case insensitive. :slight_smile:

Lol, maybe I should print off the man pages and get studying, something to read on the can I suppose! Lol

Shows how much time I spend on the can eh :wink:

Second answer:

02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8161 Gigabit Ethernet Controller [1969:1091] (rev 10)

Third answer:

*-network UNCLAIMED
description: Ethernet interface
product: AR8161 Gigabit Ethernet
vendor: Atheros Communications Inc.
Physical id: 0
version: 10
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vpd bus_master cap_list
configuration: latency=0
resources: memory:febc000-febfffff ioport:ec00 size=128

I am sorry to take so long with this, but not having the internet on that machine I am having to copy everything the hard way and my eyesight is poor.

The Windows 8 on the same machine does connect to the network/internet.

Thank you again for your help.

OK, this driver (alx) was not included in 12.04 by default, but you can download and install the (backported) package manually.

Can you post the output from running:

uname -a

in a terminal ?

Then I’ll post a link to the package you need to download and instructions how to install it.

Thank you for your reply.

uname -a
Linux Win8Ubuntu 3.2.0-29-generic-pae #46-Ubuntu SMP Fri Jul 27 17:25:43 UTC 2012 i686 athlon i386 GNU/Linux

On the Ubuntu computer create a folder on the desktop called network-drivers

on another PC download this file:
http://launchpadlibrarian.net/111339115/linux-backports-modules-cw-3.4-3.2.0-29-generic-pae_3.2.0-29.14_i386.deb

and copy it do the network-drivers folder you created on the Ubuntu desktop

Now open a terminal and run:

cd ~/Desktop/network-drivers

then

sudo dpkg -i *.deb

Or just double-click the file to install.

If networking doesn’t automatically start working, run:

sudo modprobe alx

Once you’ve done that and you have a working internet connection, it would be a good idea to also run:

sudo apt-get install linux-backports-modules-cw-3.4-generic-pae

BEFORE running any updates … as without that package, a kernel update will break your network again (requiring a different driver).

Once you have both of those installed … feel free to delete the stuff from your desktop.

Thank you again for your reply.

There’s the good news and the bad news.

The good news is that I am sending this from the new machine so the network/internet is all up and running.

The bad news is that your last line of code:

sudo apt-get install linux-backports-modules-cw-3.4-generic-pae

is generating an error:

Couldn’t find any package by regex…

OK, do a full system update then reboot … when you reboot, networking MAY be broken, if it is, post the output from:

uname -a

again.

And I’ll tell you what to do so it never breaks again :slight_smile:

Right, it is working its way through 484 updates so that is going to take a little while.

I was relieved to find that the network/internet still worked on Windows 8.

By-the-by I did ask this question on the official Ubuntu forum but did not get a reply.

I will report back.

I find the Ubuntu forum helpful, but only if you know how to sift through the rubbish for the gems :wink:

uname -a:

Linux Win8Ubuntu 3.2.0-53-generic-pae #81-Ubuntu SMP Thu Aug 22 21:23:47 UTC 2013 i686 athlon i386 GNU/Linux

Download and install this:
http://launchpadlibrarian.net/148174638/linux-backports-modules-cw-3.4-precise-generic-pae_3.2.0.53.63_i386.deb

Or if your networking has stopped working, download and install this FIRST:
http://launchpadlibrarian.net/148204065/linux-backports-modules-cw-3.4-3.2.0-53-generic-pae_3.2.0-53.41_i386.deb

Bingo. Give that man a cigar/

Thank you enormously.

This computer is off to France next Sunday so I want to have it all hunky-dory by then. There is a small funny with Nautilus but I will start a new topic for that.