[Solved] Partition missing from “Files” list

I am running Ubuntu 11.10 on a desktop in Classic view.
The directory list (“Applications/Accessories/Files”) used to show both the floppy disc and the XP partition, but not any more, although “Applications/Accessories/Search for Files” does show them and will search the 93GB file system where XP still resides (the floppy is u/s but that’s another problem).
How can I restore the XP partition and floppy drive to the file list?

Do you mean it’s missing from the left hand panel of the “Nautilus” file manager ?

Yes, that’s right - I had forgotten the Nautilus name.
Any ideas?

Try booting into Windows, and running chkdsk (checking the drive for errors).

Mark,
Sorry for the delay - XP has some problems now. The Start button is not functional and I had to relearn my way around XP!
CHKDSK completed (file attached) and indicated that it needed to fix some files using CHKDSK /F.

Key results are:
[i]Correcting errors in the master file table’s (MFT) BITMAP attribute.
Correcting errors in the Volume Bitmap.
Windows found problems with the file system.
Run CHKDSK with the /F (fix) option to correct these.

90692136 KB total disk space.
24971984 KB in 88463 files.
30472 KB in 7348 indexes.
0 KB in bad sectors.
183328 KB in use by the system.
65536 KB occupied by the log file.
65506352 KB available on disk.[/i]

CHKDSK /F could not run as “the disc is locked by another process”.
Running the system monitor showed no processing running, but the disc access light has been exercising for an hour or so. I shall leave it running for as long as it takes and come back to the Forum with the result.
I am having to communicate via my laptop as my XP security is well out of date.

Are you attempting to run chkdsk from the command line within Windows ? … if so, it won’t let you.

You need to navigate to “My Computer” then right-click the C: drive (or whichever drive you want to scan), select “Properties”, then click the “Tools” tab … then under “Error Checking” click “Check Now” … it will warn you that it cannot proceded and ask you if you want to shedule a scan at next boot … say YES, and reboot into windows … the scan should run before Windows loads.

Be aware … this was written from memory, so the names may have changed (to protect the innocent) … but it will be pretty self evident, once you get to the “tools” tab :slight_smile:

I have run CHKDSK from both the Properties menu of the hard disc (as you suggest) and from the command window (they are both the same): the check occurring after a reboot as usual. The resulting message when Windows reboots is “The disc is clean”, but there is still neither task bar nor working Start button.

Since this is clearly not going to be an easy solution, I suggest I simply migrate all my XP documents via a USB stick (because the CD drive is no longer recognised in XP) to my Linux system - this is, after all a Linux Forum!
Thank you for trying to help, Mark, but I don’t want to waste your time, unless anyone else has an interest.

Is it now displaying in Nautilus ?

(Sorry for the delay: I’m doing electrics in the loft!)
No; Nautilus still doesn’t show the XP partition.

I’ve used the PC a few times since the previous post without the partition showing (perhaps I didn’t notice it), but today it is shown and is accessible.
My thanks for your advice, which has clearly worked. As usual.
In the near future, when I have migrated all my files of interest, I shall canvass advice on recovering the partition for Linux use.

Heh … what was that about computers being logical ? ::slight_smile:

IIRC, Ubuntu runs a file system check every 29th boot … it probably fixed itself then.

Yes - patience is certainly a virtue in the computer business!
Re auto file system checks: I have been meaning to ask about some odd background PC activity, and this might explain it. I shall post a separate query rather than bury it here.
My thanks again, Mark.
By the way: what’s IIRC? I’m gradually acquiring a vocabulary of these contractions but this one beat me!

IIRC = If I Remember Correctly … Erm, IIRC :slight_smile:


I very nearly wrote …

IIRC, erm dunno, can’t remember.

But thought that might not be very helpful :wink:

That would be true - IMHO.
This is getting out of hand!

LOL ;D