[SOLVED] Problems installing Dropbox in Kubuntu

I have followed this site;

But I only get as far as step 6 where I get 'KDEInit could not launch ‘/usr/bin/kfilebox’
Not sure what to do next!

I’m assuming you’re still on Kubuntu 12.04 64bit … and that your username is pooky

Uninstall kfilebox (it’s too old):

sudo apt-get remove --purge kfilebox

now run these commands in sequence:

cd ~

then

wget https://dl.dropboxusercontent.com/u/17/dropbox-lnx.x86_64-2.6.7.tar.gz

then

tar xvf dropbox-lnx.x86_64-2.6.7.tar.gz

then

/home/pooky/.dropbox-dist/dropboxd &

Follow the onscreen instructions to either set up a new account, or use your existing account details.

Now you need to get it to autostart … go to:-

Kmenu > System Settings > Advanced > Autostart > Add Script

Navigate to /home/pooky/.dropbox-dist directory and select dropboxd

Thanks for that Mark.
Yes, I am still using Kubuntu and still pooky :slight_smile:

I followed all the instructions and got as far as

/home/pooky/.dropbox-dist &

I get
pooky2483@pooky2483-Kubuntu-1204-3:~$ bash: /home/pooky/.dropbox-dist: No such file or directory

Shouldn’t it make that itself?

Sorry, that should have read:

/home/pooky/.dropbox-dist/dropboxd &

fixed above too

Sorry, I still get a problem

pooky2483@pooky2483-Kubuntu-1204-3:~$ /home/pooky/.dropbox-dist/dropboxd &
[1] 10488
bash: /home/pooky/.dropbox-dist/dropboxd: No such file or directory
pooky2483@pooky2483-Kubuntu-1204-3:~$

So your username ISN’T pooky … it’s pooky2483 … I said I was assuming it was pooky

Change the command to:

/home/pooky2483/.dropbox-dist/dropboxd &

Sorry Mark, most people drop the ‘2483’ when using my username, I just assumed you knew.
I can’t believe I missed that lol

I get an error…

pooky2483@pooky2483-Kubuntu-1204-3:~$ Traceback (most recent call last):
File “dropbox/client/main.py”, line 13, in
File “autogen_explicit_imports.py”, line 13, in
File “ui/common/selective_sync.py”, line 6, in
File “arch/init.py”, line 28, in
File “arch/linux/tracing.py”, line 8, in
File “hard_trace.py”, line 6, in
File “client_api/connection_hub.py”, line 21, in
File “client_api/kv_connection.py”, line 23, in
File “pylinux/init.py”, line 71, in
File “cffi/api.py”, line 311, in verify
File “dropbox/overrides.py”, line 398, in load_library
File “cffi/verifier.py”, line 69, in load_library
File “cffi/verifier.py”, line 154, in _load_library
File “cffi/vengine_cpy.py”, line 124, in load_library
VerificationError: importing ‘/home/pooky2483/pylinux/pycache/_cffi__xa0c4f46bx1d95b4de.so’: No module named _cffi__xa0c4f46bx1d95b4de

what is returned if you run:

dropbox start -i

?

pooky2483@pooky2483-Kubuntu-1204-3:~$ dropbox start -i
The program ‘dropbox’ is currently not installed. You can install it by typing:
sudo apt-get install nautilus-dropbox
pooky2483@pooky2483-Kubuntu-1204-3:~$

OK let’s try another tack…

run:

sudo rm -rf /var/lib/dropbox/.dropbox-dist

don’t worry if that fails … just carry on below … then

rm -rf ~/.dropbox-dist

Now download the file below and install it.
http://linux.dropbox.com/ubuntu/pool/main/dropbox_1.6.1_amd64.deb
that doesn’t seem to have nautilus as adependency

Nautilus IS listed as a recommend … so you may want to check what’s going to be installed before proceeding


For others that may read this … 32bit version here:
http://linux.dropbox.com/ubuntu/pool/main/dropbox_1.6.1_i386.deb

32bit

That did it Mark :slight_smile:
Many Thanks.

:slight_smile: