[SOLVED] Set up dual boot of 14.04, now got a fault

pooky2483@pooky2483-14:~$ sudo apt-get install -f
[sudo] password for pooky2483:
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
1 not fully installed or removed.
Need to get 0 B/35.2 kB of archives.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package libasync-interrupt-perl (–configure):
package is in a very bad inconsistent state; you should
reinstall it before attempting configuration
E: Sub-process /usr/bin/dpkg returned an error code (1)
pooky2483@pooky2483-14:~$

Found a solution…

sudo apt-get --purge --reinstall install libasync-interrupt-perl