[SOLVED] Upgraded to VM SH2 with 150Mb BB and now getting speeds as low as 16Mb

I recently moved and had a SH2 installed and opted for the top tier speed of up to 152Mb. All was fine on the first day with speeds of 136-156Mb, but now I’m getting speeds as low as 16Mb.
Just spent 40 mins on the phone to VM to try and sort out the problem, all the readings for the speed and other settings are fine but as I’m not a slave to Window$, they cant run checks from my end.
Is there anything I can do to check things my end to see if there is any sort of problem!

That depends how you are measuring it.
Actually, 150Mbps is represented in bit and 16MBytes.
if you divide 150Mbit / 8 = 18.75 MByte
because 1Byte = 8bits
So your 16 MByte is not far off your max.
You could try to measure your avg. download speed with lftp

sudo apt-get install lftp

then download a fairly big dist.iso (syntax)

lftp -e 'pget http://something.com/distro.iso; exit; '

When finished it should give you the throughput and time it taken:
xxx bytes transferred in 75 seconds (11.47M/s)

I get;
pooky2483@pooky2483-Kubuntu-1204-3:~$ lftp -e 'pget http://something.com/distro.iso; exit; ’
pget: something.com: Name or service not known
pooky2483@pooky2483-Kubuntu-1204-3:~$

That is fully expected, that line provided you with the syntax, all you need is to replace the [b]http://something.com/distro.iso[/b] with a real url like: http://www.peppermintos.com/iso/Peppermint-5-20140623-amd64.iso

pooky2483@pooky2483-Kubuntu-1204-3:~$ lftp -e 'pget http://www.peppermintos.com/iso/Peppermint-5-20140623-amd64.iso; exit; ’
624953846 bytes transferred in 244 seconds (2.44M/s)
pooky2483@pooky2483-Kubuntu-1204-3:~$

Be aware, the Peppermint 5 ISO’s are currently not the best file(s) to use for download speed testing … it’s only just been released and the servers are getting a hammering, so it may be slow no matter what connection you have :wink:

Since you mentioned that Mark, I went to http://www.microsoft.com/en-us/download/confirmation.aspx?id=24 and downloaded XP SP3 Network Install, it downloaded at 2.7Meg - 3.2 and it shot up to 3.5 near the end for a little bit.

Just been looking at my download history for system updates in Kubuntu and just thought, I tried the speedtest in Ubuntu and got the same results - low speed, not as it was on 19th when we first had it installed (check the screenshot in a previous message).

Perhaps peppermint was a bad example, you could try Kubuntu 14.04 (1.0G), that should be stale enough but well supported.
Get it from a UK Mirror Service (University of Kent):
http://www.mirrorservice.org/sites/cdimage.ubuntu.com/cdimage/kubuntu/releases/14.04/release/kubuntu-14.04-desktop-amd64.iso

As is being suggested, having a super fast internet connection does NOT mean you’ll always get fast downloads … the limiting factor (bottleneck) could be at the other end, or anywhere in between.

Your broadband connection “speed”, as quoted by the ISP sales blurb, is a theoretical maximum and rarely achieved.

Do you have a seperate wireless router, or do you just have the superhub?
VM superhubs are known for being anything but super, Virgin will never admit it, but they are an embarressment to the company.

You’re gonna love this…
They installed the NEW SH2 and they said I don’t need my Netgear router after I said I would be using the SH2 in modem mode.
He said that I don’t need anything else as the SH2 is far superior and can block anything, I did ask if it can block specific sites/keywords like my Netgear can. What a load of b******, I can’t see anywhere in the SH2 settings where I can evter specific keywords or sites to block.
Then when it came to calling VM about the slow speeds, they said to remove the Netgear and to have the SH2 back in the standard mode as it was the Netgear causing the problems.Again, What a load of b******.

Once you call something “Super” and write it everywhere, it becomes a hard statement to back away from…

And this one is twice as “Super” … probably not that hard to achieve :wink:

VM aren’t very good with names

a) According to users it’s NOT “Super”
and
b) It’s a router and ethernet switch, not a “Hub”

I’ll give them the “2”

Fixed :wink:

And… I’m one of their ‘customers’ (have been since March 2009).
Being a customer who doesn’t use Window$, I’d rate their ‘customer service’ a 3 as they don’t cater for 'buntu users.

Downloading XPSP3;
Kubuntu 20 seconds to download 316Mb file
XP 1m44s to download 316Mb file
So, I don’t know why it’s showing slower DL speeds in Kubuntu!