Solved - Virtualbox problem in Ubuntu

I just updated Ubuntu, which included an Oracle virtualbox update.

Now, Virtualbox won’t open my most important VM . It just reports as follows…

Failed to open a session for the virtual machine XP.
The VM session was closed before any attempt to power it on.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {12f4dcdb-12b2-4ec1-b7cd-ddd9f6c5bf4d}

Some of the other VMs will start, run for a while, then abort.

No problem, I thought. I’ll just boot into XP and restore the Ubuntu partition from a Norton Ghost file. So I did. Guess what. Nothing changed. I tried it again, being extra careful about the boxes I checked, but with exactly the same result. It’s as though Ghost never ran.

Any ideas, anyone?

M

Try removing Virtualbox & reinstalling it, it sounds like a link somewhere hasn’t happened, or a config file hasn’t updated. Make sure you save your VM file elsewhere

or try:

sudo apt-get update

then

sudo apt-get upgrade

then

sudo apt-get dist-upgrade

then REBOOT <–IMPORTANT

Once rebooted run:

sudo apt-get install build-essential dkms module-assistant

then

sudo m-a prepare

then

sudo /etc/init.d/vboxdrv setup

Thanks both,

I haven’t tried your suggestions yet, because I may have solved the problem, with a bit of advice from Virtualbox.org. Looks like I upgraded the extension pack while those VMs were in a saved state, rather than shut down. Having discarded their saved states, they appear to be working. I’ll wait a couple of days before marking this solved though, just in case.

M

Great stuff :slight_smile:

Marking this solved now, as Virtualbox has been behaving beautifully for the last few days.

Thanks for the help folks.