[SOLVED] Wired connection problem

Since late Wednesday I have slowly lost Internet connection and this morning we had a visit from a Virgin engineer to come ant try to sort out the problem, we were told that it was an SNR problem.
I don’t have a clue what the engineer did but the wireless side of things was sorted but the wired side of things is fubar as it will not stay connected as about every 30 seconds it looses connection and tries to connect via wireless.
My wife’s laptop is connecting wirelessley ok.
I’m not sure but it have something to do with a recent update which may have something to do with samba? If not that, what?
Any ideas???

Why would it try to connect wirelessly … have you got a Wireless profile set up in NetworkManager ?

If so, have you tried removing it, or turning Wireless off ?

I have NO idea.
I have not got a wireless profile set up either.
Therefore I cant remove it or turn it off.

Virgin are bloody useless, Tech Support say they ONLY support Windows or Mac.
Linux has no support from Virgin as it has no Company that has a license like M$
So basically, anyone with Linux is on their own.

What option have I got regarding a wireless thingy I can plug into my PC to connect to my Virgin SuperHub

Why have you got a USB wireless adapter you wish to fit ? … or are you looking for suggestions for which one to get ?

What made you say it kept trying to connect wirelessly then ?


Can you post the output from:

sudo lshw -C network

and

ifconfig

and just in case it’s your network adapter failing … can you wait till it disconnects, then immediately run:

dmesg | tail -n 30

and post the output.

It may also help to use your log file viewer to look through your log files and look for clues as to what’s happening when it disconnects.

Pooky, do me a favour and log into

http://192.168.0.1

By default:

User: admin
Password: changeme

Then hit the advanced link ant the bottom.

Scroll to basic settings and post whatever is in there.

Then go to router status and post whatever is in there too.

Something tells me, he’s been messing with the SNR levels.

Would be interesting to know what he DID change (and why ?) … I would have thought that any settings that apply to Signal-to-Noise Ratio levels were liable to be confined to the WAN side of things, so would be unlikely to affect the LAN … and wouldn’t explain the wireless signal being unaffected.

But I have no experience with Virgin Cable 'Super’hub setup … so could be totally wrong.
(“Super” in inverted commas, cause I hear they’re not so “super” :wink: )

They really aren’t. Want to know the best thing about them?

The hubs themselves actually log activity and send it back to Virgin every 6 hours or so. People found this out, because when the tech guys started to SSH into their own hubs, within 5-6 minutes Virgin would lock them out.

It seems every ISP today just wants CONTROL over you. It’s sad, :frowning:

@Pooky - If it still carries on, phone up the cancellations department and say your going to leave if they don’t send you out a modem that isn’t the Superhub, but be polite and tell them your situation. Say you don’t want another engineer visit, but that specific router.

The only reason you’ll EVER need a Superhub is to deal with the 100+ broadband speeds, but even then, you can always go out and buy a “reliable” one that’s capable of handling gigabyte fibre broadband,

Sorry I’ve not replied for a while, been out shopping at Pets@Home for new Guinea Pig cages, been and got a new 2GB HD too ;D
Here’s the info you wanted BKS

Thinking about it and maybe yes

What made you say it kept trying to connect wirelessly then ?
Because it does, it drops wired mode and then tries wireless, finds its unable then connects wired for abt 30 seconds and then drops it again
Can you post the output from:
sudo lshw -C network

peter@Petes-ubuntu-pc:~$ sudo lshw -C network
[sudo] password for peter:
*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: 02
serial: 00:24:8c:bc:10:83
size: 1Gbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.0.2 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
resources: irq:42 ioport:d800(size=256) memory:f7fff000-f7ffffff memory:f7fe0000-f7feffff memory:fbef0000-fbefffff
peter@Petes-ubuntu-pc:~$

and
ifconfig

[spoiler]peter@Petes-ubuntu-pc:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:24:8c:bc:10:83
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::224:8cff:febc:1083/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:99469 errors:0 dropped:0 overruns:0 frame:0
TX packets:126396 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:36915361 (36.9 MB) TX bytes:17273100 (17.2 MB)
Interrupt:42 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:36890 errors:0 dropped:0 overruns:0 frame:0
TX packets:36890 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2012058 (2.0 MB) TX bytes:2012058 (2.0 MB)

peter@Petes-ubuntu-pc:~$ [/spoiler]

and just in case it's your network adapter failing .. can you wait till it disconnects, then immediately run:
dmesg | tail -n 30

and post the output.

It may also help to use your log file viewer to look through your log files and look for clues as to what’s happening when it disconnects.

peter@Petes-ubuntu-pc:~$ dmesg | tail -n 30
[17675.488043] eth0: no IPv6 routers present
[17698.816024] eth0: no IPv6 routers present
[17721.232025] eth0: no IPv6 routers present
[17744.288035] eth0: no IPv6 routers present
[17767.400028] eth0: no IPv6 routers present
[17790.536046] eth0: no IPv6 routers present
[17813.952040] eth0: no IPv6 routers present
[17837.008030] eth0: no IPv6 routers present
[17859.616034] eth0: no IPv6 routers present
[17882.832036] eth0: no IPv6 routers present
[17905.104024] eth0: no IPv6 routers present
[17928.048038] eth0: no IPv6 routers present
[17951.168037] eth0: no IPv6 routers present
[17974.672030] eth0: no IPv6 routers present
[17997.376036] eth0: no IPv6 routers present
[18020.688128] eth0: no IPv6 routers present
[18043.208030] eth0: no IPv6 routers present
[18066.096035] eth0: no IPv6 routers present
[18089.232024] eth0: no IPv6 routers present
[18112.296050] eth0: no IPv6 routers present
[18135.296025] eth0: no IPv6 routers present
[18158.960034] eth0: no IPv6 routers present
[18181.384035] eth0: no IPv6 routers present
[18204.952024] eth0: no IPv6 routers present
[18227.048042] eth0: no IPv6 routers present
[18250.240064] eth0: no IPv6 routers present
[18273.120028] eth0: no IPv6 routers present
[18296.624025] eth0: no IPv6 routers present
[18319.088029] eth0: no IPv6 routers present
[18342.696042] eth0: no IPv6 routers present
peter@Petes-ubuntu-pc:~$

Try setting IPv6 to “Ignore” in your wired profile in NetworkManager.

If you’re not sure how … just ask.

Thanks Mark, it’s sorted it, came back on after a reboot, stable so far.
Looks like I will be writing a nice juicy letter to Virgin Complaints about this.