Some newbie questions....

Hi. I registered with this site a few days ago, and made a post, but it hasn’t appeared - so I’m trying again.
My old laptop (WinXP) was falling apart, so I went out and bought a new one (HP) which came with Win10 pre-installed. My experience with it so far has convinced me that the time has come for me to part company with MS so far as I can.
I wimped out on downloading distros and burning my own CD’s so bought a ‘Windows migration pack’ which gives me CDs for Zorin OS 11, Puppy Linux 5.2.8, Lubuntu 16.04, PCLInuxOS 2014.12 and Mint 17.3 XFCE, all 32 bit.
At the moment I’m trying to prepare the laptop for a dual boot installation. What I have done so far is:
In Win10 - disabled fast startup and shrunk the Windows partition by 200GB (it’s a 1 TB drive)
In BIOS (EUFI) - disabled secure boot, changed boot order to prioritise CD, and enabled Legacy Mode (CSM).
So my question is - am I good to go with with the installation now? I do need to preserve Windows for a while at least while I figure out how to transfer the functionality I need to Linux.
TIA for any advice, Robin

Hi chaoticbob, and welcome to the forum.

Well you could install Linux now, but I’d STRONGLY advise you use a 64bit distro

why ?

Well switching to legacy BIOS mode will not allow Windows to boot (as it was installed in UEFI mode), so every time you want to switch OS you’re going to need to change back to UEFI/Legacy.

We can help you download and create a 64bit LiveUSB if you wish ?

Thanks for the welcome and advice Mark. The reasons I went for 32-bit distros were that I’d read somewhere that there were stability issues with some 64-bit versions, and that I would be more likely to find 32-bit drivers for my hardware. It may well be that this info is outdated - there’s a lot of Linux info out there, but it’s often inconsistent and/or confusing - hence my posting here. I particularly need wifi networking - the new laptop has a Realtek RTL8723BE wireless chipset.
When I changed the EUFI to Legacy BIOS support, I did get a warning that Windows might not boot. It did come up though, after a looong time, but on subsequent boots it seems to take no longer than it ever did, so I assumed that W10 had somehow adapted itself to the change.
Thanks for you offer to help me make a bootable USB. I picked up a 64GB stick today - if you could walk me through the process that would be great. I’m really looking forward to getting back to an OS which puts me in charge - though new to Linux on PC architecture I used Unix almost exclusively during my working life.
Regards, Rob.

The whole “64bit is less stable” and “64bit may have driver/software issues” is l-o-n-g behind Linux … in fact most distros are dropping 32bit soon, and out of the 2, 64bit is now the better supported architecture so less likely to give you problems than 32bit.

rtl8723be will be supported out of the box in any modern distro 32bit or 64bit without you needing to install anything … but it may keep dropping the connection to your router, this entails an easy fix, you just open a terminal and run:

sudo gedit /etc/modprobe.d/rtl8723be.conf

and when a BLANK file opens, make it read

options rtl8723be fwlps=0 ips=0

SAVE the file, and reboot.

If you choose Peppermint 7 you won’t even need to do that, I already added this fix out of the box … but if you choose any other Ubuntu based distro it’s an easy fix (as above).

Thanks again Mark. I had a look at peppermintos.com and it looks like Peppermint is just what I’m after - I like the ‘less is more’ principle. I’ll download the 64 bit iso overnight - might need some guidance as what to do with it though!
Regards, Robin.

No problem my mate :slight_smile:

OK, I now have the Peppermint 7 64 bit iso. Couple more questions. I had look at the LiLi LiveUSB creator , but the site says it supports Peppermint only up to OS 4, and also it seems to want to install a file format converter as well - which makes me wary. In the past when I’ve downloaded utilities which bundle something else with what I want, the results have not been happy. Can you recommend anything?
Second, should I reverse remove the Legacy support in UEFI before proceeding?
Regards, Robin.

If the USB stick is only going to be used as an installation media, I’d suggest (in Windows) you use Rufus to create the LiveUSB
https://rufus.akeo.ie/

In your UEFI BIOS, I’d disable Legacy mode, but also leave “secureboot” disbled

You can leave secureboot enabled if you like, but if you do, don’t tick the box the get updates and third party software during the Peppermint installation.

A further question I’m afraid - the Peppermint distro I downloaded (didn’t get any choice of chipset) is peppermint-7-20160616-amd64.iso. Is this going to be OK on my Intel system? Sorry if I’m being overcautious here, just don’t want break Windows at this point and don’t understand how all this works well enough to make an educated decision myself.
Rufus did find a 64-bit Mint Cinnamon iso which I’d downloaded earlier, so I put that on the USB - it boots / runs faster off the USB stick than Windows does off the HD! But I’d still prefer Peppermint I think.
Regards, Robin

Yes it is the correct Peppermint version and will be fine on both AMD and Intel 64bit CPU’s :wink:

It’s only designated amd64 because AMD came up with the 64bit extension to the x86 architecture that’s in mainstream use today … Intels original idea was to have a completely different architecture (IA-64) but have long since adopted the AMD x86 extension for mainstream CPU’s

.

Thanks for the explanation Mark. Peppermint 7 now installed on HD. I still have to get the BIOS up to boot into P7 (I don’t get the grub loader), but that’s a minor issue at the mo. More important is that I haven’t yet succeeded in getting a wireless internet connection. Peppermint tells me on boot that wi-fi networks are available and advises me to ‘Use the network menu to connect to to a wi-fi network’. I found a network menu under Preferences, put in my SSID and was told I was connected. But not so - Firefox can’t resolve addresses.

Megathanks for walking me through the installation so far - if I can get this last stage done I’ll be out of your hair. For a bit :wink:
I know the MAC address of the router and its default DNS server IP addresses if that’s relevant.
Regards Robin

If you look down by the clock (bottom right of screen) you should see the networkmanager icon in the system tray.

Click it, and a list of detected wireless networks will be displayed.

Click YOUR wireless network, and you should be prompted for your wireless key

enter your key, and click “Connect”

Done :slight_smile:

Pretty much the same as Windows eh :wink:


If you’re still having problems, you may need to right-click the networkmanager icon, then select “Edit Connections” … now highlight any profiles you created and click the “Delete” button.

Now close networkmanager and use the instructions above to add your connection.

Hi again Mark, Completely missed the Windows- like icon at the the bottom RHS :-[ Different context, wasn’t expecting it.
It turned out slightly more fiddly than you suggested - after deleting everything from the list of networks I’d tried to set up, Peppermint found the SSID for my router, but failed to connect. But when I edited the connection and entered the same values as PM had defaulted to it just worked! No idea why but I’m happy for now!
Rob.

Great stuff Rob, lemme know if/when you want to install stuff if you can’t figure it out, or any problems.

‘lemme know if/when you want to install stuff if you can’t figure it out, or any problems.’

I surely shall! I owe you Terathanks for getting me this far, I’ve made half-hearted attempts to get Linux going on my home PC before, but have always stumbled on getting wireless going. Much still to do, but I’m hoping I’ll soon be able to dispense with Windows altogether.
Next thing is getting my phone talking to the laptop - but that’s for another thread!
Regards, Rob

You’re welcome Rob :slight_smile:

Well, I was happy to get a wireless connection at all - but when I try to use Peppermint in ‘real life’ internet access is so slow and flakey I go back to Windows, which is obviously what I don’t want to do. I think this must be an issue with the P7 driver for my chipset, as W10 gives me acceptable speeds and stability with the same hardware.
So where to go? Should I tinker with the .conf file or just get a USB 3 wireless stick which is known to work?
Rob.

Can you open a terminal (Ctrl+Alt+T) and post the output from these commands:

inxi -F

and

iwlist scan

and

iwconfig

and remember, Linux commands ARE case sensitive, so that’s a capital “F” in the first command.