Sound issue in Game Fantastic Farm revised for mint 17 (Solved)

Hi All,

When I was using a 32bit system this was fixed by doing the following.

My wife decided that she want to play this game again.

I am now using a mint 13 64bit system and there is no sound in the game even when applying the fix that worked in the past.

Any suggestions.

Run:

sudo updatedb

then what’s the output from

dpkg -l | grep pulse

and just in case … can you post a link to where I can download the game.

userone@office2 ~ $ dpkg -l | grep pulse
ii gstreamer0.10-pulseaudio 0.10.31-1ubuntu1.2 GStreamer plugin for PulseAudio
ii libcanberra-pulse 0.28-3ubuntu3 PulseAudio backend for libcanberra
ii libpulse-mainloop-glib0 1:1.1-0ubuntu15.3 PulseAudio client libraries (glib support)
rc libpulse-mainloop-glib0:i386 1:1.1-0ubuntu15.1 PulseAudio client libraries (glib support)
ii libpulse0 1:1.1-0ubuntu15.3 PulseAudio client libraries
ii libpulse0:i386 1:1.1-0ubuntu15.3 PulseAudio client libraries
ii libpulsedsp 1:1.1-0ubuntu15.3 PulseAudio OSS pre-load library
ii mate-media-pulse 1.2.1-5+precise MATE media utilities (PulseAudio backend)
ii mate-settings-daemon-pulse 1.2.0-4+precise daemon handling the MATE session settings (PulseAudio version)
ii pulseaudio 1:1.1-0ubuntu15.3 PulseAudio sound server
ii pulseaudio-module-bluetooth 1:1.1-0ubuntu15.3 Bluetooth module for PulseAudio sound server
ii pulseaudio-module-gconf 1:1.1-0ubuntu15.3 GConf module for PulseAudio sound server
ii pulseaudio-module-x11 1:1.1-0ubuntu15.3 X11 module for PulseAudio sound server
ii pulseaudio-utils 1:1.1-0ubuntu15.3 Command line tools for the PulseAudio sound server
ii vlc-plugin-pulse 2.0.8-0ubuntu0.12.04.1 PulseAudio plugin for VLC
rc wine1.5-amd64 1.5.6-0ubuntu1~pulse17 Microsoft Windows Compatibility Layer (64-bit support)
rc wine1.5-i386:i386 1.5.6-0ubuntu1~pulse17 Microsoft Windows Compatibility Layer (32-bit support)
userone@office2 ~ $

Link to game Fantastic Farm for iPhone, iPad, Android - Kristanix Games

My present command line reads padsp “/home/userone/fantasticfarm/Fantastic Farm”

Thanks as always.

Hmm …

padsp "/home/userone/fantasticfarm/Fantastic Farm" 

works for me in Peppermint 4

do you hear any audio when you run both:

aplay /usr/share/sounds/alsa/Front_Center.wav

and

padsp aplay /usr/share/sounds/alsa/Front_Center.wav

You could try resetting pulseaudio to defaults by renaming the pulseaudio config directory:

mv -v ~/.config/pulse ~/.config/pulse-old

if the above fails … the pulse config directory may be in the old position … so try:

mv -v ~/.pulse ~/.pulse-old

then

mv -v ~/.pulse-cookie ~/.pulse-cookie-old

Now in either case … log OFF/ON again (or reboot) … pulseaudio’s config files/directory will get automagically recreated with the default settings.

Hi guys

hope you don’t mind me hijacking this thread I just want to ask a quick question regarding pulseaudio, my Grand-Daughters sound doesn’t work at all and it hasn’t worked since upgrading to PM4 would it be worth my while trying to reset pulseaudio to defaults as per Marks instructions in the last post, if not I’ll open a new thread

This is the commands I mean

You could try resetting pulseaudio to defaults by renaming the pulseaudio config directory: Code: [Select] mv -v ~/.config/pulse ~/.config/pulse-old

if the above fails … the pulse config directory may be in the old position … so try:
Code: [Select]
mv -v ~/.pulse ~/.pulse-old
then
Code: [Select]
mv -v ~/.pulse-cookie ~/.pulse-cookie-old

@Tramlink

Sorry for hijacking your post hope you don’t mind

Many thanks

Graeme

@Emegra

Probably best to open a new topic … you may not teven have pulseaudio installed, Peppermint doesn’t use it by default :slight_smile:

Hi I get the following error message.

ERROR: ld.so: object ‘libpulsedsp.so’ from LD_PRELOAD cannot be preloaded: ignored.
But the games still runs but with no sound.

By the way is your peppermint 4 a 64bit system, just asking.

No, I tested it in Peppermint 4 32bit … but can test it in 64bit if you like ?

Looking for a solution now.

The fix worked in an Earlier version of Ubuntu 32bit system but that fix is not working in mint 13 64bit.

Try this:-
(this will download the 32bit libpulsedsp.so file for Ubuntu 12.04, unpack it to your game directory, and preload it before running the game)

Open a terminal and run

cd /home/userone/fantasticfarm

then

wget https://dl.dropboxusercontent.com/u/11876059/libpulsedsp.so.tar.gz

then

tar -xvf libpulsedsp.so.tar.gz

Now see if it will run (with sound) with this command

bash -c "LD_PRELOAD=/home/userone/fantasticfarm/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

If that DOESN’T work, what was output ?


If that DOES work … modify the games .desktop file (launcher) so the “Exec=” line reads:

Exec=bash -c "LD_PRELOAD=/home/userone/fantasticfarm/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

Hi it works fine thanks for your help.

No problem :slight_smile:

Is sound working in the game now, and if so was it the above fix that worked ?

It is Yes and Yes.

Cheers :slight_smile:

Hi The sound issue is back now that I have upgraded to mint 17 64bit. Below is the fix for mint 13 64bit

but it is not working for mint 17…

Any help welcome.

That’s probably an old version of libpulsedsp.so … but if you have libpulsedsp installed you should already have it somewhere on your system

Run:

sudo apt-get install libpulsedsp

then

sudo updatedb

then post the output from

locate libpulsedsp.so

userone@Office2 ~ $ locate libpulsedsp.so
/home/userone/libpulsedsp.so
/home/userone/libpulsedsp.so.tar.gz
/home/userone/.local/share/Trash/files/libpulsedsp.so
/home/userone/.local/share/Trash/files/libpulsedsp.so.tar.gz
/home/userone/.local/share/Trash/info/libpulsedsp.so.tar.gz.trashinfo
/home/userone/.local/share/Trash/info/libpulsedsp.so.trashinfo
/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so
/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so
userone@Office2 ~ $

OK, try either

Exec=bash -c "LD_PRELOAD=/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

or

Exec=bash -c "LD_PRELOAD=/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

That’s assuming the path to Fantastic Farm is still /home/userone/fantasticfarm/'Fantastic Farm

They did not work and I got the following message for both.

-c: command not found

This computer has a AMD CPU.

you’re not entering those (still with the “Exec=”) at the command line are you ?

The “Exec=” part is only for the .desktop launcher.


do either of these work from the command line:

bash -c "LD_PRELOAD=/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

or

bash -c "LD_PRELOAD=/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so /home/userone/fantasticfarm/'Fantastic Farm'"

?