Sound issue in Game Fantastic Farm (solved)

Trying to get my wife hooked on Linux, she likes this game but there is no sound.

Asked the Game makers and they told me that the game uses openAL sound I have installed the openAL configuration Utility but changing the setting has made no difference.

This is the readout for my sound and video installed on the system:

*-multimedia UNCLAIMED
description: Audio device
product: RV635 Audio device [Radeon HD 3600 Series]
vendor: ATI Technologies Inc
physical id: 0.1
bus info: pci@0000:01:00.1
version: 00
width: 32 bits
clock: 66MHz
capabilities: pm cap_list
configuration: latency=0 mingnt=8
resources: memory:fea00000-fea03fff
*-multimedia
description: Multimedia audio controller
product: CM8738
vendor: C-Media Electronics Inc
physical id: 6
bus info: pci@0000:02:06.0
version: 10
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: driver=C-Media PCI latency=32 maxlatency=24 mingnt=2
resources: irq:19 ioport:e800(size=256)
userone@office2:~$

Sound is working in other programs on the computer any thoughts. :slight_smile:

It appears you have 2 sound devices, one of which is HD, and has no driver associated with it.

Does sound work at all on this PC ?

If this is a laptop, can we have the make/model ?

If this isn’t a laptop, how many jack plug sockets are on the soundcard ?

Also the output from these 3 commands

cat /proc/asound/card0/codec#* | grep Codec

aplay -l

lsmod | grep snd

Thanks for response, Sound is working can play mp3 files, CDs and music via Internet.

It is a desktop Pc and I am using a pci sound card CM8738 it has 4 jack plug sockets.

The information at the top Radeon HD 3600 Series is I believe my video card I know it is not the on-board sound card as it is disabled in the bios .

Results of the information you requested:

cat: /proc/asound/card0/codec#*: No such file or directory

cat /proc/asound/card0/codec#* | grep Codec

lsmod | grep snd
snd_hda_intel 24140 0
snd_cmipci 35330 1
gameport 15027 1 snd_cmipci
snd_hda_codec 90901 1 snd_hda_intel
snd_pcm 80244 3 snd_hda_intel,snd_cmipci,snd_hda_codec
snd_opl3_lib 18760 1 snd_cmipci
snd_hwdep 13274 2 snd_hda_codec,snd_opl3_lib
snd_mpu401_uart 13865 1 snd_cmipci
snd_seq_midi 13132 0
snd_rawmidi 25269 2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28659 3 snd_pcm,snd_opl3_lib,snd_seq
snd_seq_device 14110 4 snd_opl3_lib,snd_seq_midi,snd_rawmidi,snd_seq
snd 55295 13 snd_hda_intel,snd_cmipci,snd_hda_codec,snd_pcm,snd_opl3_lib,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 12600 1 snd
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
userone@office2:~$

cat: /proc/asound/card0/codec#*: No such file or directory
userone@office2:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CMI8738 [C-Media CMI8738], device 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 2: CMI8738-MC6 [C-Media PCI IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0

Thanks.

have you got a link to this game ?

Is it a Windows game ?

[EDIT]

I’ve just downloaded the Linux version (demo) and I get no sound either, so it’s NOT your audio setup… I’ll see what (if anything) I can come up with.

Game is the Linux version that you downloaded.

This is the info I got from the game maker:

Most likely there is some kind of sound library missing that Fantastic
Farm is looking for. I’m not that experienced with Linux, but Fantastic
Farm uses OpenAL, so you might have to put those kind of libraries next
to the game. It’s been some time since I’ve some investigation on this
on Linux, so you might have to use some command line to find out what
exact library it’s looking for…

Is it possible to find out if OpenAL is running on my system?

Easiest fix is to just add padsp at the beginning of the command line that launches the game… this will force the game to use pulse audio.

So if you have a desktop Launcher (shortcut) called “Fantastic Farm”, right-click on it, select Properties

Then change the Command: line from:

Command: “/home/username/fantasticfarm/Fantastic Farm”

to

Command: padsp “/home/username/fantasticfarm/Fantastic Farm”

(don’t forget the space after padsp… and change the username part)

Click Close

Now start the game from that launcher.

Yes it worked like a dream, many thanks for your help.