Sound problem on Dell Laptop

Hi All!

I’ve been gifted a Dell Latitude D520 which had XP Pro on it - now removed and replaced with Zorin O/S. All seems ok with the installation except I can’t get sound from the onboard speakers. Plugging in external speakers works ok - I don’t have headphones available to test but assume they would work, as the jack socket is ‘live’.

Looking online, there seems to have been sound issues with this particular model of lappy right from the off. :frowning: I’ve tried a few things but nothing will restore sound. Any ideas?

Thanks, as ever


What’s the output from:

sudo lshw -C multimedia


aplay -l

Hi Mark - thanks for the response.

output as requested -

[color=black]~$ sudo lshw -C multimedia
[sudo] password for richard:
description: Audio device
product: NM10/ICH7 Family High Definition Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:43 memory:efebc000-efebffff
richard@richard-Latitude-D520:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
Subdevices: 1/1
Subdevice #0 subdevice #0


Try this…

Open a terminal and run:

sudo gedit /etc/modprobe.d/alsa-base.conf

add a NEW LINE at the bottom that reads

options snd-hda-intel model=gateway-m4

SAVE the file.

Reboot to test.

Done as advised but still no sound. I’ve installed pulseaudio and alsamixer but no joy.

Going to Sound/Sound Settings/Hardware/Test Speakers gives me the smiley face and each speaker symbol changes colour when clicked but no sound output! ???


Update: I now have no sound at all! I removed pulseaudio and alsamixer to try to revert to the default settings but must have removed too much! How do I get back to default, please?


have a look in:

gedit /var/log/apt/history.log

scroll to the bottom and there should be a list of what you removed … reinstall it

Ok! I’ve reinstated the sound to the external speakers but still nothing to the onboard. Will keep trying… ;D



Try changing the line we added earlier to

options snd-hda-intel model=gateway

and don’t forget to reboot before testing.

Done! No change… :frowning:

OK, remove that line … save the file … reboot.

Make sure pulseaudio is installed:

sudo apt-get install pulseaudio pulseaudio-utils pavucontrol

Find PulseAudio Volume Control in the menu … and make sure the correct audio device is selected in the Output Device tab.

Ok, done - but still the same…

It looks now like this is a hardware problem rather than software. The Pulseaudio control shows audio is configured correctly and the volume control output Alsa plugin bar is moving with radio broadcast. This does not change when the external speaker plug is removed - i.e. the bar still moves but no sound from the onboard speakers.

Searching this model on the Web (Dell Latitude D520), there are hundreds of posts in the same vein, with as many solutions! A strong candidate is the headphone socket which has an internal switch that toggles between onboard speakers and headphones when the plug is removed. This switch may become stuck, which has resulted in Dell replacing part or all of the motherboard in the past. Erm… I think this one might be out of warranty!! ;D

Worst-case scenario is I buy a set of lappy headphones, otherwise I plug in to my PC screen jack and use the in-built speakers there. Rather defeats the object though… ::slight_smile:

I’m half-way there, so to speak, so many thanks for your advice thus far… I’ll keep trying and post the outcome if I ever get that far!


Just a thought - would there be a way of disabling said switch? I’d have no probs with losing the headphone facility if the onboards were working…

If you open a terminal and run:


then hit F3 to display only playback.

Isd there anything in there relating to “headphones” ? … or anything muted ?

Alsamixer looks ok to me - nothing related to headphones.

F3 shows Master at 100, PCM at 100 (but no box at the bottom where it can be muted/unmuted), then S/PDIF and S/PDIF Default PCM both at 00, but with no upper slider. Mute/Unmute on Master channel works properly.