Static IP issues (solved)

I have had the same static ip for years now on the pc and everything else is also set to static (both x boxes, both play stations and server (wd cloud)).
Recently I have moved from sky broadband to sky fibre (won’t actually be on fibre till 10/2/15) but got the new sky hub last week. Plugged it in and everything worked fine once connected.
This morning I turned the pc on and it wouldn’t connect to the internet. It can be seen in the router settings but it can’t connect to the internet. I tried making a new connection with a static ip but got the the same results. Made another with dhcp and it worked, but when I ignored ipv 6 it stopped working, change this back to automatic and it worked again.
I have no idea why it stopped working in the first place, everything else still works.
I have reduced the dhcp pool so 192.168.0.201 to 198.162.254 is free for static ip’s.
I can’t remember why now but there was a good reason I was on a static ip ( think it was something to do with plex) and would like to return to it if possible.
Any help or advice would be appreciated.
Thanx for reading.

Edit
Just set up a static wireless connection with all the same info as the original connection and it worked

I take it you tried simply restarting the router ?

What’s the IP address of the new router ? … same as the old one ?

can you ping:

ping -c 5 216.58.210.14

?

Restarted the router, restarted the pc, also see edit above.

Yes, gateway is still 198.162.0.1

LinuBox ~ $ ping -c 5 216.58.210.14
PING 216.58.210.14 (216.58.210.14) 56(84) bytes of data.
64 bytes from 216.58.210.14: icmp_seq=1 ttl=58 time=49.9 ms
64 bytes from 216.58.210.14: icmp_seq=2 ttl=58 time=50.0 ms
64 bytes from 216.58.210.14: icmp_seq=3 ttl=58 time=51.5 ms
64 bytes from 216.58.210.14: icmp_seq=4 ttl=58 time=47.3 ms
64 bytes from 216.58.210.14: icmp_seq=5 ttl=58 time=50.4 ms

--- 216.58.210.14 ping statistics ---

Fast reply btw
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 47.315/49.885/51.590/1.415 ms

Fast reply btw

Werre you able to connect to the interweb ?

ping suggests you can, so if you’re not able to get internet pages, it’s likely a DNS settings issue

Ah, sorry that ping was from the working wireless connection, hold on

~ $ ping -c 5 216.58.210.14
PING 216.58.210.14 (216.58.210.14) 56(84) bytes of data.
64 bytes from 216.58.210.14: icmp_seq=1 ttl=58 time=46.5 ms
64 bytes from 216.58.210.14: icmp_seq=2 ttl=58 time=47.0 ms
64 bytes from 216.58.210.14: icmp_seq=3 ttl=58 time=46.7 ms
64 bytes from 216.58.210.14: icmp_seq=4 ttl=58 time=46.2 ms
64 bytes from 216.58.210.14: icmp_seq=5 ttl=58 time=45.8 ms

--- 216.58.210.14 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4004ms
rtt min/avg/max/mdev = 45.820/46.474/47.002/0.476 ms

That’s from a non working wired connection (static ip that used to work)

This one is from a wired connection but dhcp with ipv6 ignored on automatic

~ $ ping -c 5 216.58.210.14
PING 216.58.210.14 (216.58.210.14) 56(84) bytes of data.
64 bytes from 216.58.210.14: icmp_seq=1 ttl=58 time=46.6 ms
64 bytes from 216.58.210.14: icmp_seq=2 ttl=58 time=46.8 ms
64 bytes from 216.58.210.14: icmp_seq=3 ttl=58 time=46.0 ms
64 bytes from 216.58.210.14: icmp_seq=4 ttl=58 time=46.7 ms
64 bytes from 216.58.210.14: icmp_seq=5 ttl=58 time=45.7 ms

--- 216.58.210.14 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 45.773/46.407/46.834/0.428 ms

This also connects to the internet
If necessary I can leave it static on wireless but seeing as how I have a fast network (wired) I’d rather not slow down transfers with a slow network card.

You’re confusing the heck outa me here

The top ping output suggest it CAN access the internet (as pings to the google servers are returned)

am I right in thinking that if you go here in your web browser:
http://216.58.210.14/
it works … but it you go here:
http://google.co.uk
it doesn’t ?

Gotta go to work, I’ll get back on this tonight add there needs to be some clarity from me on this

Oey dokey … catch ya later :slight_smile:

First of all, thanx for taking the time to help with this.
I think I have gotten to the bottom of this.
Originally I didn’t have/need anything in the DNS field and it worked fine
but for some reason it worked ok when I installed the new router (sky hub) then stopped working.
After some deductive reasoning and a few experiments it seems that you need to have your gateway address in the DNS field if you are using a sky hub and want a static IP.

Yup … I always set the routers IP as the DNS server :wink:

other options would be to set the openDNS servers or the Google DNS servers … but they wouldn’t give you name resolution on your LOCAL network too (as the routers can).