stating no internet when loging in to steam on Linux POP OS.

Hi Guys, any chance some one might help me out . I am finally taking the plunge and ditching Windows 10 and moving to Linux. I downloaded and installed Pop OS Linux Distro today. It was going on a clean Hard drive. No problem with the system install. The problem came when I tried to open and log into Steam. I went into the PoP Shop and when I clicked to open Steam it said it was not connected to the internet. I was connected as I was using the browser . I tried using support .system76.com. I typed in sudo apt install steam. All went well until I clicked on the steam icon in Pop shop. I was hoping to get to " enable steam play ( Proton ). It would not allow me to connect to the net. Please bare with with me as this is my first time to actually go all out to to change my system over from Windows. At 76, I am not the best in remembering things. I will give it a go anyway. If no help is available, no problem, thanks anyway.
All the best.

Hello Luckyjfl - and welcome to the Forum.

Pop has not appeared here before and I am not familiar with it - and I am guessing that few of our Members are.

You say:
“The problem came when I tried to open and log into Steam.” So does Steam come pre-installed? I ask because you mention later I typed in sudo apt install steam."

If you perform an internet search by going to Linux pop steam cannot connect to internet at DuckDuckGo you will find very many questions (and some answers) about difficulty with Steam connecting to the internet, so it looks like a common problem.

In the meantime, you might try:

steam --reset

Good luck!
Keith