stevehicksons voice command

hey guys, been trying to run steve hicksons voice command program on ubuntu and im getting the error,
voicecommand: error while loading shared libraries: libboost_regex.so.1.46.1: cannot open shared object file: No such file or directory
now iv tried installing the older libraries but they dont exist on ‘apt-cache search’
any ideas?
just FYI, im a n00b on linux haha so dumb it down if possible please :slight_smile:

oh also i think the boost library is up to 1.55 or something :slight_smile:

Which version of Ubuntu are you running ? … and is it 32bit or 64bit ?

Ubuntu 14.04 LTS 64bit
thanks :slight_smile:

Also, i know its designed for a raspberry pi, i dont have the peripherals to use it on there hence the need for the good old dual boot lappy :slight_smile: he does state somewhere that he thinks it is compatable with mainstream linux distros…?

OK, as I see it you have 2 options

a) try the version from Precise (12.04) from here:
http://packages.ubuntu.com/uk/precise/libboost-regex1.46.1
direct download of the 64bit version here:
http://cz.archive.ubuntu.com/ubuntu/pool/main/b/boost1.46/libboost-regex1.46.1_1.46.1-7ubuntu3_amd64.deb

or

b) install the libboost-regex1.55.0 package in Trusty (14.04):

sudo apt-get install libboost-regex1.55.0

then create a symlink called libboost_regex.so.1.46.1 that points at libboost_regex.so.1.55.0 with:

ln -s /usr/lib/x86_64-linux-gnu/libboost_regex.so.1.55.0 /usr/lib/x86_64-linux-gnu/libboost_regex.so.1.46.1

and cross your fingers :wink:

we are in business, via the symbolic link :slight_smile: thankyou soooo much lol

You’re welcome. :slight_smile: